View Issue Details

IDProjectCategoryView StatusLast Update
12767Bug reports[All Projects] Survey designpublic2017-10-25 11:12
ReporterolleAssigned Toolle 
PrioritynoneSeveritymajor 
Status closedResolutionreopened 
Product Version3.0.0-beta.x 
Target Version3.xFixed in Version3.0.0-beta.x 
Summary12767: Saving presentation survey settings resets survey languages
DescriptionTitle.
Steps To Reproduce1. Add language to survey
2. Go to presentation
3. Save
4. Go back to general settings.
5. Languages are gone.
TagsNo tags attached.
Complete LimeSurvey version number (& build)latest dev
I will donate to the project if issue is resolvedNo
Browser-
Database & DB-Version-
Operating System (Server)-
Webserver software & version-
PHP Version-

Activities

markusfluer

markusfluer

2017-10-12 16:39

developer   ~44622

Fix committed to develop branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=24087
olle

olle

2017-10-13 10:25

administrator   ~44644

Not fixed, because now it's not possible to remove languages.

1. Add language
2. Save
3. Remove language
4. Save
5. Language is still there.
olle

olle

2017-10-13 12:07

administrator   ~44645

Fix committed to develop branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=24097
c_schmitz

c_schmitz

2017-10-25 11:12

administrator   ~44831

3.0.0-RC1 Build 171025 released

Related Changesets

LimeSurvey: develop 87677a9f

2017-10-12 16:39:33

markusfluer

Details Diff
Fixed issue 12767: Saving presentation survey settings resets survey languages
mod - application/controllers/admin/database.php Diff File

LimeSurvey: develop cd83bb76

2017-10-13 12:07:02

olle

Details Diff
Fixed issue 12767: Saving presentation survey settings resets survey languages
mod - application/controllers/admin/database.php Diff File
mod - application/helpers/update/updatedb_helper.php Diff File
mod - application/views/admin/survey/subview/accordion/_generaloptions_panel.php Diff File

Issue History

Date Modified Username Field Change
2017-10-11 15:51 olle New Issue
2017-10-12 16:39 markusfluer Changeset attached => LimeSurvey develop 87677a9f
2017-10-12 16:39 markusfluer Note Added: 44622
2017-10-12 16:39 markusfluer Assigned To => markusfluer
2017-10-12 16:39 markusfluer Resolution open => fixed
2017-10-12 16:47 markusfluer Status new => resolved
2017-10-12 16:47 markusfluer Fixed in Version => 3.0.0-beta.x
2017-10-13 10:25 olle Note Added: 44644
2017-10-13 10:26 olle Status resolved => new
2017-10-13 10:26 olle Resolution fixed => reopened
2017-10-13 10:28 olle Assigned To markusfluer =>
2017-10-13 12:07 olle Changeset attached => LimeSurvey develop cd83bb76
2017-10-13 12:07 olle Note Added: 44645
2017-10-13 14:47 olle Assigned To => olle
2017-10-13 14:47 olle Status new => resolved
2017-10-25 11:12 c_schmitz Note Added: 44831
2017-10-25 11:12 c_schmitz Status resolved => closed