View Issue Details

IDProjectCategoryView StatusLast Update
12365Bug reports[All Projects] Conditionspublic2018-04-06 11:47
ReporterChacoKevyAssigned Tomarkusfluer 
PriorityurgentSeverityminor 
Status closedResolutionfixed 
Product Version2.64.x 
Target VersionFixed in Version3.6.x 
Summary12365: Using relevance equation on multiple choice sub-questions removes "Other" selection
Description

Survey attached created in Lime's online Demo (2.64.0). When I remove the relevance equations from the sub-questions, only then does the "Other" option appears as viewable.

From Forums, Jelo's comment:
This is a bug. When there is subquestion with a relevance of 1 at the beginning the other field is not displayed. That is only happening when the subquestion relevance source is in the same group (which converts into 0 for every subquestion when the second question is rendered).

If you place your two questions in different groups you will not get this issue.

Steps To Reproduce

The survey attached shows the error already. The second question does not display the "other" option. Removing sub-question equations will display the option again.

TagsNo tags attached.
Complete LimeSurvey version number (& build)2.64.0
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionLime online demo
Server OS (if known)Lime online demo
Webserver software & version (if known)Lime online demo
PHP VersionLime online demo

Activities

ChacoKevy

ChacoKevy

2017-05-01 16:28

reporter  

limesurvey_survey_372374.lss (17,039 bytes)
markusfluer

markusfluer

2018-04-05 15:01

administrator   ~47346

This seems to be fixed in 3.X

Issue History

Date Modified Username Field Change
2017-05-01 16:28 ChacoKevy New Issue
2017-05-01 16:28 ChacoKevy File Added: limesurvey_survey_372374.lss
2017-05-03 17:56 LouisGac Priority none => urgent
2018-04-05 15:01 markusfluer Assigned To => markusfluer
2018-04-05 15:01 markusfluer Status new => resolved
2018-04-05 15:01 markusfluer Resolution open => fixed
2018-04-05 15:01 markusfluer Fixed in Version => 3.6.x
2018-04-05 15:01 markusfluer Note Added: 47346
2018-04-06 11:47 markusfluer Status resolved => closed