View Issue Details

IDProjectCategoryView StatusLast Update
12359Bug reports[All Projects] Survey designpublic2018-01-12 15:59
ReporterUllrichAssigned Toolle 
PriorityurgentSeveritymajor 
Status closedResolutionfixed 
Product Version2.64.x 
Target VersionFixed in Version 
Summary12359: Quick add does not work
DescriptionWhen using "Quick add" on question type List (radio) for example, the list is not added to the answer list.
Instead new emtpy items are created in a broken layout.
Steps To ReproduceCreate a new question of type List (radio)

Try to add answers with using "Quick add" option
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 2.64.7+170404
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Version10.1.22-MariaDB
Operating System (Server)Ubuntu 16.04
Webserver software & versionApache 2.4
PHP Version7.0

Activities

Ullrich

Ullrich

2017-04-28 12:41

reporter  

lime2.jpg (48,335 bytes)
lime2.jpg (48,335 bytes)
lime1.jpg (60,957 bytes)
lime1.jpg (60,957 bytes)
olle

olle

2017-04-28 13:03

administrator   ~43490

Last edited: 2017-04-28 13:03

View 2 revisions

Cannot reproduce. Do you have more info? A video?

Tried on Firefox.

Ullrich

Ullrich

2017-04-28 15:11

reporter   ~43492

Ok, here is the video.

The error seems not to be browser (using Chrome for the video) related. Doing the same on a 2.59 customer installation, using same browser, works as expected.

2017-04-28_15-07-15.mp4 (678,862 bytes)
olle

olle

2017-04-28 15:17

administrator   ~43493

Still can't reproduce. Does it help if you clear browser cache? Can you attach your survey, please?
Ullrich

Ullrich

2017-04-28 15:46

reporter   ~43495

Clear browser cache does not solve it. Neither using different browsers and/or Incognito Tabs.
I've no special survey. Just created a new one, added one question and it happens.

A colleague of mine run in this issue when scripting this week.

I installed a new, clean system today and it still happens.
Just checked on my test server running Version 2.62.0+170124 has the same behaviour. After upgrading to latest release still no change.
olle

olle

2017-04-28 15:54

administrator   ~43496

Can you click F12 after the error happens and check the Javascript console? Paste any errors here.
olle

olle

2017-04-28 15:54

administrator   ~43497

In the video you paste into the quick-add text field. Do you always do that, or write manually sometimes?
Ullrich

Ullrich

2017-04-28 16:02

reporter   ~43498

Tried both - no difference
Ullrich

Ullrich

2017-06-07 09:29

reporter   ~43836

I'm still struggling with this issue.

Attached a screenshot (Firebug console) from one Limesurvey Installation (2.59) where everything works fine and one screenshot from the last version, where it does not work correct as described above.

Lime_correct.jpg (140,209 bytes)
Lime_not_correct.jpg (118,410 bytes)
tammo

tammo

2017-06-07 09:57

developer   ~43841

Last edited: 2017-06-07 09:58

View 2 revisions

Strange, I am also working on 2.64.7 170404
I am currently defing survey and using this option very much. No problems.

Difference: PHP5.5, MySQL, Chrome on W10

olle

olle

2017-06-07 10:02

administrator   ~43842

Noone can reproduce this. Can you try on another computer?
Ullrich

Ullrich

2017-06-07 11:13

reporter   ~43846

Seems to be an php issue.

Replaced my current web server running php 7 with a web server running php 5.6 and everything looks great!
Ullrich

Ullrich

2017-06-07 11:13

reporter   ~43847

But a downgrade to php 5.6 can't be the solution.
olle

olle

2017-06-07 11:15

administrator   ~43848

7.0 or 7.1?
Ullrich

Ullrich

2017-06-07 11:19

reporter   ~43850

I tried both, these versions are not working correct:

PHP Version 7.1.5-1+deb.sury.org~xenial+1
PHP Version 7.0.18-1+deb.sury.org~xenial+1

I've a live server running fine with:

PHP Version 7.0.12-1+deb.sury.org~xenial+1
olle

olle

2018-01-12 11:59

administrator   ~45577

Still a problem?
Ullrich

Ullrich

2018-01-12 12:06

reporter   ~45579

No worked on last version I checked it.
olle

olle

2018-01-12 15:59

administrator   ~45591

Phew, great, finally! Closing this issue.

Issue History

Date Modified Username Field Change
2017-04-28 12:41 Ullrich New Issue
2017-04-28 12:41 Ullrich File Added: lime1.jpg
2017-04-28 12:41 Ullrich File Added: lime2.jpg
2017-04-28 13:03 olle Assigned To => olle
2017-04-28 13:03 olle Status new => feedback
2017-04-28 13:03 olle Note Added: 43490
2017-04-28 13:03 olle Note Edited: 43490 View Revisions
2017-04-28 15:11 Ullrich File Added: 2017-04-28_15-07-15.mp4
2017-04-28 15:11 Ullrich Note Added: 43492
2017-04-28 15:11 Ullrich Status feedback => assigned
2017-04-28 15:17 olle Note Added: 43493
2017-04-28 15:17 olle Status assigned => feedback
2017-04-28 15:46 Ullrich Note Added: 43495
2017-04-28 15:46 Ullrich Status feedback => assigned
2017-04-28 15:54 olle Note Added: 43496
2017-04-28 15:54 olle Note Added: 43497
2017-04-28 16:02 Ullrich Note Added: 43498
2017-05-03 18:00 LouisGac Priority none => urgent
2017-06-07 09:29 Ullrich File Added: Lime_not_correct.jpg
2017-06-07 09:29 Ullrich File Added: Lime_correct.jpg
2017-06-07 09:29 Ullrich Note Added: 43836
2017-06-07 09:57 tammo Note Added: 43841
2017-06-07 09:58 tammo Note Edited: 43841 View Revisions
2017-06-07 10:02 olle Note Added: 43842
2017-06-07 11:13 Ullrich Note Added: 43846
2017-06-07 11:13 Ullrich Note Added: 43847
2017-06-07 11:15 olle Note Added: 43848
2017-06-07 11:19 Ullrich Note Added: 43850
2018-01-12 11:59 olle Status assigned => feedback
2018-01-12 11:59 olle Note Added: 45577
2018-01-12 12:06 Ullrich Note Added: 45579
2018-01-12 12:06 Ullrich Status feedback => assigned
2018-01-12 15:59 olle Note Added: 45591
2018-01-12 15:59 olle Status assigned => closed
2018-01-12 15:59 olle Resolution open => fixed
2018-01-12 15:59 olle Fixed in Version => 3.0.2