View Issue Details

IDProjectCategoryView StatusLast Update
12353Bug reports[All Projects] Survey takingpublic2017-05-03 17:00
Reporterolle 
Assigned ToLouisGac 
PrioritynoneSeverityminor 
Status resolvedResolutionfixed 
Product Version3.0 
Target Version3.0Fixed in Version 
Summary12353: Sample survey - some EM not executed
DescriptionSee attached survey, compare with master branch. Some EM is not executed in develop, it seems.
TagsNo tags attached.
Complete LimeSurvey version number (& build)develop
I will donate to the project if issue is resolvedNo
Browser-
Database & DB-Version-
Operating System (Server)-
Webserver software & version-
PHP Version7.1

Relationships

related to 12360 resolvedDenisChenu Big difference in HTML produced with previous develop version 

Activities

olle

2017-04-27 15:02

administrator  

ls205_sample_survey_english.lss (563,557 bytes)
Selection_192.png (82,398 bytes)
Selection_192.png (82,398 bytes)
Selection_193.png (85,394 bytes)
Selection_193.png (85,394 bytes)

LouisGac

2017-05-02 11:08

developer   ~43513

first observation: the problem already affected the answers_html branch

DenisChenu

2017-05-02 15:03

developer   ~43518

What do you mean about answers_html branch . answers_html never exist really : http://testing.sondages.pro/answershtml/index.php/863316 on 99bdf08b23081d833b7dc497b3bb0ca9361ccf0c

LouisGac

2017-05-02 15:07

developer   ~43519

I mean that when reverting until the merge with answers_html (8/11/2016), the bug is already there. But it's just a quick observation, it sill needs more investigation.

DenisChenu

2017-05-02 15:08

developer   ~43520

Strange, because i'm sure it work with some simple part (i tested it ....)

olle

2017-05-02 15:19

administrator   ~43521

Test with the attached survey, if you have time.

DenisChenu

2017-05-02 16:33

developer   ~43527

Commit broke situation :

- At https://github.com/LimeSurvey/LimeSurvey/commit/07cbcc11330d8a5c5a01291d903f61cb4d36046a : OK
- At https://github.com/LimeSurvey/LimeSurvey/commit/0835d09392b4e22de09e943598de4c5baaa6c3cf : broken

@olle : bad merging here ... I try replacing EM_core + EM_helper + qanda : better for HTML, but EM still broken.

LouisGac

2017-05-02 16:37

developer   ~43528

good catch Denis! thank you very much

olle

2017-05-02 17:03

administrator   ~43530

Well, fuck.

DenisChenu

2017-05-02 17:41

developer   ~43534

Yezp, and more : i try to replace directly the 2 em files and the qanda : seems this didn't solve this issue .... :/ double f**

olle

2017-05-03 09:44

administrator   ~43536

The problem might be in a view, rather. I will check it today.

olle

2017-05-03 11:14

administrator   ~43538

I can't reproduce the problem with the merge. It still works for me in this commit: b46e70ee3a3b042fa27ffb876ba6e75234cfc5e9

olle

2017-05-03 11:27

administrator   ~43539

For me, the EM worked before the twig-layout merge in develop branch: 71685ac145af96adfbe85d9eb22d36488f80516e

@LouisGac Could you check this again, please?

olle

2017-05-03 11:28

administrator   ~43540

Also note that right after twig-layout merge, it's broken in one way, but in the most recent commit, it's broken in another way.

olle

2017-05-03 11:39

administrator   ~43541

First broken in this commit: Dev: replaced {QUESTION_TEXT} by twig logic.

DenisChenu

2017-05-03 11:41

developer   ~43542

Arg, why it broke yesterday and not today .... maybe twig cache ? Sorry @olle for false alarm ....

LouisGac

2017-05-03 11:42

developer   ~43543

thx olle.
could you provide the exact commit hash?

olle

2017-05-03 11:45

administrator   ~43544

This is the commit: 6ff35720d3854de4b230792670247d8bf25aa779

If you do "git checkout HEAD^" from that commit, it should work, meaning it's the breaking commit.

olle

2017-05-03 11:46

administrator   ~43545

Maybe just add the "raw" filter from Twig? https://twig.sensiolabs.org/doc/2.x/filters/raw.html

olle

2017-05-03 11:48

administrator   ~43546

Yes, adding "raw" seems to fix it:

{{ aQuestion.text | raw}}

olle

2017-05-03 11:50

administrator   ~43547

Uh, nvm. It only fixes it in THAT commit, but not in the most recent commit, since there's a different problem there.

olle

2017-05-03 11:57

administrator   ~43548

New theory: When removing the templatereplace() function from SurveyRuntimeHelper, the EM ProcessString() is never called:

        return LimeExpressionManager::ProcessString($line, $questionNum, NULL, false, 1, 1, true);

olle

2017-05-03 12:33

administrator   ~43552

Is it really a good idea to remove templatereplace entirely? Wouldn't it be better to just put Twig _inside_ templatereplace instead? There's a lot of different logic in there.

LouisGac

2017-05-03 12:45

developer   ~43553

all the logic in templatereplace() has been moved to twig views.

LouisGac

2017-05-03 15:52

developer   ~43558

Fix committed to develop branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=22710

Related Changesets

LimeSurvey: develop 6654103f

2017-05-03 15:52:44

LouisGac

Details Diff
Fixed issue 12353: Sample survey - some EM not executed
mod - application/helpers/SurveyRuntimeHelper.php Diff File

Issue History

Date Modified Username Field Change
2017-04-27 15:02 olle New Issue
2017-04-27 15:02 olle Status new => assigned
2017-04-27 15:02 olle Assigned To => LouisGac
2017-04-27 15:02 olle File Added: ls205_sample_survey_english.lss
2017-04-27 15:02 olle File Added: Selection_193.png
2017-04-27 15:02 olle File Added: Selection_192.png
2017-04-27 17:37 LouisGac Sticky Issue No => Yes
2017-05-02 11:08 LouisGac Note Added: 43513
2017-05-02 15:03 DenisChenu Note Added: 43518
2017-05-02 15:07 LouisGac Note Added: 43519
2017-05-02 15:08 DenisChenu Note Added: 43520
2017-05-02 15:19 olle Note Added: 43521
2017-05-02 16:33 DenisChenu Note Added: 43527
2017-05-02 16:33 DenisChenu Relationship added related to 12360
2017-05-02 16:37 LouisGac Note Added: 43528
2017-05-02 17:03 olle Note Added: 43530
2017-05-02 17:41 DenisChenu Note Added: 43534
2017-05-03 09:44 olle Note Added: 43536
2017-05-03 10:59 olle Assigned To LouisGac => olle
2017-05-03 11:14 olle Note Added: 43538
2017-05-03 11:27 olle Note Added: 43539
2017-05-03 11:27 olle Assigned To olle => LouisGac
2017-05-03 11:28 olle Note Added: 43540
2017-05-03 11:39 olle Note Added: 43541
2017-05-03 11:41 DenisChenu Note Added: 43542
2017-05-03 11:42 LouisGac Note Added: 43543
2017-05-03 11:45 olle Note Added: 43544
2017-05-03 11:46 olle Note Added: 43545
2017-05-03 11:48 olle Note Added: 43546
2017-05-03 11:50 olle Note Added: 43547
2017-05-03 11:57 olle Note Added: 43548
2017-05-03 12:33 olle Note Added: 43552
2017-05-03 12:45 LouisGac Note Added: 43553
2017-05-03 15:52 LouisGac Changeset attached => LimeSurvey develop 6654103f
2017-05-03 15:52 LouisGac Note Added: 43558
2017-05-03 15:52 LouisGac Resolution open => fixed
2017-05-03 17:00 LouisGac Sticky Issue Yes => No
2017-05-03 17:00 LouisGac Status assigned => resolved