View Issue Details

IDProjectCategoryView StatusLast Update
12275Bug reports[All Projects] Survey designpublic2017-07-21 17:11
ReportertammoAssigned ToLouisGac 
PrioritynoneSeverityminor 
Status closedResolutionduplicate 
Product Version3.0 
Target Version3.xFixed in Version 
Summary12275: Javascript warning, even when Javascript is turned on.
DescriptionSee image, Javascript is turned on in my Browser (FF)
TagsNo tags attached.
Complete LimeSurvey version number (& build)3.0 Git
I will donate to the project if issue is resolvedYes
BrowserFF
Database & DB-VersionFF
Operating System (Server)Xampp on W10
Webserver software & versionFF
PHP VersionFF

Relationships

duplicate of 12342 closedLouisGac Some JS and CSS files not loaded when debug == 1 or 2 
related to 12286 closedLouisGac Subquestion answers are repeated in Twig version 

Activities

tammo

tammo

2017-04-21 10:02

developer  

limsurveyjavascript.png (27,389 bytes)
limsurveyjavascript.png (27,389 bytes)
LouisGac

LouisGac

2017-04-24 12:45

developer   ~43429

I can't reproduce this one, could you please tell me which page is affected? or could you join a survey?
tammo

tammo

2017-04-24 13:04

developer   ~43430

Here is a survey, but I guess that that does not help you. It happens in all surveys. On Firefox and on Microsoft Edge.

limesurvey_survey_522992.lss (15,890 bytes)
tammo

tammo

2017-04-24 13:15

developer   ~43431

I use this one for testing. When on page 1 the time expires, there is a loop and I cannot proceed. Perhaps related?

mytestsurvey.lss (508,043 bytes)
tammo

tammo

2017-04-26 09:47

developer   ~43470

I forgot to tell: this is happening locally, using Xampp on Windows10
tammo

tammo

2017-04-26 10:15

developer   ~43471

See console.

javascript.png (108,953 bytes)
LouisGac

LouisGac

2017-04-26 13:25

developer   ~43474

Fix committed to develop branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=22664
c_schmitz

c_schmitz

2017-07-21 17:11

administrator   ~44193

Version 3.0.0-beta.1 released

Related Changesets

LimeSurvey: develop d8b06984

2017-04-26 13:04:07

LouisGac

Details Diff
Dev: moved scripts and css to root/assets/
Dev: main goal is to fix 12275 by moving core package out of application subfolders

Issue History

Date Modified Username Field Change
2017-04-20 17:56 tammo New Issue
2017-04-20 17:56 tammo Status new => assigned
2017-04-20 17:56 tammo Assigned To => LouisGac
2017-04-21 10:02 tammo File Added: limsurveyjavascript.png
2017-04-24 12:45 LouisGac Note Added: 43429
2017-04-24 13:04 tammo File Added: limesurvey_survey_522992.lss
2017-04-24 13:04 tammo Note Added: 43430
2017-04-24 13:15 tammo File Added: mytestsurvey.lss
2017-04-24 13:15 tammo Note Added: 43431
2017-04-26 09:47 tammo Note Added: 43470
2017-04-26 10:15 tammo File Added: javascript.png
2017-04-26 10:15 tammo Note Added: 43471
2017-04-26 12:03 LouisGac Sticky Issue No => Yes
2017-04-26 13:25 LouisGac Changeset attached => LimeSurvey develop d8b06984
2017-04-26 13:25 LouisGac Note Added: 43474
2017-04-26 13:25 LouisGac Resolution open => fixed
2017-04-26 13:51 tammo Relationship added duplicate of 12342
2017-04-26 14:30 tammo Relationship added related to 12286
2017-04-26 16:16 LouisGac Sticky Issue Yes => No
2017-04-26 17:32 LouisGac Status assigned => resolved
2017-04-26 17:32 LouisGac Resolution fixed => duplicate
2017-07-21 17:11 c_schmitz Note Added: 44193
2017-07-21 17:11 c_schmitz Status resolved => closed