View Issue Details

IDProjectCategoryView StatusLast Update
12200Feature requests[All Projects] Survey participants (Tokens)public2017-03-14 13:19
ReporterDenisChenu 
Assigned To 
PrioritynoneSeverityfeature 
Status newResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary12200: PHPmailer : allow SMTP auth type update
DescriptionCurrently PHPMailer try, in that order 'CRAM-MD5', 'LOGIN', 'PLAIN', 'NTLM', 'XOAUTH2'. But some smtp server seems to have issue with CRAM-MD5 in new PHPMailer
Additional InformationI have a critsend account, with new PHPMailer :
2017-03-13 09:21:33 CLIENT -> SERVER: AUTH CRAM-MD5
2017-03-13 09:21:33 SERVER -> CLIENT: 334 **********************+
2017-03-13 09:21:33 CLIENT -> SERVER: **********************
2017-03-13 09:21:33 SERVER -> CLIENT: 535 Authentication failed
2017-03-13 09:21:33 SMTP ERROR: Username command failed: 535 Authentication failed

I force man ually to LOGIN
2017-03-13 09:04:07 CLIENT -> SERVER: AUTH LOGIN
2017-03-13 09:04:07 SERVER -> CLIENT: 334 **********************
2017-03-13 09:04:07 CLIENT -> SERVER: **********************
2017-03-13 09:04:07 SERVER -> CLIENT: 334 **********************
2017-03-13 09:04:07 CLIENT -> SERVER: **********************
2017-03-13 09:04:07 SERVER -> CLIENT: 235 Authentication successful.

Then i open a ticket to critsend

Their answer :
----
Hi/Bonjour Denis Chenu,
Thanks for contacting the support.
According to our tech team, this an issue due to the new version of PHP Mailer.
The new encoding is not retro compatible, we have planned an upgrade but there is no deadline for this project at the moment.
Thanks for your understanding.
Best regards,
-----

Then i think it can be integrated in config.php, optionnal settings

It's easy after to set it in PHPMailer call.

(i can get it, no issue here)
TagsNo tags attached.

Relationships

Issue History

Date Modified Username Field Change
2017-03-14 13:15 DenisChenu New Issue
2017-03-14 13:19 DenisChenu Note Added: 43281