View Issue Details

This bug affects 1 person(s).
 4
IDProjectCategoryView StatusLast Update
12162Bug reportsExpression Managerpublic2020-03-13 18:47
Reporterjelo Assigned To 
PrioritynoneSeveritypartial_block 
Status closedResolutionopen 
Product Version2.63.x 
Target Version4.0.0dev 
Summary12162: relevanceStatus not available for every question e.g. arrays.
Description

Relevance equation with e.g. sum(Q2.NAOK.relevanceStatus, Q3.NAOK.relevanceStatus, Q4.NAOK.relevanceStatus) LT 2
will work with with certain questiontypes (e.g. text display) but others (e.g. array questions) are marked with a syntax error on each term with relevancestatus.

The post was already discussed in the forum. The original poster seems to not have submit the issue. So I do it now, since LS 2.63.1 is still showing this behavior. I used demo.limesurvey.org to reproduce.

Steps To Reproduce

Use attached example by tpartner. Take a look at the thread too.

Additional Information

https://www.limesurvey.org/forum/can-i-do-this-with-limesurvey/100555-choose-1-question-out-of-a-group

TagsNo tags attached.
Bug heat4
Complete LimeSurvey version number (& build)2.63.1
I will donate to the project if issue is resolvedNo
Browser
Database type & versionN/A
Server OS (if known)N/A
Webserver software & version (if known)N/A
PHP VersionN/A

Relationships

duplicate of 09931 closedc_schmitz Bug reports relevancestatus does not appear to work for multiple choice questions in v2.06+ 
related to 10055 assignedLouisGac Feature requests Hide question if all sub-questions are hidden. 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

jelo

jelo

2017-02-28 17:46

partner  

DenisChenu

DenisChenu

2017-03-01 14:50

developer   ~43111

I think (unsure)

Q2_SQ01.relevanceStatus are the relevance status of Q2, not of Q2_SQ01.

If we move Q2_SQ01.relevanceStatus to relevanceStatus of Q2_SQ01 ( the group status AND question status AND sub question status) : we can break existing survey (who use Q2_SQ01.relevanceStatus as Q2.relevanceStatus)

Then : if we broke API : for 3.0
https://bugs.limesurvey.org/view.php?id=10055#c41908

c_schmitz

c_schmitz

2020-03-13 18:47

administrator   ~56491

This version of LimeSurvey is not longer supported. Please check so that the issue is fixed in a more recent version of LimeSurvey. If it's not, please reopen this bug report. Thank you.

Issue History

Date Modified Username Field Change
2017-02-28 17:46 jelo New Issue
2017-02-28 17:46 jelo File Added: limesurvey_survey_414155.lss
2017-03-01 14:50 DenisChenu Note Added: 43111
2017-03-01 14:50 DenisChenu Relationship added duplicate of 09931
2017-03-01 14:51 DenisChenu Relationship added related to 10055
2018-05-23 12:21 LouisGac Target Version => 4.0.0dev
2020-03-13 18:47 c_schmitz Note Added: 56491
2020-03-13 18:47 c_schmitz Status new => closed