View Issue Details

IDProjectCategoryView StatusLast Update
11931Bug reportsOtherpublic2016-11-21 17:23
Reporterhtwchur Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionduplicate 
Product Version2.55.x 
Summary11931: <label>-Tag didn't enclose the answer
Description

In the question-type List (Radio) the <label>-Tag didn't enlcose the answer but is empty tag.
The consequence is, that the answer isn't clickable how it is suggested by the label-clickable class in subsequent <div>.

<label class="control-label radio-label" for="answer584832X107X584S1.1"> </label>
<div id="label-answer584832X107X584S1.1" class="label-text label-clickable">
Testanswer
</div>

Steps To Reproduce

Create a List (Radio) question.
Add 2 answer options.
In the preview try to click the answer text. The radio-button isn't clickable.

Additional Information

The code should be corrected in all three answer-files in application\views\survey\questions\listradio\rows

A similiar coding is used in the multiplechoice-, gender- and yesno\radio- code.

Tagsanswers_html
Complete LimeSurvey version number (& build)2.56.1+161118
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMySQL
Server OS (if known)Windows
Webserver software & version (if known)IIS 7.5
PHP Version5.5

Relationships

duplicate of 11449 closedDenisChenu Feature requests Readding real label 

Activities

DenisChenu

DenisChenu

2016-11-21 17:22

developer   ~42091

It's one of the reason why we rework totally all HTML code

Issue History

Date Modified Username Field Change
2016-11-21 13:58 htwchur New Issue
2016-11-21 17:22 DenisChenu Assigned To => DenisChenu
2016-11-21 17:22 DenisChenu Status new => resolved
2016-11-21 17:22 DenisChenu Resolution open => duplicate
2016-11-21 17:22 DenisChenu Fixed in Version => 3.0
2016-11-21 17:22 DenisChenu Note Added: 42091
2016-11-21 17:23 DenisChenu Tag Attached: answers_html
2016-11-21 17:23 DenisChenu Relationship added duplicate of 11449
2016-11-21 17:23 DenisChenu Status resolved => closed