View Issue Details

IDProjectCategoryView StatusLast Update
11833Bug reportsOtherpublic2020-03-13 19:22
ReporterDenisChenu Assigned To 
PrioritynoneSeverityminor 
Status newResolutionreopened 
Product Version2.55.x 
Summary11833: Question index complete : auto submit
DescriptionIf you have a non relevant group in question index (full) : survey can be submitted without "button" click
Steps To ReproduceImport lss file included , follow instruction on the first question and see what happen.

Relevance equation of the last group is Q1.NAOK=="something", then can be submitted : step goes up of max step
Additional Informationfinished is done here : https://github.com/Shnoulle/LimeSurvey-Shnoulle/commit/5383b51cd5fe5d226a473c00620178e4edc45d27#diff-bd7fb0608632543b300becba7fa4e791R109

If the step is up of "max step" : set to finished.

Like comment ; i think it's bad idea to submit survey without any "button" click.

Allow finished in static function NavigateForwards

But NEVER allow finished in JumpTo, there are no reason i think.
TagsNo tags attached.
Complete LimeSurvey version number (& build)4.1.10
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Activities

DenisChenu

DenisChenu

2016-10-25 19:43

developer  

DenisChenu

DenisChenu

2016-10-26 10:26

developer   ~41544

@olle : it's not a preoblem to fix it, but it's more to have feedback : did someone remind why we allow finished here ?

JumpTo is used when:
- reload
- question index
- ????

reload & question index surely dot need finished=>true, but another one ?

Some advice needed ;). Dis someone think of another way where we use JumpTo ?
ollehar

ollehar

2016-10-26 10:44

administrator   ~41546

Well, you're then one who knows EM best, so... If you write down scenarios we can QA-test it.
DenisChenu

DenisChenu

2016-10-26 10:52

developer   ~41547

OK : i fix it in 3.0/develop/answers_html
DenisChenu

DenisChenu

2016-11-14 16:37

developer   ~41907

Not fixed actually : EM task .....
c_schmitz

c_schmitz

2020-03-13 18:46

administrator   ~56449

This version of LimeSurvey is not longer supported. Please check so that the issue is fixed in a more recent version of LimeSurvey. If it's not, please reopen this bug report. Thank you.
DenisChenu

DenisChenu

2020-03-13 19:21

developer   ~56527

 4.1.10 have the same issue withn same lss

Issue History

Date Modified Username Field Change
2016-10-25 19:43 DenisChenu New Issue
2016-10-25 19:43 DenisChenu File Added: limesurvey_survey_dontsubmitWithNoButton.lss
2016-10-26 09:59 ollehar Assigned To => DenisChenu
2016-10-26 09:59 ollehar Status new => assigned
2016-10-26 10:26 DenisChenu Note Added: 41544
2016-10-26 10:44 ollehar Note Added: 41546
2016-10-26 10:52 DenisChenu Note Added: 41547
2016-10-26 10:53 DenisChenu Target Version => 3.0
2016-11-14 16:36 LouisGac Status assigned => resolved
2016-11-14 16:36 LouisGac Resolution open => fixed
2016-11-14 16:36 LouisGac Fixed in Version => 3.0.x
2016-11-14 16:37 DenisChenu Status resolved => assigned
2016-11-14 16:37 DenisChenu Note Added: 41907
2018-07-10 08:08 DenisChenu Assigned To DenisChenu =>
2018-07-10 08:08 DenisChenu Status assigned => new
2018-07-10 08:08 DenisChenu Fixed in Version 3.0.x =>
2020-03-13 18:46 c_schmitz Note Added: 56449
2020-03-13 18:46 c_schmitz Status new => closed
2020-03-13 19:21 DenisChenu Assigned To => DenisChenu
2020-03-13 19:21 DenisChenu Status closed => new
2020-03-13 19:21 DenisChenu Resolution fixed => reopened
2020-03-13 19:21 DenisChenu Complete LimeSurvey version number (& build) 2.55 => 4.1.10
2020-03-13 19:21 DenisChenu Note Added: 56527
2020-03-13 19:22 DenisChenu Assigned To DenisChenu =>