View Issue Details

IDProjectCategoryView StatusLast Update
11787Bug reports[All Projects] Survey designpublic2018-11-01 17:08
ReporterLiod_DSAssigned ToDenisChenu 
PrioritynoneSeverityminor 
Status resolvedResolutionfixed 
Product Version2.53 
Target VersionFixed in Version3.15.x 
Summary11787: filtered question column alignment 2nd
Description

When you try to display more than 1 columns in a filtered question the alignment doesn't fit

Steps To Reproduce

#1 create a survey
#2 add a multi-choice question
#3 add a single/multi [filtered on the previus multi]
#4 try it

OR

Use the attached survey (new)

Additional Information

same as:

bugs.limesurvey.org/view.php?id=10995

that one was closed as "solved" but the problem isn't fixed at the moment

Tagsanswers_html
Complete LimeSurvey version number (& build)2.54.1+161010
I will donate to the project if issue is resolvedNo
Browserchrome
Database & DB-Versionunknow
Server OS (if known)Linux - ubuntu
Webserver software & version (if known)Apache
PHP Version5.5.9

Relationships

related to 14202 new Feature requests Readd "column style" css for multiple column but in attribute 
child of 11738 closedDenisChenu Bug reports Uneven space between filtered answers 

Activities

Liod_DS

Liod_DS

2016-10-12 14:36

reporter  

limesurvey_survey_746393.lss (74,004 bytes)
Liod_DS

Liod_DS

2016-10-12 14:39

reporter   ~41269

Links to forum post:

https://www.limesurvey.org/forum/design-issues/107295-answer-display-columns-error

Liod_DS

Liod_DS

2016-10-12 14:43

reporter   ~41270

for a better example, from the attached survey:

Choose like 10 numbers from the list, from the middle to the high values
(the lower ones are less relevant becouse they directly go to the first column)

DenisChenu

DenisChenu

2016-10-12 15:48

developer   ~41274

In 2.06 version : we have a setting for "coluln" type

  • ul have same issue (if you hide all 1st coluln : you still have the 1st column)
  • css is OK : show an inline list.

Upload the 2 way. Maybe add it in answers_html (3.X) in attribute.

DenisChenu

DenisChenu

2016-10-12 15:49

developer  

css.png (17,360 bytes)
css.png (17,360 bytes)
DenisChenu

DenisChenu

2016-10-12 15:49

developer  

ul.png (18,407 bytes)
ul.png (18,407 bytes)
DenisChenu

DenisChenu

2016-10-12 15:54

developer   ~41275

Ordering is different too :
1 2 3
4 5 6
7 8 9

Not like this (ul style)
1 4 7
2 5 8
3 6 9

DenisChenu

DenisChenu

2016-10-13 10:25

developer   ~41281

3.X , not 3.0 (New feature)

DenisChenu

DenisChenu

2016-10-13 10:33

developer   ~41282

The class attribute can not do the work in 2.50 due to https://bugs.limesurvey.org/view.php?id=11738 ....

3.0 : class attribute can do the job
3.X : Have an attribute (just add col-sm-X to answer-item, no multi column)

DenisChenu

DenisChenu

2018-11-01 17:02

developer   ~49504

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28441

DenisChenu

DenisChenu

2018-11-01 17:08

developer   ~49505

Fixed with js system to hide/show related columns

Related Changesets

LimeSurvey: master dcb699cb

2018-11-01 17:02:29

DenisChenu

Details Diff
Fixed issue 11787: filtered question with multiple column
Dev: function is here, but not called …
Dev: since user can extend vaniall and remove template-core js, test if exist before
mod - themes/survey/vanilla/scripts/theme.js Diff File

Issue History

Date Modified Username Field Change
2016-10-12 14:36 Liod_DS New Issue
2016-10-12 14:36 Liod_DS File Added: limesurvey_survey_746393.lss
2016-10-12 14:39 Liod_DS Note Added: 41269
2016-10-12 14:43 Liod_DS Note Added: 41270
2016-10-12 15:48 DenisChenu Note Added: 41274
2016-10-12 15:49 DenisChenu File Added: css.png
2016-10-12 15:49 DenisChenu File Added: ul.png
2016-10-12 15:54 DenisChenu Note Added: 41275
2016-10-13 10:18 ollehar Assigned To => DenisChenu
2016-10-13 10:18 ollehar Status new => assigned
2016-10-13 10:22 DenisChenu Tag Attached: answers_html
2016-10-13 10:25 DenisChenu Note Added: 41281
2016-10-13 10:32 DenisChenu Relationship added child of 11738
2016-10-13 10:33 DenisChenu Note Added: 41282
2016-10-13 10:34 DenisChenu Target Version => 3.0.x
2018-07-10 08:09 DenisChenu Assigned To DenisChenu =>
2018-07-10 08:09 DenisChenu Status assigned => new
2018-07-10 08:09 DenisChenu Target Version 3.0.x =>
2018-11-01 17:02 DenisChenu Changeset attached => LimeSurvey master dcb699cb
2018-11-01 17:02 DenisChenu Note Added: 49504
2018-11-01 17:02 DenisChenu Assigned To => DenisChenu
2018-11-01 17:02 DenisChenu Resolution open => fixed
2018-11-01 17:08 DenisChenu Status new => resolved
2018-11-01 17:08 DenisChenu Fixed in Version => 3.15.x
2018-11-01 17:08 DenisChenu Note Added: 49505
2018-11-01 17:08 DenisChenu Relationship added related to 14202