View Issue Details

IDProjectCategoryView StatusLast Update
11734Feature requests[All Projects] Ergonomypublic2018-04-06 11:48
ReporterDenisChenu Assigned ToDenisChenu  
PrioritynoneSeverityfeature 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0 
Summary11734: Reimplement input size
Description

When move from 2.06 to 2.50 : input-width are replaced by input-col-width, and it's not the same think and the same behaviour

Steps To Reproduce

Find a way to have a very little input, but without a big label.

Additional Information

Actually : bostrap default is to set 100% by default to the input-control, but have a way to show different size for input it's a must have for big survey i think.

An idea : leave text_input_width to set the input container width (input-group)
Add a input-size for text and numeric (maybe for select , but select fon't have a size,

Set the size of the input (attribute:size) and add a class for this : something like form-control-inline : adding some core css to show it inline.

if input-width is not set width is not set : take 100% of text_input_width like actually.

For size attribute : http://www.w3schools.com/TAGS/att_input_size.asp

Tagsanswers_html

Activities

DenisChenu

DenisChenu

2016-09-30 18:48

developer  

DenisChenu

DenisChenu

2016-09-30 18:49

developer   ~41049

Last edited: 2016-09-30 18:49

View 2 revisions

PS : the 2.06 text_input_width is totally incompatible with new one. But we use same attribute ....

PS2 : An exemple : zipcode must be mless wide than country, phone mus be less wide too than name etc ....

DenisChenu

DenisChenu

2016-10-03 17:15

developer   ~41059

With input size (in short free text question) it's easy to use form-inline (if it's set only for example)

Send a screenshot

DenisChenu

DenisChenu

2016-10-03 17:15

developer  

Mazi

Mazi

2016-10-04 09:36

partner   ~41065

If I get this right, the plan is to re-add the input width question attribute (good idea!) and if it is set, that setting is applied.
If nothing is set, we have some basic CSS to deal with it.
Correct?

DenisChenu

DenisChenu

2016-10-04 10:21

developer   ~41071

input size=XXX

We get a default if not set (in fact we always need a default if user disable css (if i remind)

If set : we put it ... + add a extra class in the item or list.

It's the idea.

Question : form-inline or not ? With form-inline (from BS) : the size of the input is not forced to 100%.

Mazi

Mazi

2016-10-04 10:23

partner   ~41072

About your question: I think for text types 100% is fine but for numeric types a shorter field length would look better.

DenisChenu

DenisChenu

2016-10-04 10:35

developer   ~41076

100% come from boostrap .....

Set size : you get your auto seems the best :)

Just an issue .... form-inline have label inlined too .... then must add a cpore class.

For your issue did you try input.numeric {width:auto} in template.css ?

Mazi

Mazi

2016-10-04 10:42

partner   ~41079

Nope, I didn't try such CSS. It is just my 2 cents that since you usually input some very few characters/number at numeric questions, 100% field width always looks far too large.

tammo

tammo

2016-10-04 13:44

partner   ~41097

Use the input width as a min-width, please expand to 100% at xs screens

DenisChenu

DenisChenu

2016-10-04 14:21

developer   ~41103

@tammo : didn't understand ? You mean width:auto with a size=X ?

tammo

tammo

2016-10-04 14:30

partner   ~41104

xs in Bootstrap language: extra small screens.
See: https://v4-alpha.getbootstrap.com/layout/grid/#grid-options

DenisChenu

DenisChenu

2016-10-04 14:42

developer   ~41105

It's already the case, in general : col-xs-12 col-sm-X / col-xs-12 col-sm-Y

Then no issue .

And here : it's about : input size="5" : actually set a size of 1 or 50 don't change anything .

tammo

tammo

2016-10-04 15:07

partner   ~41107

In my view col-xs-12 is rarely needed. Most of the times something like col-sm-6 is enough, without col-xs-12, because that will also add paddings that are mostly not needed on very small screens.

jelo

jelo

2016-10-12 01:19

partner   ~41242

Recapturing the feature request:
Additional option "Answer field size" which would be available in questions types which contain a text or numeric input field.
If a select field can get such an option in currently not known.

Reject feature results in no change of current situation.
Is that summary correct?

DenisChenu

DenisChenu

2016-10-12 08:08

developer   ~41243

Hi jelo , thanks for the summary, i update the Additional Information after:

  1. Additional option "Answer field size" which would be available in questions types which contain a text or numeric input field. :
  2. This option add a inline class to the input : reset the full-width of the input due to bootstrap (because actually : set a size to the input/textarea don't change the size of this input).

    Reject feature results in no change of current situation : yes

DenisChenu

DenisChenu

2016-10-31 20:04

developer   ~41624

Fix committed to answers_html branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=21220

Related Changesets

LimeSurvey: answers_html 6889d849

2016-10-31 17:57:44

DenisChenu

Details Diff
Dev: issue 11734: Reimplement input size
Dev: short text only actually
Affected Issues
11734
mod - application/core/packages/limesurvey/survey.css Diff File
mod - application/helpers/qanda_helper.php Diff File
mod - application/helpers/questionHelper.php Diff File
mod - application/views/admin/survey/Question/advanced_settings_view.php Diff File
mod - application/views/survey/questions/shortfreetext/text/item.php Diff File
mod - application/views/survey/questions/shortfreetext/textarea/item.php Diff File

LimeSurvey: answers_html 5a841145

2016-10-31 20:03:14

DenisChenu

Details Diff
New feature 11734: Reimplement input size
Dev: if i lost somewhere : report issue
Dev: have some issue with screen width : core fix or template fix ?
Affected Issues
11734
mod - application/core/packages/limesurvey/survey.css Diff File
mod - application/helpers/qanda_helper.php Diff File
mod - application/helpers/questionHelper.php Diff File
mod - application/views/survey/questions/arrays/multiflexi/answer.php Diff File
mod - application/views/survey/questions/arrays/multiflexi/rows/cells/answer_td.php Diff File
mod - application/views/survey/questions/arrays/texts/answer.php Diff File
mod - application/views/survey/questions/arrays/texts/rows/cells/answer_td.php Diff File
mod - application/views/survey/questions/arrays/texts/rows/cells/td_grand_total.php Diff File
mod - application/views/survey/questions/arrays/texts/rows/cells/td_total.php Diff File
mod - application/views/survey/questions/longfreetext/answer.php Diff File
mod - application/views/survey/questions/multiplenumeric/rows/input/answer_row.php Diff File
mod - application/views/survey/questions/multiplenumeric/rows/sliders/answer_row.php Diff File
mod - application/views/survey/questions/multipleshorttext/rows/answer_row_inputtext.php Diff File
mod - application/views/survey/questions/multipleshorttext/rows/answer_row_textarea.php Diff File
mod - application/views/survey/questions/numerical/answer.php Diff File
mod - application/views/survey/questions/shortfreetext/text/item.php Diff File
mod - styles-public/numeric-slider.css Diff File
mod - templates/lumen/css/template-core.css Diff File

Issue History

Date Modified Username Field Change
2016-09-30 18:48 DenisChenu New Issue
2016-09-30 18:48 DenisChenu File Added: Capture du 2016-09-30 18-40-55.png
2016-09-30 18:49 DenisChenu Note Added: 41049
2016-09-30 18:49 DenisChenu Note Edited: 41049 View Revisions
2016-09-30 18:54 DenisChenu Tag Attached: answers_html
2016-09-30 18:54 DenisChenu Project Development => Feature requests
2016-09-30 18:54 DenisChenu Category Survey Design => Other issues
2016-09-30 18:55 DenisChenu Severity @50@ => feature
2016-09-30 18:55 DenisChenu Category Other issues => Accessibility
2016-09-30 18:55 DenisChenu Product Version 2.5x =>
2016-09-30 19:05 DenisChenu Summary Reimplement input width => Reimplement input size
2016-09-30 19:06 DenisChenu Additional Information Updated View Revisions
2016-10-03 17:15 DenisChenu Note Added: 41059
2016-10-03 17:15 DenisChenu File Added: Capture du 2016-10-03 17-14-40.png
2016-10-04 09:36 Mazi Note Added: 41065
2016-10-04 10:21 DenisChenu Note Added: 41071
2016-10-04 10:23 Mazi Note Added: 41072
2016-10-04 10:35 DenisChenu Note Added: 41076
2016-10-04 10:42 Mazi Note Added: 41079
2016-10-04 13:44 tammo Note Added: 41097
2016-10-04 14:21 DenisChenu Note Added: 41103
2016-10-04 14:30 tammo Note Added: 41104
2016-10-04 14:42 DenisChenu Note Added: 41105
2016-10-04 15:07 tammo Note Added: 41107
2016-10-12 01:19 jelo Note Added: 41242
2016-10-12 08:08 DenisChenu Note Added: 41243
2016-10-17 16:26 DenisChenu Category Accessibility => Ergonomy
2016-10-31 16:50 DenisChenu Assigned To => DenisChenu
2016-10-31 16:50 DenisChenu Status new => assigned
2016-10-31 17:58 DenisChenu Changeset attached => LimeSurvey answers_html 6889d849
2016-10-31 20:04 DenisChenu Changeset attached => LimeSurvey answers_html 5a841145
2016-10-31 20:04 DenisChenu Note Added: 41624
2016-10-31 20:04 DenisChenu Resolution open => fixed
2016-10-31 20:05 DenisChenu Status assigned => resolved
2016-10-31 20:05 DenisChenu Fixed in Version => 3.0
2018-04-06 11:48 markusfluer Status resolved => closed