View Issue Details

IDProjectCategoryView StatusLast Update
11361Bug reports[All Projects] Survey takingpublic2019-01-29 13:09
ReporterSiemAssigned ToLouisGac 
PrioritylowSeverityminor 
Status assignedResolutionreopened 
Product Version2.50.x 
Target VersionFixed in Version2.50.x 
Summary11361: progress bar counts hidden questions
Description

When there are hidden calculation questions the progress bar also counts these when indicating the progress.
For instance in a survey with 5 questions and 5 hidden questions (the last 5), the progress bar will indicate 40% at question 4 instead of 80%.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 2.50+ Build 160606
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Version 5.5.49-0+deb7u1
Server OS (if known)Debian
Webserver software & version (if known)Apache/2.2.22 (Debian)
PHP Version5.4.45-0+deb7u2

Relationships

has duplicate 14003 confirmedcdorin progressbar includes hidden questions 

Activities

Siem

Siem

2016-06-09 15:52

reporter  

survey_archive_758532.lsa (8,623 bytes)
Siem

Siem

2016-06-09 15:53

reporter  

limesurvey_survey_758532.lss (119,826 bytes)
LouisGac

LouisGac

2016-06-09 17:37

manager   ~39381

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=19386

DenisChenu

DenisChenu

2016-06-10 08:13

developer   ~39389

We count the step of EM in fact. And hidden group question are step ...

For such system : it's really hard to find the best way.

  • For question by question mode : we surely can find a way for hidden question (but not for relevance)
  • For group by group : i really think we must not try to find 'hidden group" because all question inside group are hidden.

In fact : for specific survey : it's really easy to add manually the script on group description (for example). "progress bar" work in a lot of case, working on a php system to count the 'real' step can : do new bug, add new evaluation and SQL request. Really think we must NOT fix this issue.

It's my opinion.

LouisGac

LouisGac

2016-06-10 09:59

manager   ~39391

Denis: do you think my fix is ok?

https://github.com/LimeSurvey/LimeSurvey/commit/93d30e4e1935f370a3e6f50586d731f1313d05ea

DenisChenu

DenisChenu

2016-06-10 10:18

developer   ~39394

If i don't make error : it's for "Total number of questions" at start of survey. Not the "progress bar".

Denis

LouisGac

LouisGac

2016-06-10 10:25

manager   ~39397

it's also use for the progress bar (pushed to the EM session, etc).
I was wondering if it could brake something else...

DenisChenu

DenisChenu

2016-06-10 10:30

developer   ~39398

Then : it work for Question by QUetsion mode ? But not for group by group ? Right ?

LouisGac

LouisGac

2016-06-10 10:33

manager   ~39399

the bug was about hidden questions, so yes.

c_schmitz

c_schmitz

2016-06-13 12:26

administrator   ~39477

Version 2.50 Build 160613 released

Siem

Siem

2016-08-08 12:53

reporter   ~40201

bug is present in version 2.50+ Build 160804

LouisGac

LouisGac

2016-11-15 19:17

manager   ~41970

Note: to avoid bugs, a separate variable should be created for the progress bar.

Related Changesets

LimeSurvey: master 93d30e4e

2016-06-09 15:35:58

LouisGac

Details Diff
Fixed issue 11361: progress bar counts hidden questions Affected Issues
11361
mod - application/helpers/frontend_helper.php Diff File

Issue History

Date Modified Username Field Change
2016-06-09 15:52 Siem New Issue
2016-06-09 15:52 Siem File Added: survey_archive_758532.lsa
2016-06-09 15:53 Siem File Added: limesurvey_survey_758532.lss
2016-06-09 16:55 LouisGac Sticky Issue No => Yes
2016-06-09 17:06 c_schmitz Priority none => low
2016-06-09 17:07 c_schmitz Sticky Issue Yes => No
2016-06-09 17:37 LouisGac Changeset attached => LimeSurvey master 93d30e4e
2016-06-09 17:37 LouisGac Note Added: 39381
2016-06-09 17:37 LouisGac Assigned To => LouisGac
2016-06-09 17:37 LouisGac Resolution open => fixed
2016-06-09 17:37 LouisGac Status new => resolved
2016-06-10 08:13 DenisChenu Note Added: 39389
2016-06-10 09:59 LouisGac Note Added: 39391
2016-06-10 10:18 DenisChenu Note Added: 39394
2016-06-10 10:25 LouisGac Note Added: 39397
2016-06-10 10:30 DenisChenu Note Added: 39398
2016-06-10 10:33 LouisGac Note Added: 39399
2016-06-10 15:42 Jelle_S Changeset attached => LimeSurvey master 3065832d
2016-06-10 15:42 Jelle_S Assigned To LouisGac => Jelle_S
2016-06-10 15:49 c_schmitz Changeset removed LimeSurvey master 3065832d =>
2016-06-12 10:16 c_schmitz Status resolved => assigned
2016-06-12 10:16 c_schmitz Assigned To Jelle_S => LouisGac
2016-06-12 10:16 c_schmitz Status assigned => resolved
2016-06-12 10:16 c_schmitz Fixed in Version => 2.5
2016-06-13 12:26 c_schmitz Note Added: 39477
2016-06-13 12:26 c_schmitz Status resolved => closed
2016-06-14 15:52 c_schmitz Status closed => feedback
2016-06-14 15:52 c_schmitz Resolution fixed => reopened
2016-08-08 12:53 Siem Note Added: 40201
2016-08-08 12:53 Siem Status feedback => assigned
2016-11-15 19:17 LouisGac Note Added: 41970
2019-01-29 13:09 jelo Relationship added has duplicate 14003