View Issue Details

IDProjectCategoryView StatusLast Update
10025Bug reports[All Projects] Survey takingpublic2017-02-13 22:45
ReporterRaCMJS 
Assigned ToDenisChenu 
PriorityhighSeveritymajor 
Status resolvedResolutionfixed 
Product Version2.50.x 
Target VersionFixed in Version3.0 
Summary10025: Quotas : Terminate survey with warning sentence is unclear
DescriptionI am using quotas to screen people out of the survey with a token table. Survey behavior works - i.e. people who exceed the quota on the screening question get kicked out of the survey and a message telling them that they were screened out is displayed.

HOWEVER, these tokens are NOT marked as Q in the completed field in the token table and just remain as N. This means that the screened out person can take the survey AGAIN defeating the purpose of the screening process.

Test survey posted on the demo website TestSurveyRaCMJS
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 2.05+ Build 150310
I will donate to the project if issue is resolvedYes
BrowserFirefox
Database & DB-VersionMSSQL Server 2008
Operating System (Server)Red Had Enterprise Linux
Webserver software & versionApache 2.2.15
PHP Version5.3.8

Relationships

Activities

DenisChenu

2015-11-07 00:26

developer   ~33526

Last edited: 2015-11-07 00:29

View 2 revisions

Just tested with last GIT : working WITh or WITHOUT anonymous survey

Upload the lss : demo is cleaned each night.

RaCMJS

2015-11-07 02:30

reporter  

limesurvey_survey_848521.lss (17,567 bytes)

RaCMJS

2015-11-07 02:37

reporter   ~33532

I uploaded the lss survey. When I tested this on the demo site with a token table where the survey is NOT anonymous it was NOT working. From a respondent perspective the behavior is fine. HOWEVER, the key problem is that the response field "completed" is not changed when people are screened out. I need to be able to see that they have completed/screened out of the survey. Even if the likelihood is low, someone could still log onto the survey again and take it. If I send reminders, they will get those too because they are not marked as completed or screened out. This is a problem.

DenisChenu

2015-11-07 14:23

developer   ~33535

Last edited: 2015-11-07 14:25

View 2 revisions

Your quota action is "Terminate survey with warning", then user is allowed to click "Previous" and not submit the quota, if user is allwed to update answers : then token user must have the same ability. Use "Terminate survey" fix your issue.

The sentence is unclear : we have to fix it. Something like :
"Allow update answers" or something like that.

DenisChenu

2016-09-05 10:38

developer   ~40679

@c_schmitz : i have again someone activate "Terminate survey with warning" because he think the quota message aren't shown if not.

I can fix, but .... i know you fix my fix ;)

"Don't terminate survey, allow user to update answers"

c_schmitz

2016-09-21 16:14

administrator   ~40893

IMHO the warning screen should have a final Submit button that marks the survey/token as 'Quota out' (and redirects to the configured quota URL, if applicable).

DenisChenu

2016-09-21 16:16

developer   ~40894

Yes : must have 2 buttons:

< Previous (like actually)
Submit : close survey and set Quota terminated

But here : it's just the original sentence : a lot of user don't understand and think if they don't use thois message is not showned :)

DenisChenu

2016-11-01 09:32

developer   ~41635

I do some test with 'Previous + submit' in 3.0. If it's OK : i fix it for 3.0. If not .... de-assign it from me ....

c_schmitz

2016-11-01 09:39

administrator   ~41636

Yes, please fix it.

DenisChenu

2016-11-02 00:13

developer   ~41666

Added but
- Show same message twice.
- Add a redirect in SurveyRuntimeHelper

DenisChenu

2016-11-03 08:13

developer   ~41689

Fix committed to answers_html branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=21255

Related Changesets

LimeSurvey: answers_html 9c261a6a

2016-11-02 17:37:13

DenisChenu

Details Diff
Dev: some fix to old default template
Dev: separation of class (Thansk Tammo)
mod - application/controllers/admin/quotas.php Diff File
mod - application/helpers/SurveyRuntimeHelper.php Diff File
mod - application/helpers/expressions/em_manager_helper.php Diff File
mod - application/helpers/frontend_helper.php Diff File
mod - application/views/admin/quotas/editquota_view.php Diff File
mod - application/views/admin/quotas/newquota_view.php Diff File
mod - application/views/admin/quotas/viewquotasrow_view.php Diff File
mod - application/views/survey/questions/arrays/multiflexi/answer.php Diff File
mod - templates/default/views/clearall.pstpl Diff File
mod - templates/default/views/completed.pstpl Diff File
mod - templates/flatmodern/css/template-core.css Diff File
mod - templates/flatmodern/css/template.css Diff File
mod - templates/flatmodern/views/groupdescription.pstpl Diff File
mod - templates/flatmodern/views/navigator.pstpl Diff File
mod - templates/flatmodern/views/startgroup.pstpl Diff File
mod - templates/flatmodern/views/startpage.pstpl Diff File
mod - templates/flatmodern/views/welcome.pstpl Diff File
mod - templates/lumen/pstpl/startgroup.pstpl Diff File

LimeSurvey: answers_html 82285614

2016-11-03 08:12:08

DenisChenu

Details Diff
Fixed issue 10025: Quotas : Terminate survey with warning allow submit or not
mod - application/models/TemplateConfiguration.php Diff File
mod - application/views/admin/quotas/editquota_view.php Diff File
mod - application/views/admin/quotas/newquota_view.php Diff File

Issue History

Date Modified Username Field Change
2015-11-06 18:01 RaCMJS New Issue
2015-11-07 00:26 DenisChenu Note Added: 33526
2015-11-07 00:29 DenisChenu Note Edited: 33526 View Revisions
2015-11-07 02:30 RaCMJS File Added: limesurvey_survey_848521.lss
2015-11-07 02:37 RaCMJS Note Added: 33532
2015-11-07 14:23 DenisChenu Note Added: 33535
2015-11-07 14:24 DenisChenu Reproducibility have not tried => sometimes
2015-11-07 14:24 DenisChenu Product Version 2.05+ => 2.06+
2015-11-07 14:24 DenisChenu Priority high => low
2015-11-07 14:25 DenisChenu Note Edited: 33535 View Revisions
2015-11-09 08:45 DenisChenu Summary Quotas don't work with a token table. => Quotas : Terminate survey with warning sentence is unclear
2016-08-25 11:33 c_schmitz Priority low => high
2016-08-25 11:33 c_schmitz Product Version 2.06+ => 2.50.x
2016-09-05 10:33 LouisGac Assigned To => c_schmitz
2016-09-05 10:33 LouisGac Status new => assigned
2016-09-05 10:38 DenisChenu Note Added: 40679
2016-09-21 16:14 c_schmitz Note Added: 40893
2016-09-21 16:15 c_schmitz Assigned To c_schmitz =>
2016-09-21 16:15 c_schmitz Status assigned => new
2016-09-21 16:16 DenisChenu Note Added: 40894
2016-11-01 09:32 DenisChenu Assigned To => DenisChenu
2016-11-01 09:32 DenisChenu Status new => assigned
2016-11-01 09:32 DenisChenu Note Added: 41635
2016-11-01 09:39 c_schmitz Note Added: 41636
2016-11-02 00:13 DenisChenu Assigned To DenisChenu => c_schmitz
2016-11-02 00:13 DenisChenu Note Added: 41666
2016-11-03 08:13 DenisChenu Changeset attached => LimeSurvey answers_html 82285614
2016-11-03 08:13 DenisChenu Note Added: 41689
2016-11-03 08:13 DenisChenu Assigned To c_schmitz => DenisChenu
2016-11-03 08:13 DenisChenu Resolution open => fixed
2016-11-03 08:15 DenisChenu Changeset attached => LimeSurvey answers_html 9c261a6a
2016-11-03 08:15 DenisChenu Status assigned => resolved
2016-11-03 08:15 DenisChenu Fixed in Version => 3.0