LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
08444Bug reports[All Projects] Import/Exportpublic2013-12-11 21:592014-06-11 18:02
ReporterKitchM 
Assigned ToDenisChenu 
PrioritynormalSeverityfeature 
StatusclosedResolutionfixed 
Product Version2.00+ 
Target VersionFixed in Version2.05+ 
Summary08444: Participant DB : CSV Import Fails To Display All Fields
DescriptionCannot see Email field to import.
Steps To ReproduceI open the program interface on my server and I see the login page. After login, I see the main screen. I select my survey name and select Central Participant Database/Panel. Next I select Import from CSV. When I browse and select the file, I then select to Upload.

The next screen shows all fields but the Email field. It is maddening. No matter what I do, that field will not display in the list.
Additional InformationSee screenshot attached.
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit IDVersion 2.00+ Build 131206
BrowserFirefox 25.0
Database & DB-VersionMySQL version 5.1.71
Operating System (Server)CentOS Linux 6.4
Webserver software & versionApache version 2.2.15
PHP Version5.3.3-27.el6_5
Attached Filespng file icon Screenshot - 12112013 - 03:19:04 PM - LimeSurvey showing Field Selection page.png [^] (42,685 bytes) 2013-12-11 21:59


png file icon Screenshot - 12132013 - 01:34:58 PM - LimeSurvey import failure with empty fields.png [^] (61,423 bytes) 2013-12-13 19:37


png file icon Screenshot - 12132013 - 01:37:52 PM - LimeSurvey shows no participants.png [^] (58,680 bytes) 2013-12-13 19:39


csv file icon test.csv [^] (267 bytes) 2013-12-16 22:53
csv file icon central_1401908650.csv [^] (121 bytes) 2014-06-05 11:11
csv file icon limeSurvey_2_invitation.csv [^] (456 bytes) 2014-06-05 11:11
csv file icon limeSurvey_2_invitation_modifs.csv [^] (244 bytes) 2014-06-05 11:11

- Relationships
related to 09078closedDenisChenu CSV export of particiapnt DB can make invalid CSV file 
child of 08447closedMazi Partcipant DB : outdated documentation 

-  Notes
User avatar (27556)
DenisChenu (developer)
2013-12-12 19:01

Hi,

Think email is allways linked to email ?
When you import, did you have email imported ?

I don't use a lot participant DB.
User avatar (27557)
KitchM (reporter)
2013-12-12 22:26

Sorry, I don't understand. Database does contain an email field. Are you suggesting to import the file as it is, even though it does not display an email field?
User avatar (27558)
DenisChenu (developer)
2013-12-13 08:17
edited on: 2013-12-13 08:24

Yes,

Because i think email fiels is set automatically to email field.

Look at http://manual.limesurvey.org/Central_participants_database_%28User_panel%29_Development#lime_participants [^] . This documentation is outdated, but you can try and update documentation, please.

Denis

User avatar (27562)
KitchM (reporter)
2013-12-13 19:37

Assuming your implecation was correct, I just went ahead and imported the records. However, ther results were less than convincing. Please review the screenshot.
User avatar (27563)
DenisChenu (developer)
2013-12-14 14:08

OK,

Seems confirmed there are a real lack of documentation and information from CDB.

Seems mandatory fields was : firstname,lastname,email and participant_id

And check duplicate was done with participant_id
                if ((!in_array('firstname', $firstline) && !in_array('lastname', $firstline) && !in_array('email', $firstline)) && !in_array('participant_id', $firstline))
                {
                    $recordcount = count($tokenlistarray);
                    break;
                }
This must be rewrited, but first documented.

Denis
User avatar (27566)
KitchM (reporter)
2013-12-16 02:26

Obviously, it doesn't work the way it is.
User avatar (27567)
DenisChenu (developer)
2013-12-16 08:30

Can you upload your CSV file for testing purpose ? With only one line for participant.
User avatar (27570)
KitchM (reporter)
2013-12-16 18:43

Sadly, no. I'm dealing with sensitive corporate data, and I cannot let it out.

But please tell me your thoughts on the subject. What are you looking for exactly?
User avatar (27571)
DenisChenu (developer)
2013-12-16 19:36

You can remove whole information, just pur an line with some data.

Maybe some problem with excel/CSV or something other.
User avatar (27572)
KitchM (reporter)
2013-12-16 22:52

Okay, I'm attaching a sample file created from the original. I only opened it in Excel and deleted 515 records, leaving one that I changed to false information. Then I saved it as CSV again.
User avatar (27592)
DenisChenu (developer)
2013-12-17 16:04

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=13584 [^]
User avatar (27593)
DenisChenu (developer)
2013-12-17 16:06

Hi,

Your CSV file don't have NEEDED header :
firstname,lastname and email

Writing like this (not in capital).

Anyway : i do some fix here.
Can upload a file without firstname,lastname and email (if you don't check Filter blank email addresses: ).

Here: it's an exported file ?
User avatar (27594)
DenisChenu (developer)
2013-12-17 16:07

PS: you see : 518 records have EMPTY mandatory fields : the explanation is here.
And if you look at "import file" you see:
 Mandatory fields: firstname, lastname, email
User avatar (27596)
KitchM (reporter)
2013-12-17 17:43

Please change the coding so that it will recognize these regardless of case.
User avatar (27601)
DenisChenu (developer)
2013-12-18 12:08

Please : it's a feature request, not a bug.

Participant_DB is constructed like this actually.

Need complete rewrite to be really fixed.
User avatar (27608)
KitchM (reporter)
2013-12-18 16:02

Ouch!

Why have a section for selection and arrangement of fields if it is so specific? It is counterintuitive from the user's viewpoint.
User avatar (27611)
DenisChenu (developer)
2013-12-18 16:21

Again : Need complete rewrite to be really fixed.

Move it to Feature, sorry.
User avatar (27614)
KitchM (reporter)
2013-12-18 16:45

Oh well. Can't get back into it anyway. Just give blank screen.
User avatar (30054)
riqcles (reporter)
2014-06-05 11:14

I tried several method.
  from the demo site.

  Method 1: Use the format of central database management

  I export a csv file, then I delete the records, except one.
  After I re-import -> not happening.
  I retry deleting the information in the "participant_id" column -> not pass.

  Method 2: Using a "classic" of invitation csv file
  I import with all columns -> not pass
  I import the file with 3 minimum information:
  firstname, lastname, email -> not pass
User avatar (30055)
riqcles (reporter)
2014-06-05 11:15

tested on a Postgres 9.1 database also
User avatar (30091)
DenisChenu (developer)
2014-06-11 18:02

Not this issue.

2 issue :
http://bugs.limesurvey.org/view.php?id=9078 [^] for the export DB
http://bugs.limesurvey.org/view.php?id=8462 [^] for empty firstname/lastname

- Related Changesets
LimeSurvey: master 1e23dcce
Timestamp: 2013-12-17 15:03:52
Author: DenisChenu
Committer: Denis Chenu
Details ] Diff ]
Fixed issue 08444: Participant DB : CSV Import Fails To Display All Fields
Dev: This part need complete rewriting actually ...
Dev: quick fix to import with only email
Dev: fix lot of HTML issue
mod - application/controllers/admin/participantsaction.php Diff ] File ]
mod - application/views/admin/participants/attributeMapCSV_view.php Diff ] File ]
mod - application/views/admin/participants/uploadSummary_view.php Diff ] File ]

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2013-12-11 21:59 KitchM New Issue
2013-12-11 21:59 KitchM File Added: Screenshot - 12112013 - 03:19:04 PM - LimeSurvey showing Field Selection page.png
2013-12-12 18:59 DenisChenu Summary CSV Import Fails To Display All Fields => Participant DB : CSV Import Fails To Display All Fields
2013-12-12 19:01 DenisChenu Note Added: 27556
2013-12-12 22:26 KitchM Note Added: 27557
2013-12-13 08:17 DenisChenu Note Added: 27558
2013-12-13 08:23 DenisChenu Relationship added child of 08447
2013-12-13 08:24 DenisChenu Note Edited: 27558 View Revisions
2013-12-13 19:37 KitchM Note Added: 27562
2013-12-13 19:37 KitchM File Added: Screenshot - 12132013 - 01:34:58 PM - LimeSurvey import failure with empty fields.png
2013-12-13 19:39 KitchM File Added: Screenshot - 12132013 - 01:37:52 PM - LimeSurvey shows no participants.png
2013-12-14 14:08 DenisChenu Note Added: 27563
2013-12-16 02:26 KitchM Note Added: 27566
2013-12-16 08:30 DenisChenu Note Added: 27567
2013-12-16 10:33 c_schmitz Assigned To => DenisChenu
2013-12-16 10:33 c_schmitz Status new => feedback
2013-12-16 18:43 KitchM Note Added: 27570
2013-12-16 18:43 KitchM Status feedback => assigned
2013-12-16 19:36 DenisChenu Note Added: 27571
2013-12-16 22:52 KitchM Note Added: 27572
2013-12-16 22:53 KitchM File Added: test.csv
2013-12-17 16:04 DenisChenu Changeset attached => LimeSurvey master 1e23dcce
2013-12-17 16:04 DenisChenu Note Added: 27592
2013-12-17 16:04 DenisChenu Resolution open => fixed
2013-12-17 16:06 DenisChenu Note Added: 27593
2013-12-17 16:06 DenisChenu Status assigned => resolved
2013-12-17 16:06 DenisChenu Fixed in Version => 2.05+
2013-12-17 16:07 DenisChenu Note Added: 27594
2013-12-17 17:43 KitchM Note Added: 27596
2013-12-18 12:08 DenisChenu Note Added: 27601
2013-12-18 16:02 KitchM Note Added: 27608
2013-12-18 16:21 DenisChenu Note Added: 27611
2013-12-18 16:21 DenisChenu Project Bug reports => Feature requests
2013-12-18 16:22 DenisChenu Status resolved => feedback
2013-12-18 16:22 DenisChenu Resolution fixed => reopened
2013-12-18 16:22 DenisChenu Assigned To DenisChenu =>
2013-12-18 16:22 DenisChenu Assigned To => DenisChenu
2013-12-18 16:22 DenisChenu Status feedback => new
2013-12-18 16:22 DenisChenu Assigned To DenisChenu =>
2013-12-18 16:22 DenisChenu Priority high => normal
2013-12-18 16:22 DenisChenu Severity block => feature
2013-12-18 16:45 KitchM Note Added: 27614
2014-06-05 11:11 riqcles File Added: central_1401908650.csv
2014-06-05 11:11 riqcles File Added: limeSurvey_2_invitation.csv
2014-06-05 11:11 riqcles File Added: limeSurvey_2_invitation_modifs.csv
2014-06-05 11:14 riqcles Note Added: 30054
2014-06-05 11:15 riqcles Note Added: 30055
2014-06-06 17:50 DenisChenu Assigned To => DenisChenu
2014-06-06 17:50 DenisChenu Status new => assigned
2014-06-08 20:22 DenisChenu Project Feature requests => Bug reports
2014-06-11 18:01 DenisChenu Relationship added related to 09078
2014-06-11 18:02 DenisChenu Note Added: 30091
2014-06-11 18:02 DenisChenu Status assigned => closed
2014-06-11 18:02 DenisChenu Resolution reopened => fixed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker