LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
08325Bug reports[All Projects] Otherpublic2013-10-31 14:542014-02-04 13:32
Reporterolegb 
Assigned ToDenisChenu 
PriorityhighSeveritymajor 
StatusclosedResolutionfixed 
Product Version2.00+ 
Target VersionFixed in Version2.05+ 
Summary08325: Part of long text is hidden in Ranking form (MS Internet Explorer)
DescriptionWhen I open Ranking question in MS Internet Explorer 8 or 10, part of answer text is hidden under the next answer (see attachment) When I open this question in Firefox all is OK.
Steps To ReproduceCreate ranking question.
Add long answers.
Test this question.
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit ID2.00+ build131022
Browser
Database & DB-VersionMySQL 5.1.69
Operating System (Server)RedHat 6
Webserver software & versionAoache 2.2
PHP VersionPHP 5.4
Attached Filespdf file icon Limesurvey.pdf [^] (102,803 bytes) 2013-10-31 14:55
? file icon limesurvey_survey_329724.lss [^] (13,569 bytes) 2013-11-04 12:27
png file icon ie_10.png [^] (18,452 bytes) 2013-11-07 16:03

- Relationships
related to 08636closedDenisChenu Templates and admin interface - Internet Explorer 9 

-  Notes
User avatar (27065)
tpartner (developer)
2013-11-01 12:12

olegb, I cannot reproduce the problem.

What template are you using?

Can you please attach a sample survey so I can see exactly what settings you are using?
User avatar (27079)
olegb (reporter)
2013-11-04 12:28

Hello,
I've attached sample survey. I use basic template.
User avatar (27142)
tpartner (developer)
2013-11-07 16:04

Sorry, still can't reproduce the problem. See my screenshot - ie_10.png. It looks the same in IE8 and IE9.
User avatar (27185)
olegb (reporter)
2013-11-13 15:04

Hello,
This functionality doesn't work in Internet Explorer compatibility view. Please enable Compatibility view in IE Tools and check my test survey.
User avatar (27186)
tpartner (developer)
2013-11-13 15:09

Why would you enable Compatibility view?
User avatar (27187)
olegb (reporter)
2013-11-13 17:46

It's default setting in IE Compatibility View Settings : Display Intranet sites in Compatibility View. This functionality (Ranking questions) worked fine also in Compatibility View in previous versions.
User avatar (27249)
olegb (reporter)
2013-11-20 13:24

It's not easy to disable this setting in our organization.
User avatar (27301)
DenisChenu (developer)
2013-11-21 18:13
edited on: 2013-11-21 18:14

Hi,

IE10 compatibility view is buggy, because it work on IE8/IE9 ......

PS: try to deactivate "same heigth for all choice".
PS2: think we can not fix this : it's a IE bug.

User avatar (27699)
tpartner (developer)
2013-12-26 14:10

I agree - compatibility mode effectively reverts to IE 6/7 (and buggy at that) which I don't think we can support.

Carsten?
User avatar (27701)
DenisChenu (developer)
2013-12-26 16:34
edited on: 2013-12-26 16:36

Maybe:

<!--[if IE]>
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<![endif]-->

?

@olegb : can you give it a try with a updated template ?

PS: https://github.com/h5bp/html5-boilerplate/blob/master/index.html#L5 [^]

User avatar (27775)
c_schmitz (administrator)
2014-01-08 17:33

@olegb : Did you try to insert that statement into your template header? Does it change anything?
User avatar (27842)
c_schmitz (administrator)
2014-01-14 00:47

@olegb: Feedback please?
User avatar (27948)
c_schmitz (administrator)
2014-01-17 13:39

Closing due to missing feedback. After reading up on <meta http-equiv="X-UA-Compatible" content="IE=edge" /> I don't think it will make any difference in the intranet-mode as the policy will prevent to change the rendering mode.
User avatar (28377)
DenisChenu (developer)
2014-02-01 17:00

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=13811 [^]
User avatar (28439)
DenisChenu (developer)
2014-02-03 12:33

Thanks @riqcles
User avatar (28502)
c_schmitz (administrator)
2014-02-04 13:32

Version 2.05+ Build 140204 released

- Related Changesets
LimeSurvey: master bb0a1b29
Timestamp: 2014-02-01 15:59:56
Author: DenisChenu
Committer: Denis Chenu
Details ] Diff ]
Fixed issue 08636 : Deactivate IE compatibility view on Admin and public template
Dev: X-UA-Compatible edge to be sure to use last for all IE
Dev: To be confirmed : fix 08325: Part of long text is hidden in Ranking form (MS Internet Explorer)
Dev: to be confirmed : fix 08635: Adding answer options impossible in IE9
mod - application/views/admin/super/header.php Diff ] File ]
mod - application/views/layouts/main.php Diff ] File ]
mod - templates/basic/startpage.pstpl Diff ] File ]
mod - templates/bluengrey/startpage.pstpl Diff ] File ]
mod - templates/citronade/startpage.pstpl Diff ] File ]
mod - templates/clear_logo/startpage.pstpl Diff ] File ]
mod - templates/default/startpage.pstpl Diff ] File ]
mod - templates/eirenicon/startpage.pstpl Diff ] File ]
mod - templates/limespired/startpage.pstpl Diff ] File ]
mod - templates/mint_idea/startpage.pstpl Diff ] File ]
mod - templates/sherpa/startpage.pstpl Diff ] File ]
mod - templates/vallendar/startpage.pstpl Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-10-31 14:54 olegb New Issue
2013-10-31 14:55 olegb File Added: Limesurvey.pdf
2013-11-01 11:39 c_schmitz Assigned To => tpartner
2013-11-01 11:39 c_schmitz Status new => assigned
2013-11-01 12:12 tpartner Note Added: 27065
2013-11-04 12:27 olegb File Added: limesurvey_survey_329724.lss
2013-11-04 12:28 olegb Note Added: 27079
2013-11-07 16:03 tpartner File Added: ie_10.png
2013-11-07 16:04 tpartner Note Added: 27142
2013-11-13 15:04 olegb Note Added: 27185
2013-11-13 15:09 tpartner Note Added: 27186
2013-11-13 17:46 olegb Note Added: 27187
2013-11-20 13:24 olegb Note Added: 27249
2013-11-21 18:13 DenisChenu Note Added: 27301
2013-11-21 18:14 DenisChenu Note Edited: 27301 View Revisions
2013-12-26 14:10 tpartner Note Added: 27699
2013-12-26 14:11 tpartner Assigned To tpartner => c_schmitz
2013-12-26 16:34 DenisChenu Note Added: 27701
2013-12-26 16:34 DenisChenu Note Edited: 27701 View Revisions
2013-12-26 16:36 DenisChenu Note Edited: 27701 View Revisions
2014-01-08 17:33 c_schmitz Note Added: 27775
2014-01-08 17:33 c_schmitz Status assigned => feedback
2014-01-14 00:47 c_schmitz Note Added: 27842
2014-01-17 13:39 c_schmitz Note Added: 27948
2014-01-17 13:39 c_schmitz Status feedback => closed
2014-01-17 13:39 c_schmitz Resolution open => fixed
2014-01-31 15:48 DenisChenu Relationship added related to 08636
2014-02-01 17:00 DenisChenu Changeset attached => LimeSurvey master bb0a1b29
2014-02-01 17:00 DenisChenu Note Added: 28377
2014-02-01 17:00 DenisChenu Assigned To c_schmitz => DenisChenu
2014-02-03 12:32 DenisChenu Status closed => feedback
2014-02-03 12:32 DenisChenu Resolution fixed => reopened
2014-02-03 12:33 DenisChenu Note Added: 28439
2014-02-03 12:33 DenisChenu Status feedback => resolved
2014-02-03 12:33 DenisChenu Fixed in Version => 2.05+
2014-02-03 12:33 DenisChenu Resolution reopened => fixed
2014-02-04 13:32 c_schmitz Note Added: 28502
2014-02-04 13:32 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker