LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
06646Bug reports[All Projects] Survey takingpublic2012-10-04 16:172012-10-15 11:28
Reporterdocl 
Assigned Toc_schmitz 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
Product Version2.00+ 
Target VersionFixed in Version2.00+ 
Summary06646: HTML entities shown when answering survey and not filling out mandatory questions (all languages)
DescriptionWhen answering a survey and not filling out mandatory questions, the text
"If you choose 'Other:' you must provide a description."
is shown WITH html entities (instead of "If you choose "Other:" you must provide a description.")

This applies to all languages and is not resolved by using escape character \" in the language file. Workaround is of course to change " to something else (eg space or ยด) that is not an HTML entity, in locale file.
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit ID121002
Browser
Database & DB-VersionMySQL 5.1.63-0+squeeze1
Operating System (Server)Linux
Webserver software & versionApache/2.2.16 (Debian)
PHP Version5.3.17
Attached Filespng file icon Capture du 2012-10-05 09:03:30.png [^] (15,938 bytes) 2012-10-05 09:09


png file icon Capture du 2012-10-05 09:03:43.png [^] (19,288 bytes) 2012-10-05 09:10

- Relationships
duplicate of 06593closedDenisChenu Displays HTML Quote 
duplicate of 06550closedDenisChenu Translation of 'Other:' comment mandatory for survey taking (And text is untranslatable) 

-  Notes
User avatar (21038)
docl (reporter)
2012-10-04 19:56

This might be an ugly way of solving it, but I replaced

$mandatoryTip .= "
\n".sprintf($LEM->gT("If you choose '%s' you must provide a description."), $othertext);

with

$mandatoryTip .= "
\n".html_entity_decode(sprintf($LEM->gT("If you choose '%s' you must provide a description."), $othertext));

in application\helpers\expressions\em_manager_helper.php
User avatar (21045)
DenisChenu (developer)
2012-10-05 09:08
edited on: 2012-10-05 09:13

Hello,

Can you try with : http://git.io/fvhAXw [^]

See the 2 picture:
Arabic are already translated
French are untranslated
(please put resolved if it's OK)

User avatar (21058)
DenisChenu (developer)
2012-10-05 12:05

Fixed issue: 06646 : HTML entities shown when answering survey and not filling a mandatory Multiple choice questions

https://github.com/LimeSurvey/LimeSurvey/commit/8e872cf2e6f25782aca9af44bdd62fcc96bbdcbb [^]

Sorry for my mistake, i look only for single question type (with other_comment_mandatory)
User avatar (21067)
c_schmitz (administrator)
2012-10-05 15:26

New version 2.00+ build 121005 released.
User avatar (21176)
mdekker (developer)
2012-10-10 15:54

Issue also present in 1.92 http://www.limesurvey.org/en/forum/design-issues/84862-html-entities-showing-on-error-message [^]

Considering the amount of fixes still going on for 2.0 branch, please consider updating 1.92 (what i did was in qanda.php apply the html_enitity_decode). If not updating, maybe a patched qanda.php attached to this bug might be helpful?
User avatar (21178)
DenisChenu (developer)
2012-10-10 15:57

Memno : maybe you're right, but before, we add to look at all important bug for 192 :).

Denis
User avatar (21316)
c_schmitz (administrator)
2012-10-15 11:28

If you could attached a fixed file for 1.92, that would be great.
In general I think that 2.0 is stable enough to upgrade now.

- Issue History
Date Modified Username Field Change
2012-10-04 16:17 docl New Issue
2012-10-04 19:56 docl Note Added: 21038
2012-10-05 08:57 c_schmitz Assigned To => DenisChenu
2012-10-05 08:57 c_schmitz Status new => assigned
2012-10-05 09:08 DenisChenu Note Added: 21045
2012-10-05 09:09 DenisChenu File Added: Capture du 2012-10-05 09:03:30.png
2012-10-05 09:10 DenisChenu File Added: Capture du 2012-10-05 09:03:43.png
2012-10-05 09:11 DenisChenu Relationship added duplicate of 06593
2012-10-05 09:12 DenisChenu Relationship added duplicate of 06550
2012-10-05 09:13 DenisChenu Note Edited: 21045 View Revisions
2012-10-05 12:05 DenisChenu Note Added: 21058
2012-10-05 12:05 DenisChenu Status assigned => resolved
2012-10-05 12:05 DenisChenu Fixed in Version => 2.00+
2012-10-05 12:05 DenisChenu Resolution open => fixed
2012-10-05 15:26 c_schmitz Note Added: 21067
2012-10-05 15:26 c_schmitz Status resolved => closed
2012-10-10 15:54 mdekker Assigned To DenisChenu => c_schmitz
2012-10-10 15:54 mdekker Note Added: 21176
2012-10-10 15:54 mdekker Status closed => feedback
2012-10-10 15:54 mdekker Resolution fixed => reopened
2012-10-10 15:57 DenisChenu Note Added: 21178
2012-10-15 11:28 c_schmitz Note Added: 21316
2012-10-15 11:28 c_schmitz Status feedback => closed
2012-10-15 11:28 c_schmitz Resolution reopened => fixed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker