LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
08899Bug reports[All Projects] Tokenspublic2014-03-24 15:092014-04-17 09:29
ReporterMazi 
Assigned ToDenisChenu 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
Product Version2.05+ 
Target Version2.05+Fixed in Version 
Summary08899: When importing token data from CSV file the invitation date is ignored
DescriptionWhen importing token data from CSV file the invitation date is ignored and set to "N" even though a correct date exist.
Steps To ReproduceImport the attached token file.
Additional InformationThis problem also occurs at Limesurvey 2.0 build 131206
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit ID131206
BrowserGoogle Chrome
Database & DB-VersionMySQL 5
Operating System (Server)Linux
Webserver software & versionApache
PHP Version5.3
Attached Filescsv file icon tokens_657996.csv [^] (226 bytes) 2014-03-24 15:09

- Relationships
parent of 08961closedDenisChenu importing tokens: 2 "new" fields "Email status" and "Language" not filled causes bug on send email invitations 

-  Notes
User avatar (29548)
DenisChenu (developer)
2014-03-26 18:58
edited on: 2014-03-26 18:59

It's in concept [*] .....

Remove : ,'completed','invited','reminded','remindercount'

And don't remove 'usesleft' ... silly

Think i add 2 option:
- Reset Token status
- Reset email status

Token status : remove usesleft and completed
Email status : remove 'invited','reminded','remindercount'

Your advice for the language string ?

* A really silly concept, i understand now why i have problem when importing completed token .... really silly concept

User avatar (29549)
Mazi (developer)
2014-03-26 19:34

Denis, I would NOT create any additional setting for this at all. If the date exist, it should be imported.
Same for all other data sets listed above.
User avatar (29551)
DenisChenu (developer)
2014-03-27 08:44

Yes, but i think some user need 'resetting',

If i put a new function 'import token' => i don't update anything when importing (leave whole date and state), but actually it's the case since 1.92 (and surely before).

$allowedfieldnames=array('firstname','lastname','email','emailstatus','token','language', 'validfrom', 'validuntil', 'usesleft');

We can not change this without control.
User avatar (29559)
c_schmitz (administrator)
2014-03-27 10:07

I think too that such a function (additional setting) would make more sense if it is part of the survey grid (indeed it was in the past but was lost).
User avatar (29562)
DenisChenu (developer)
2014-03-27 10:14

I make a quick fix for 2.05 : just disallow tid.
All other can be imported, i just try with bad information in date to see if we have to fix it.

If user want to reset completes : he can remove the column before upload.

For 2.06:
- Token import need to be updated : use Yii token model
- Add the reset function
User avatar (29564)
Mazi (developer)
2014-03-27 10:42

Sounds good, thanks!
User avatar (29566)
DenisChenu (developer)
2014-03-27 10:57

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=14076 [^]
User avatar (29567)
DenisChenu (developer)
2014-03-27 10:58
edited on: 2014-03-27 10:58

According to dev discussion : don't remove any exitng field except tid .;
This allow to import invited/sent to 'DONT SEND' ;)

User avatar (29664)
c_schmitz (administrator)
2014-04-04 10:26

2.05+ Build 140404 released.

- Related Changesets
LimeSurvey: master 7461a732
Timestamp: 2014-03-27 09:56:59
Author: DenisChenu
Committer: Denis Chenu
Details ] Diff ]
Fixed issue 08899: When importing token data from CSV file the invitation date is ignored
Fixed issue : unable to redisplay duplcate token attribute
Dev: Just remove tid when importing
Dev: Update insert SQL to use Yii
mod - application/controllers/admin/tokens.php Diff ] File ]
mod - scripts/admin/tokens.js Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-03-24 15:09 Mazi New Issue
2014-03-24 15:09 Mazi File Added: tokens_657996.csv
2014-03-26 10:56 DenisChenu Assigned To => DenisChenu
2014-03-26 10:56 DenisChenu Status new => assigned
2014-03-26 18:58 DenisChenu Note Added: 29548
2014-03-26 18:59 DenisChenu Note Edited: 29548 View Revisions
2014-03-26 19:34 Mazi Note Added: 29549
2014-03-27 08:44 DenisChenu Note Added: 29551
2014-03-27 10:07 c_schmitz Note Added: 29559
2014-03-27 10:14 DenisChenu Note Added: 29562
2014-03-27 10:42 Mazi Note Added: 29564
2014-03-27 10:57 DenisChenu Changeset attached => LimeSurvey master 7461a732
2014-03-27 10:57 DenisChenu Note Added: 29566
2014-03-27 10:57 DenisChenu Resolution open => fixed
2014-03-27 10:58 DenisChenu Note Added: 29567
2014-03-27 10:58 DenisChenu Status assigned => resolved
2014-03-27 10:58 DenisChenu Note Edited: 29567 View Revisions
2014-04-04 10:26 c_schmitz Note Added: 29664
2014-04-04 10:26 c_schmitz Status resolved => closed
2014-04-17 09:29 DenisChenu Relationship added parent of 08961


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker