LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
08526Bug reports[All Projects] Installationpublic2014-01-10 11:442014-02-26 13:32
ReporterDenisChenu 
Assigned ToDenisChenu 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
Product Version2.05+ 
Target VersionFixed in Version2.05+ 
Summary08526: No information if installation broke
DescriptionWhen trying to install with a PHP version < 5.3 : we have only a blank page.
No information.
Steps To ReproduceFind a server with php version < 5.3 and try a new install of 2.05 or upgrade ....
Additional Information Parse error: syntax error, unexpected T_FUNCTION in /master/application/helpers/ClassFactory.php on line 31

We can have this with:
    if (!isset($aSettings['config']['debug']) || $aSettings['config']['debug']>0)
in index.php

(Set debug mode when installing ...,
maybe JUST error_reporting(E_ERROR | E_PARSE); to broken installation)
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit ID130110
Browsernot relevant
Database & DB-Versionnot relevant
Operating System (Server)linux
Webserver software & versionapache
PHP VersionPHP Version 5.2.17
Attached Files

- Relationships

-  Notes
User avatar (27816)
DenisChenu (developer)
2014-01-10 12:08
edited on: 2014-01-17 09:06

See :
https://www.limesurvey.org/en/forum/installation-a-update-issues/95375-installation-limesurvey205-build131209-blank-page [^]

And other forum post too

Main question is : did we set 5.3 need for LS ?

User avatar (27938)
c_schmitz (administrator)
2014-01-17 09:20

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=13701 [^]
User avatar (27940)
c_schmitz (administrator)
2014-01-17 09:37

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=13702 [^]
User avatar (27944)
DenisChenu (developer)
2014-01-17 10:12

OK, then 5.3
User avatar (28167)
c_schmitz (administrator)
2014-01-25 17:22

2.05+ Build 140125 released
User avatar (28804)
DenisChenu (developer)
2014-02-18 08:51

Re open for "No information if installation broke"
See: http://www.limesurvey.org/en/forum/installation-a-update-issues/96063-blank-screen-on-install-php-5-3-17#105165 [^]

It's more to get some information in any situation:
Update this line of index.php
    if (isset($aSettings['config']['debug']) && $aSettings['config']['debug']>0)
To
    if (!isset($aSettings['config']['debug']) || $aSettings['config']['debug']>0)
User avatar (28908)
c_schmitz (administrator)
2014-02-25 16:22

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=13931 [^]
User avatar (28911)
DenisChenu (developer)
2014-02-25 16:28

Thanks , but don't fix information for jamesm1470 (the firts on topic : PHP 5.3.17, then another error somewhere).

Seems some user don't upload all file too (one or 2 forum post), if we force error_reporting(1); this user have some information to fix themself :).
User avatar (28916)
c_schmitz (administrator)
2014-02-25 17:13

Please add it :-)
User avatar (28926)
DenisChenu (developer)
2014-02-26 10:55

Have a better idea (i think)

- If not set : do nothing : then webmaster default seetings apply (PHP default : E_ALL ^ E_NOTICE)
- Is set : same think than actually
User avatar (28928)
DenisChenu (developer)
2014-02-26 11:11

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=13934 [^]
User avatar (28929)
DenisChenu (developer)
2014-02-26 11:13

PS: PHP<5.3 need a die : else :
 Parse error: syntax error, unexpected T_FUNCTION in ./application/helpers/ClassFactory.php on line 31

(or blank page without last commit)
User avatar (28933)
c_schmitz (administrator)
2014-02-26 13:32

2.05+ Build 140226 released

- Related Changesets
LimeSurvey: master 1a45b818
Timestamp: 2014-01-17 08:20:33
Author: c_schmitz
Committer: Carsten Schmitz
Details ] Diff ]
Fixed issue 08526: No information when trying to install with php < 5.3
mod - application/core/LSYii_Controller.php Diff ] File ]
LimeSurvey: master aa1806ca
Timestamp: 2014-01-17 08:37:38
Author: c_schmitz
Committer: Carsten Schmitz
Details ] Diff ]
Fixed issue 08526: No information when trying to install with php < 5.3
mod - application/controllers/InstallerController.php Diff ] File ]
LimeSurvey: master 4dafeb1f
Timestamp: 2014-02-25 15:21:45
Author: c_schmitz
Committer: Carsten Schmitz
Details ] Diff ]
Fixed issue 08526: Blank screen if minimum PHP version requirement is not met
mod - index.php Diff ] File ]
LimeSurvey: master 8543ea87
Timestamp: 2014-02-26 10:11:17
Author: DenisChenu
Committer: Denis Chenu
Details ] Diff ]
Fixed issue 08526: No information if installation broke
Dev: with PHP<5.3 need a die because we load application/helpers/ClassFactory.php before have information
mod - index.php Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-01-10 11:44 DenisChenu New Issue
2014-01-10 11:45 DenisChenu Additional Information Updated View Revisions
2014-01-10 12:08 DenisChenu Note Added: 27816
2014-01-17 08:19 DenisChenu Relationship added has duplicate 08550
2014-01-17 09:06 DenisChenu Note Edited: 27816 View Revisions
2014-01-17 09:06 DenisChenu Note Edited: 27816 View Revisions
2014-01-17 09:19 c_schmitz Assigned To => c_schmitz
2014-01-17 09:19 c_schmitz Status new => assigned
2014-01-17 09:20 c_schmitz Changeset attached => LimeSurvey master 1a45b818
2014-01-17 09:20 c_schmitz Note Added: 27938
2014-01-17 09:20 c_schmitz Resolution open => fixed
2014-01-17 09:20 c_schmitz Status assigned => resolved
2014-01-17 09:20 c_schmitz Fixed in Version => 2.05+
2014-01-17 09:37 c_schmitz Changeset attached => LimeSurvey master aa1806ca
2014-01-17 09:37 c_schmitz Note Added: 27940
2014-01-17 10:12 DenisChenu Note Added: 27944
2014-01-25 17:22 c_schmitz Note Added: 28167
2014-01-25 17:22 c_schmitz Status resolved => closed
2014-02-18 08:51 DenisChenu Note Added: 28804
2014-02-18 08:51 DenisChenu Status closed => feedback
2014-02-18 08:51 DenisChenu Resolution fixed => reopened
2014-02-18 08:51 DenisChenu Summary No information when trying to install with php < 5.3 => No information if installation broke
2014-02-25 16:21 c_schmitz Status feedback => resolved
2014-02-25 16:21 c_schmitz Resolution reopened => fixed
2014-02-25 16:22 c_schmitz Changeset attached => LimeSurvey master 4dafeb1f
2014-02-25 16:22 c_schmitz Note Added: 28908
2014-02-25 16:28 DenisChenu Note Added: 28911
2014-02-25 17:13 c_schmitz Assigned To c_schmitz => DenisChenu
2014-02-25 17:13 c_schmitz Status resolved => assigned
2014-02-25 17:13 c_schmitz Note Added: 28916
2014-02-26 10:55 DenisChenu Note Added: 28926
2014-02-26 11:11 DenisChenu Changeset attached => LimeSurvey master 8543ea87
2014-02-26 11:11 DenisChenu Note Added: 28928
2014-02-26 11:11 DenisChenu Status assigned => resolved
2014-02-26 11:13 DenisChenu Note Added: 28929
2014-02-26 13:32 c_schmitz Note Added: 28933
2014-02-26 13:32 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker