LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
08515Bug reports[All Projects] Survey takingpublic2014-01-07 13:192014-01-09 23:31
Reportertpartner 
Assigned ToDenisChenu 
PrioritynormalSeveritymajor 
StatusclosedResolutionfixed 
Product Version2.05+ 
Target Version2.05+Fixed in Version2.05+ 
Summary08515: Language switcher does not work in token registration form
DescriptionLanguage switcher does not work in token registration form
Steps To ReproduceUpload attached survey
Test survey and try to switch language in the registration screen
Additional InformationThis was broken in 1.92, fixed in 2.0 and is now broken again. Can anyone shed some light on why the functionality of the language switcher select was changed?
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit ID769eca5f993cb7ba0a896fc36f03
BrowserFF
Database & DB-VersionN/A
Operating System (Server)N/A
Webserver software & versionN/A
PHP VersionN/A
Attached Files? file icon limesurvey_survey_926833.lss [^] (21,500 bytes) 2014-01-07 13:19

- Relationships

-  Notes
User avatar (27729)
tpartner (developer)
2014-01-07 14:00

Denis, your fix to survey_runtime.js on 02/01/2014 seems to have broken this :)
User avatar (27730)
DenisChenu (developer)
2014-01-07 14:31
edited on: 2014-01-07 14:52

OK, i try to fix another one with old template ...

I revert or search for a beter way

Token registration form use form#limesurvey too ....

User avatar (27733)
DenisChenu (developer)
2014-01-07 15:22

It's not JS ... i send 'lang' now, but same think ...
User avatar (27734)
DenisChenu (developer)
2014-01-07 16:36

@tpartner : Can anyone shed some light on why the functionality of the language switcher select was changed?

Answer is here : http://bugs.limesurvey.org/view.php?id=7967 [^]
User avatar (27735)
DenisChenu (developer)
2014-01-07 16:40

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=13650 [^]
User avatar (27736)
DenisChenu (developer)
2014-01-07 16:46

Updated to use existing form (if exist)
Maybe it's better to use allways $_GET for token and register ?
But then need removing existing lang param in URL.

What do you think Tony : better in $_GET or in $_POST ?

Before it's only by url : no get or post, but http://bugs.limesurvey.org/view.php?id=7967 [^]
User avatar (27737)
tpartner (developer)
2014-01-07 17:12

Hi Denis,

The language now switches correctly but, since you are submitting the "register" form, the CAPTCHA warning appears after the switch.
User avatar (27738)
DenisChenu (developer)
2014-01-07 17:23
edited on: 2014-01-07 17:24

Yes ...

Surely better in $_GET then. But if you have already a /lang/fr in URL : getParam don't get the good param.

But we can have lang-fr or /lang/fr or &lang=fr or ?lang=fr

Did you have an idea to remove it in JS ?

PS: another alternative is to add a data-submit="UrlOfSurveyController" in the select or in the button.
Then we can add directly it to this url.

User avatar (27739)
DenisChenu (developer)
2014-01-07 17:39

Got it, add to test with preview to see if it's OK.
User avatar (27740)
DenisChenu (developer)
2014-01-07 17:53

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=13652 [^]
User avatar (27741)
DenisChenu (developer)
2014-01-07 17:54

Tony : 2nd fix : working in preview/token/register and in survey even if {LANGUAGECHANGER} is not at the good place.
User avatar (27742)
tpartner (developer)
2014-01-07 18:12

You got it :)
User avatar (27745)
DenisChenu (developer)
2014-01-07 19:25

JS needed for change language in token and register.
User avatar (27804)
c_schmitz (administrator)
2014-01-09 23:31

2.05+ build 140109 released

- Related Changesets
LimeSurvey: master 5d88fbd6
Timestamp: 2014-01-07 15:40:15
Author: DenisChenu
Committer: Denis Chenu
Details ] Diff ]
Fixed issue 08515: Language switcher does not work in token registration form
Dev: lang search for all existing form
Dev: alternative if form don't exist : remove /lang-XX, /lang/XX and lang=XX from url and do it in GET param
Dev: Remove some hardly coded SQL in RegisterController
Dev: remove some uneended code in RegisterController
mod - application/controllers/RegisterController.php Diff ] File ]
mod - application/controllers/survey/index.php Diff ] File ]
mod - scripts/survey_runtime.js Diff ] File ]
LimeSurvey: master 80c3d693
Timestamp: 2014-01-07 16:53:01
Author: DenisChenu
Committer: Denis Chenu
Details ] Diff ]
Dev: refix 08515: Language switcher does not work in token registration form
Dev: use GET if we are no in form, except if #limesurvey for exist or we are not in preview mode
mod - application/helpers/frontend_helper.php Diff ] File ]
mod - scripts/survey_runtime.js Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-01-07 13:19 tpartner New Issue
2014-01-07 13:19 tpartner File Added: limesurvey_survey_926833.lss
2014-01-07 14:00 tpartner Note Added: 27729
2014-01-07 14:00 tpartner Assigned To => DenisChenu
2014-01-07 14:00 tpartner Status new => assigned
2014-01-07 14:31 DenisChenu Note Added: 27730
2014-01-07 14:52 DenisChenu Note Edited: 27730 View Revisions
2014-01-07 15:22 DenisChenu Note Added: 27733
2014-01-07 16:36 DenisChenu Note Added: 27734
2014-01-07 16:40 DenisChenu Changeset attached => LimeSurvey master 5d88fbd6
2014-01-07 16:40 DenisChenu Note Added: 27735
2014-01-07 16:40 DenisChenu Resolution open => fixed
2014-01-07 16:46 DenisChenu Note Added: 27736
2014-01-07 17:12 tpartner Note Added: 27737
2014-01-07 17:23 DenisChenu Note Added: 27738
2014-01-07 17:24 DenisChenu Note Edited: 27738 View Revisions
2014-01-07 17:39 DenisChenu Note Added: 27739
2014-01-07 17:53 DenisChenu Changeset attached => LimeSurvey master 80c3d693
2014-01-07 17:53 DenisChenu Note Added: 27740
2014-01-07 17:54 DenisChenu Note Added: 27741
2014-01-07 18:12 tpartner Note Added: 27742
2014-01-07 19:25 DenisChenu Note Added: 27745
2014-01-07 19:25 DenisChenu Status assigned => resolved
2014-01-07 19:25 DenisChenu Fixed in Version => 2.05+
2014-01-09 23:31 c_schmitz Note Added: 27804
2014-01-09 23:31 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker