LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
08509Bug reports[All Projects] Survey takingpublic2014-01-05 21:292014-01-09 23:31
Reportertpartner 
Assigned Toc_schmitz 
PriorityhighSeveritymajor 
StatusclosedResolutionfixed 
Product Version2.05+ 
Target Version2.05+Fixed in Version2.05+ 
Summary08509: Expression manager inserting <span> elements incorrectly
DescriptionWhen running a survey in "all-in-one", mode values that are piped into the end message and into the end URL are wrapped in span elements.

If the piped value is used in a parameter or attribute it breaks the URL or attribute (see attached screenshot).
Steps To ReproduceCreate a survey (attached)
Run in "all-in-one" mode
Add an equation question
Pipe an expression manager value into the end message or end URL something like "http://somedomain.com/index.php?a={equation1.value}" [^]
Additional InformationNot sure what the fix is but I suspect it is because $staticReplacement returns false at line 1903 of em_core_helper.php. In my opinion, this should always be true in end messages, end URLs and emails.
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit ID33fd96904bc223545e1b8fc7f857
BrowserN/A
Database & DB-VersionN/A
Operating System (Server)N/A
Webserver software & versionN/A
PHP VersionN/A
Attached Files? file icon limesurvey_survey_338692(1).lss [^] (14,014 bytes) 2014-01-05 21:29
png file icon spans_1.png [^] (27,005 bytes) 2014-01-05 21:33

- Relationships
duplicate of 07923closedc_schmitz INSERTANS all-in-one presentation SPAN problem 

-  Notes
User avatar (27720)
tpartner (developer)
2014-01-05 21:39

See discussion in the forum - http://www.limesurvey.org/en/forum/can-i-do-this-with-limesurvey/95479-unnecessary-span-in-the-end-message-box#103100, [^]
User avatar (27750)
TMSWhite (reporter)
2014-01-08 05:19

Tony-

Yes, ensuring that $staticReplacement returns true in end messages, end URLs and emails should do the trick.
User avatar (27762)
tpartner (developer)
2014-01-08 12:43

Great, thanks for the confirmation Tom.
User avatar (27763)
tpartner (developer)
2014-01-08 13:02

Carsten,I'm not sure where is the best place to detect the replacement use-case and set this var. Can I hand this off to you? (or Sam?)
User avatar (27785)
c_schmitz (administrator)
2014-01-09 11:16

Looks like I fixed this in the past for 2.0 but forgot to port the fix. The fix applied to 2.05 is also more complete.
User avatar (27786)
c_schmitz (administrator)
2014-01-09 11:17

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=13663 [^]
User avatar (27800)
c_schmitz (administrator)
2014-01-09 23:31

2.05+ build 140109 released

- Related Changesets
LimeSurvey: master 0730c831
Timestamp: 2014-01-09 10:17:59
Author: c_schmitz
Committer: Carsten Schmitz
Details ] Diff ]
Fixed issue 08509: INSERTANS SPAN problem in end URL/page when using then all-in-one page presentation setting
mod - application/helpers/SurveyRuntimeHelper.php Diff ] File ]
mod - application/helpers/replacements_helper.php Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-01-05 21:29 tpartner New Issue
2014-01-05 21:29 tpartner File Added: limesurvey_survey_338692(1).lss
2014-01-05 21:32 tpartner Description Updated View Revisions
2014-01-05 21:33 tpartner File Added: spans_1.png
2014-01-05 21:39 tpartner Note Added: 27720
2014-01-08 05:19 TMSWhite Note Added: 27750
2014-01-08 12:43 tpartner Note Added: 27762
2014-01-08 13:01 tpartner Assigned To => c_schmitz
2014-01-08 13:01 tpartner Status new => assigned
2014-01-08 13:02 tpartner Note Added: 27763
2014-01-09 11:15 c_schmitz Relationship added duplicate of 07923
2014-01-09 11:16 c_schmitz Note Added: 27785
2014-01-09 11:16 c_schmitz Status assigned => resolved
2014-01-09 11:16 c_schmitz Fixed in Version => 2.05+
2014-01-09 11:16 c_schmitz Resolution open => fixed
2014-01-09 11:17 c_schmitz Changeset attached => LimeSurvey master 0730c831
2014-01-09 11:17 c_schmitz Note Added: 27786
2014-01-09 23:31 c_schmitz Note Added: 27800
2014-01-09 23:31 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker