LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
08489Bug reports[All Projects] Survey designpublic2013-12-24 17:172014-01-16 16:45
Reporterriqcles 
Assigned Toc_schmitz 
PriorityhighSeveritymajor 
StatusclosedResolutionfixed 
Product Version2.00+ 
Target VersionFixed in Version2.05+ 
Summary08489: Non-operational CAPTCHA due backup to resume later.
DescriptionHello everyone,
We discovered a major bug in captcha function related to the backup.

I have attached a questionnaire to the test.
Steps To ReproduceHere are the steps :
1 . create a questionnaire with some questions

2 . In general settings select the Publishing tab

3 . Enable captcha to access the questionnaire.

4 . Enable the questionnaire NOT create table invitation.

5 . Run the questionnaire and answer the captcha

6 . Answer to the first question

7 . Save for later resume : CAUTION
DO NOT GRAB EMAIL ADDRESS .

8 . Copy to clipboard URL access to the questionnaire.

9 . CLOSE the browser ( to remove cookies) !

10 . Open the browser and paste the URL to access the questionnaire.

11 . Reply to captcha

12 . Choose "Resume a saved Questionnaire"

13 . enter the name and password recovery.


From that moment , it returns to the prompt CAPTCHA .
NORMALLY must enter the answer to the addition, BUT WE CAN PUT ANYTHING! !

Access to the questionnaire and we have no saved answers !


Try on the demo version on the site, the same as mine.

If this is not a bug ... :) .

Question: the patch on V2.00 and V2.05 ?
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit IDBuild 131107
BrowserFirefox
Database & DB-VersionPostgresql 9.1 & MYSQL
Operating System (Server)CentOS
Webserver software & versionApache 2.2
PHP Version5.3.x
Attached Files? file icon Erreur_CAPTCHA_limesurvey_survey_984688.lss [^] (17,709 bytes) 2013-12-24 17:17

- Relationships

-  Notes
User avatar (27885)
c_schmitz (administrator)
2014-01-15 14:25

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=13691 [^]
User avatar (27886)
riqcles (reporter)
2014-01-15 16:37

Hello,
correction has been made, bugs.limesurvey.org / view.php? id = 8489

But I find that when entering the captcha if you give the wrong answer the first time, it rests the same question.

If one gives the wrong answer again, it changes the captcha, and so on.

I reopen the bug?
I used the modified code in my version 2.00 build 131107 My EasyPHP server.
We find the saved data and the captcha works, except for the point mentioned above
User avatar (27908)
c_schmitz (administrator)
2014-01-16 16:45

2.05+ Build 140116 released

- Related Changesets
LimeSurvey: master 3b999f8f
Timestamp: 2014-01-15 13:24:11
Author: c_schmitz
Committer: Carsten Schmitz
Details ] Diff ]
Fixed issue 08489: Non-operational CAPTCHA due backup to resume later.
mod - .gitignore Diff ] File ]
mod - application/helpers/frontend_helper.php Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-12-24 17:17 riqcles New Issue
2013-12-24 17:17 riqcles File Added: Erreur_CAPTCHA_limesurvey_survey_984688.lss
2014-01-15 12:18 c_schmitz Assigned To => c_schmitz
2014-01-15 12:18 c_schmitz Status new => assigned
2014-01-15 14:23 c_schmitz Status assigned => resolved
2014-01-15 14:23 c_schmitz Fixed in Version => 2.05+
2014-01-15 14:23 c_schmitz Resolution open => fixed
2014-01-15 14:25 c_schmitz Changeset attached => LimeSurvey master 3b999f8f
2014-01-15 14:25 c_schmitz Note Added: 27885
2014-01-15 16:37 riqcles Note Added: 27886
2014-01-16 16:45 c_schmitz Note Added: 27908
2014-01-16 16:45 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker