LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
08473Bug reports[All Projects] Otherpublic2013-12-19 15:212014-01-09 23:31
Reporterobenard 
Assigned ToDenisChenu 
PriorityurgentSeveritymajor 
StatusclosedResolutionfixed 
Product Version2.05+ 
Target VersionFixed in Version2.05+ 
Summary08473: Resume later leads to lose answers
DescriptionThe Resume later + Load unfinished survey does not work. All answer provided after the resumed session are not saved in the Database:

This is a very basic use case that was working with 2.00+, so it seems to be a regression of 2.05.

The issue happens when you save the survey ("Resume Later"), and when you come back (for example using the URL sent by mail), it looks like everything is OK, you can continue the survey. Unfortunately all the information you enter is not anymore stored in the DB. You can reach the end of the survey and submit it, but all information since the save is lost (the printed document does not contain the answers, the mail sent to the administrator does not contain the answers, the DB does not contain the answers).
Steps To ReproduceI prepared a very simple survey: 2 groups of 1 question each.

- You start the survey,
- You answer the first question then click next
- You click the "Resume later"and enter requested information to get the mail
- you close the browser
- you retrieve the mail and click on the saved survey
- the survey is correctly displayed again
- you enter the second question and click submit.
- The survey is completed bu the second question is not stored in the DB
I will donate to the project if issue is resolved within 48 hrsYes
LimeSurvey build number OR git commit IDVersion 2.05+ Build 131209
BrowserIE or firefox
Database & DB-VersionMySQL 5.1.71
Operating System (Server)Linux
Webserver software & versionApache/2.2.15 (Red Hat)
PHP Version5.3.3
Attached Files? file icon limesurvey_survey_372452.lss [^] (13,331 bytes) 2013-12-19 15:21

- Relationships
related to 08374closedDenisChenu Previewing a question add a response line 
has duplicate 08504closedDenisChenu Saved token-based response persistence forms cannot be edited or completed 

-  Notes
User avatar (27667)
c_schmitz (administrator)
2013-12-19 18:04
edited on: 2013-12-19 18:06

Denis, this issue was introduced by the fix for 08374

User avatar (27668)
DenisChenu (developer)
2013-12-19 18:27

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=13617 [^]
User avatar (27805)
c_schmitz (administrator)
2014-01-09 23:31

2.05+ build 140109 released

- Related Changesets
LimeSurvey: master f3655a1f
Timestamp: 2013-12-19 17:25:54
Author: DenisChenu
Committer: Denis Chenu
Details ] Diff ]
Fixed issue 08473: Resume later leads to lose answers
Dev:remove private $bProcessPost because it's keep on submit
mod - application/helpers/expressions/em_manager_helper.php Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-12-19 15:21 obenard New Issue
2013-12-19 15:21 obenard File Added: limesurvey_survey_372452.lss
2013-12-19 18:03 c_schmitz Assigned To => DenisChenu
2013-12-19 18:03 c_schmitz Status new => assigned
2013-12-19 18:04 c_schmitz Relationship added related to 08374
2013-12-19 18:04 c_schmitz Note Added: 27667
2013-12-19 18:06 c_schmitz Note Edited: 27667 View Revisions
2013-12-19 18:27 DenisChenu Changeset attached => LimeSurvey master f3655a1f
2013-12-19 18:27 DenisChenu Note Added: 27668
2013-12-19 18:27 DenisChenu Resolution open => fixed
2013-12-19 19:02 DenisChenu Status assigned => resolved
2013-12-19 19:02 DenisChenu Fixed in Version => 2.05+
2014-01-02 16:32 DenisChenu Relationship added has duplicate 08504
2014-01-09 23:31 c_schmitz Note Added: 27805
2014-01-09 23:31 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker