LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
08466Bug reports[All Projects] Survey designpublic2013-12-18 17:322014-01-16 16:45
ReporterDenisChenu 
Assigned Tomdekker 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
Product Version2.05+ 
Target VersionFixed in Version2.05+ 
Summary08466: CSS/HTML issue with Plugin/settings
DescriptionIf plugin use input[text] css and HTML seems OK, but broke if use checkbox or select.

See screen shot with one checkbox and one select.
Steps To ReproduceInstall Shnoulle/LS-recomputeExpression from Github and go to config. Or do a setting with 2 checkbox.
Additional InformationActually HTML is
<label><input>

Maybe we can use li or dl/dt to have same system like other form.
OR :
Maybe we can remove the width:40%;display:inline-block and use bootstrap system (checkbox included in label, control-group etc ...)
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit ID131218
BrowserFF22
Database & DB-Versionnot relevant
Operating System (Server)not relevant
Webserver software & versionnot relevant
PHP Versionnot relevant
Attached Filespng file icon Capture du 2013-12-18 17:32:47.png [^] (15,409 bytes) 2013-12-18 17:32


jpg file icon menno_plugin_settings.jpg [^] (23,749 bytes) 2014-01-15 09:30

- Relationships
related to 08306new Development  HTML in admin are really hard to style 

-  Notes
User avatar (27847)
c_schmitz (administrator)
2014-01-14 12:06

Can you provide a test plugin demonstrating the issue, please?
User avatar (27848)
DenisChenu (developer)
2014-01-14 12:20

https://github.com/Shnoulle/LS-recomputeExpression [^]
User avatar (27871)
mdekker (developer)
2014-01-15 09:22

Hey Denis, didn't see this plugin before but (just by reading) it sounds really helpful! I think it should at least be added to the available extensions and maybe even added to core as to me not being able to recalc is a dealbreaker for serious score calculation.
User avatar (27872)
mdekker (developer)
2014-01-15 09:31

In my install (on chrome) it looks ok, maybe a browser incompatibility?
User avatar (27875)
DenisChenu (developer)
2014-01-15 10:11

@mdekker : NO, it's not really ready : it use a lot of hack and actionRecompute() use a lot of complete LS rewriting : it's not clean. You're rigth : this need to be in https://www.limesurvey.org/en/extensions [^] but i work on another website for 'extend and plugin' presentation. I don't like to use external service for this (git.sondages.pro).

For chrome : near same but different in blue or grenn (see attached screen).

The problem is here : https://github.com/LimeSurvey/LimeSurvey/blob/master/styles/configure.css [^] : I think this part and HTML can/must be clean without any template. We have width: 40% for label.

Maybe we can use bootstrap here, but then input[text] is underneath/below label.
User avatar (27876)
mdekker (developer)
2014-01-15 11:26

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=13689 [^]
User avatar (27878)
mdekker (developer)
2014-01-15 11:34

Tried to quickfix the look of the plugins / pluginsettings to be more like the other pages. Feel free to do other improvements. I also thought of removing the config.css and to put it somewhere else as it is another request adding overhead. But since i don't have time to check i left it like this.
User avatar (27879)
DenisChenu (developer)
2014-01-15 12:02

Hi @mdekker, yes it's better now, more like other.

Leave future for 08306 ? (and close this one).
User avatar (27880)
c_schmitz (administrator)
2014-01-15 12:11

Looks fine to me. Thank you, Menno!
User avatar (27909)
c_schmitz (administrator)
2014-01-16 16:45

2.05+ Build 140116 released

- Related Changesets
LimeSurvey: master 2a5afb38
Timestamp: 2014-01-15 09:32:54
Author: mdekker
Committer: Menno Dekker
Details ] Diff ]
dev: added admin footer to plugin layout (as a widget)
add - application/extensions/AdminFooter/AdminFooter.php Diff ] File ]
add - application/extensions/AdminFooter/views/footer.php Diff ] File ]
mod - application/views/layouts/main.php Diff ] File ]
LimeSurvey: master 29dfd571
Timestamp: 2014-01-15 10:06:57
Author: mdekker
Committer: Menno Dekker
Details ] Diff ]
dev: made plugins / pluginsettings use the same rendering using bootstrap in the right order
mod - application/controllers/PluginsController.php Diff ] File ]
mod - styles/configure.css Diff ] File ]
LimeSurvey: master 792a8655
Timestamp: 2014-01-15 10:26:27
Author: mdekker
Committer: Menno Dekker
Details ] Diff ]
Fixed 08466: CSS/HTML issue with Plugin/settings
mod - application/extensions/SettingsWidget/SettingsWidget.php Diff ] File ]
mod - application/extensions/SettingsWidget/assets/settingswidget.css Diff ] File ]
mod - styles/configure.css Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-12-18 17:32 DenisChenu New Issue
2013-12-18 17:32 DenisChenu File Added: Capture du 2013-12-18 17:32:47.png
2014-01-14 12:06 c_schmitz Note Added: 27847
2014-01-14 12:20 DenisChenu Note Added: 27848
2014-01-15 09:22 mdekker Note Added: 27871
2014-01-15 09:30 mdekker File Added: menno_plugin_settings.jpg
2014-01-15 09:31 mdekker Note Added: 27872
2014-01-15 10:11 DenisChenu Note Added: 27875
2014-01-15 10:12 DenisChenu Relationship added related to 08306
2014-01-15 11:26 mdekker Changeset attached => LimeSurvey master 792a8655
2014-01-15 11:26 mdekker Note Added: 27876
2014-01-15 11:26 mdekker Assigned To => mdekker
2014-01-15 11:26 mdekker Resolution open => fixed
2014-01-15 11:34 mdekker Note Added: 27878
2014-01-15 11:46 mdekker Changeset attached => LimeSurvey master 29dfd571
2014-01-15 11:46 mdekker Changeset attached => LimeSurvey master 2a5afb38
2014-01-15 12:02 DenisChenu Note Added: 27879
2014-01-15 12:11 c_schmitz Note Added: 27880
2014-01-15 12:11 c_schmitz Status new => resolved
2014-01-15 12:11 c_schmitz Fixed in Version => 2.05+
2014-01-16 16:45 c_schmitz Note Added: 27909
2014-01-16 16:45 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker