LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
08323Bug reports[All Projects] Otherpublic2013-10-30 07:592013-11-24 19:05
Reporterfradeff 
Assigned Toc_schmitz 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
Product Version 
Target Version2.00+Fixed in Version2.00+ 
Summary08323: problem with mail subject (title) when using application/helpers/expressions/em_manager_helper.php
Descriptionlime Version 2.00+ Build 131022

when using email notification to send a feedback to the user with "TO" = content of an email question within the survey, I have a strange behaviour in the "object" (subject) of the mail - see snapshots

sometimes, the object is OK, sometimes, a <span ID="LEMtailor...> appears (see snapshots) ???

I suspected the mail client of the receiver, but it is not the case, we made several tests and the problem remains, even on a webmail

Grepping in lime soce, I've seen in the file application/helpers/expressions/em_manager_helper.php around line 6480

// If it is an equation, and relevance is true, then write the value from the question to the answer field storing the result
                    if ($arg['type'] == '*')
                    {
                        $relParts[] = " // Write value from the question into the answer field\n";
                        $jsResultVar = $LEM->em->GetJsVarFor($arg['jsResultVar']);
                        // Note, this will destroy embedded HTML in the equation (e.g. if it is a report)
                        // Should be possible to use jQuery to remove just the LEMtailoring span, but not easy since done (the following doesn't work)
                        // _tmpval = $('#question801 .em_equation').clone()
                        // $(_tmpval).find('[id^=LEMtailor]').each(function(){ $(this).replaceWith(function(){ $(this).contents; }); })
                        $relParts[] = " $('#" . substr($jsResultVar,1,-1) . "').val($.trim(LEMstrip_tags($('#question" . $arg['qid'] . " .em_equation').html())));\n";
                    }
I will donate to the project if issue is resolved within 48 hrs
LimeSurvey build number OR git commit ID
Browser
Database & DB-Version
Operating System (Server)
Webserver software & version
PHP Version
Attached Filesjpg file icon test-0.jpg [^] (21,755 bytes) 2013-10-30 07:59


jpg file icon test-1.jpg [^] (5,046 bytes) 2013-10-30 07:59


jpg file icon test-2.jpg [^] (13,364 bytes) 2013-10-30 08:00


? file icon limesurvey_survey_285175.lss [^] (24,080 bytes) 2013-11-11 10:02

- Relationships

-  Notes
User avatar (27022)
fradeff (reporter)
2013-10-30 08:02

sorry I've submitted to early the bug without finishing to add informations...

so I finish here:

Is there a way to hide that <span id...>? in the commented note of
application/helpers/expressions/em_manager_helper.php around line 6480 it seems the problem is known but has not yet a solution?

thank you in advance
User avatar (27119)
c_schmitz (administrator)
2013-11-07 14:10

Well, it is hard to reproduce without seeing the survey. Please attach the survey.
There is no thing such sporadic. If it happens with some uses and with some it does not then it must be a certain thing that is different.
User avatar (27174)
fradeff (reporter)
2013-11-11 10:03

thank you, I've just attached the file
and I agree with you, sporadic is awfull
User avatar (27251)
c_schmitz (administrator)
2013-11-20 14:00

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=13467 [^]
User avatar (27252)
c_schmitz (administrator)
2013-11-20 14:03

Thank you.
User avatar (27253)
c_schmitz (administrator)
2013-11-20 14:03

Fix committed to 2.05 branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=13470 [^]
User avatar (27349)
c_schmitz (administrator)
2013-11-24 19:05

2.00+ Build 131122 released

- Related Changesets
LimeSurvey: master c21e2361
Timestamp: 2013-11-20 13:00:46
Author: c_schmitz
Committer: Carsten Schmitz
Details ] Diff ]
Fixed issue 08323: (span) tags in confirmation messages when survey in all-in-one mode
mod - application/helpers/frontend_helper.php Diff ] File ]
LimeSurvey: 2.05 332cef32
Timestamp: 2013-11-20 13:03:09
Author: c_schmitz
Committer: Carsten Schmitz
Details ] Diff ]
Fixed issue 08323: (span) tags in confirmation messages when survey in all-in-one mode
mod - application/helpers/frontend_helper.php Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-10-30 07:59 fradeff New Issue
2013-10-30 07:59 fradeff File Added: test-0.jpg
2013-10-30 07:59 fradeff File Added: test-1.jpg
2013-10-30 08:00 fradeff File Added: test-2.jpg
2013-10-30 08:02 fradeff Note Added: 27022
2013-11-05 19:07 DenisChenu Project Feature requests => Bug reports
2013-11-07 12:11 c_schmitz Assigned To => c_schmitz
2013-11-07 12:11 c_schmitz Severity feature => minor
2013-11-07 12:11 c_schmitz Status new => assigned
2013-11-07 12:11 c_schmitz Target Version => 2.00+
2013-11-07 14:10 c_schmitz Note Added: 27119
2013-11-07 14:10 c_schmitz Status assigned => feedback
2013-11-11 10:02 fradeff File Added: limesurvey_survey_285175.lss
2013-11-11 10:03 fradeff Note Added: 27174
2013-11-11 10:03 fradeff Status feedback => assigned
2013-11-20 14:00 c_schmitz Changeset attached => LimeSurvey master c21e2361
2013-11-20 14:00 c_schmitz Note Added: 27251
2013-11-20 14:00 c_schmitz Resolution open => fixed
2013-11-20 14:03 c_schmitz Changeset attached => LimeSurvey 2.05 332cef32
2013-11-20 14:03 c_schmitz Note Added: 27252
2013-11-20 14:03 c_schmitz Note Added: 27253
2013-11-20 14:03 c_schmitz Status assigned => resolved
2013-11-20 14:03 c_schmitz Fixed in Version => 2.00+
2013-11-20 14:03 c_schmitz Status resolved => assigned
2013-11-24 19:05 c_schmitz Note Added: 27349
2013-11-24 19:05 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker