LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
08185Bug reports[All Projects] Survey takingpublic2013-09-24 04:522013-09-29 15:27
Reporterpksupport 
Assigned ToDenisChenu 
PriorityhighSeveritymajor 
StatusclosedResolutionfixed 
Product Version2.00+ 
Target VersionFixed in Version2.00+ 
Summary08185: Large ranking question prevents following questions/submit button showing
DescriptionExceeding 160 choices in a ranking question prevents proceeding further (submit button disappears) Worked in 1.9
Steps To ReproduceRan survey. No submit button. Remove entries from last ranking question down to 160. Submit button appears.
Additional InformationI have removed all the conditions on the questions; normally the 'year of study' question branches to different ranking questions. There are two ranking questions in the survey. It's the second one with 255 entries which is preventing the survey running. I also feel the ranking question is slower and clunkier in v2.
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit IDVersion 2.00+ Build 130923
BrowserSafari 6.0.5, IE 9.0
Database & DB-Versionmysql 5.5.28
Operating System (Server)OS X 10.8.4
Webserver software & versionApache 2.2.22
PHP Version5.3.15
Attached Files? file icon limesurvey_survey_47288.lss [^] (188,968 bytes) 2013-09-24 04:52

- Relationships

-  Notes
User avatar (26333)
DenisChenu (developer)
2013-09-24 08:49

The problem is :
- In LS192 HTML is limited by the max rank number. Not in 2.0 ... Think i look at this but not .... Stupid guy i'm ;)
User avatar (26434)
c_schmitz (administrator)
2013-09-29 15:27

Version 2.00+ Build 130929 released

- Related Changesets
LimeSurvey: master 6aff2620
Timestamp: 2013-09-24 08:02:33
Author: DenisChenu
Committer: Denis Chenu
Details ] Diff ]
Fixed issue : 08185: Large ranking question prevents following questions/submit button showing
Dev: memory issue if there are a lot of choice
Dev: use max_answers as limit of answers (like 1.92)
mod - application/helpers/qanda_helper.php Diff ] File ]
LimeSurvey: 2.05 e13bf4ba
Timestamp: 2013-09-24 08:10:26
Author: DenisChenu
Committer: Denis Chenu
Details ] Diff ]
Fixed issue : 08185: Large ranking question prevents following questions/submit button showing
Dev: memory issue if there are a lot of choice
Dev: use max_answers as limit of answers (like 1.92)
Dev: add the number of choice without JS
mod - application/helpers/qanda_helper.php Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-09-24 04:52 pksupport New Issue
2013-09-24 04:52 pksupport File Added: limesurvey_survey_47288.lss
2013-09-24 08:48 DenisChenu Assigned To => DenisChenu
2013-09-24 08:48 DenisChenu Status new => assigned
2013-09-24 08:49 DenisChenu Note Added: 26333
2013-09-24 10:12 DenisChenu Changeset attached => LimeSurvey 2.05 e13bf4ba
2013-09-24 10:12 DenisChenu Changeset attached => LimeSurvey master 6aff2620
2013-09-24 10:13 DenisChenu Status assigned => resolved
2013-09-24 10:13 DenisChenu Fixed in Version => 2.00+
2013-09-24 10:13 DenisChenu Resolution open => fixed
2013-09-29 15:27 c_schmitz Note Added: 26434
2013-09-29 15:27 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker