LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
08076Bug reports[All Projects] Otherpublic2013-08-02 05:322013-10-23 14:40
Reporteranthony_b 
Assigned Toc_schmitz 
PrioritynormalSeveritymajor 
StatusclosedResolutionfixed 
Product Version2.00+ 
Target Version2.05 RCFixed in Version2.05 RC 
Summary08076: Unable to respond to survey when using PostgreSQL and database sessions
DescriptionWhen attempting to complete a survey, no responses are saved. Where a question is mandatory, the page simply refreshes, losing the responses given. If there is only one group/page, a warning about not having completed a mandatory question is given first, whereas if there is more than one group, the page refreshes when next is clicked, and the responses are lost.

A minimal survey that demonstrates this is attached.

Responses are saved correctly if database sessions are turned off, or we switch to MySQL (which works correctly with database sessions).
Steps To Reproduce1. Install LimeSurvey 2.00+ (build 130708) using a PostgreSQL database
2. Uncomment the configuration for sessions within application/config/config.php, as follows:
                'session' => array (
                        'class' => 'system.web.CDbHttpSession',
                        'connectionID' => 'db',
                        'sessionTableName' => '{{sessions}}',
                ),
3. Create a new survey, and add a single group and question. Make completing the question mandatory.
4. Execute the survey and attempt to complete it
Additional InformationThere is no indication of any other issue within the admin interface when using database sessions - it appears to function normally. It is only when a survey is execute that a session related issue occurs.
I will donate to the project if issue is resolved within 48 hrsYes
LimeSurvey build number OR git commit ID130708
BrowserChrome
Database & DB-VersionPostgreSQL 9.1.9
Operating System (Server)Debian 6.0.7
Webserver software & versionApache 2.2.16
PHP Version5.3.3
Attached Files? file icon limesurvey_survey_392434.lss [^] (12,655 bytes) 2013-08-02 05:32

- Relationships

-  Notes
User avatar (26378)
c_schmitz (administrator)
2013-09-26 10:01

This seems to be a bug in the Yii framework/session table setup. Data column in session table needs to be bytea but this does not work with the current Yii version used. Moving target to 2.05.
User avatar (26735)
c_schmitz (administrator)
2013-10-11 16:27

Yii update needed.
User avatar (26897)
c_schmitz (administrator)
2013-10-22 11:29

Fix committed to 2.05 branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=13326 [^]
User avatar (26940)
anthony_b (reporter)
2013-10-23 02:30

Thanks - I will try in out when the next RC comes out.
User avatar (26952)
c_schmitz (administrator)
2013-10-23 14:40

2.05RC3 released.

- Related Changesets
LimeSurvey: 2.05 61023330
Timestamp: 2013-10-22 09:19:18
Author: c_schmitz
Committer: Carsten Schmitz
Details ] Diff ]
Fixed issue 08076: Unable to respond to survey when using PostgreSQL and database sessions
mod - application/config/version.php Diff ] File ]
mod - application/helpers/update/updatedb_helper.php Diff ] File ]
mod - installer/sql/create-mssql.sql Diff ] File ]
mod - installer/sql/create-mysql.sql Diff ] File ]
mod - installer/sql/create-pgsql.sql Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-08-02 05:32 anthony_b New Issue
2013-08-02 05:32 anthony_b File Added: limesurvey_survey_392434.lss
2013-09-26 08:28 c_schmitz Assigned To => c_schmitz
2013-09-26 08:28 c_schmitz Status new => assigned
2013-09-26 10:01 c_schmitz Note Added: 26378
2013-09-26 10:01 c_schmitz Target Version => 2.05 RC
2013-09-26 10:02 c_schmitz Assigned To c_schmitz =>
2013-09-26 10:02 c_schmitz Status assigned => new
2013-10-11 16:26 c_schmitz Relationship added child of 08122
2013-10-11 16:27 c_schmitz Note Added: 26735
2013-10-11 16:27 c_schmitz Assigned To => c_schmitz
2013-10-11 16:27 c_schmitz Status new => assigned
2013-10-20 22:29 c_schmitz Relationship deleted child of 08122
2013-10-22 11:29 c_schmitz Changeset attached => LimeSurvey 2.05 61023330
2013-10-22 11:29 c_schmitz Note Added: 26897
2013-10-22 11:29 c_schmitz Resolution open => fixed
2013-10-22 11:45 c_schmitz Status assigned => resolved
2013-10-22 11:45 c_schmitz Fixed in Version => 2.05 RC
2013-10-23 02:30 anthony_b Note Added: 26940
2013-10-23 14:40 c_schmitz Note Added: 26952
2013-10-23 14:40 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker