LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
07797Bug reports[All Projects] Survey takingpublic2013-04-24 18:412013-10-29 17:45
ReporterDenisChenu 
Assigned ToDenisChenu 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
Product Version2.00+ 
Target Version2.05 RCFixed in Version2.00+ 
Summary07797: User with token can answer twice or more without use left more than 1.
DescriptionCombination of "Anonymized responses? " and "Allow editing responses after completion?" allow user to answer more than 1 time to a survey.

It can be allowed, but it's not clear in sentence.
Steps To ReproduceImport lsa files and test with Token TEST
Additional InformationThink it's a bad idea:
Allow editing responses after completion? can not be true if Anonymized responses? is Yes.

Think best is to:
If Anonymized responses? ==Y set
- Enable token-based response persistence? to NO

If Enable token-based response persistence? is NO
- Allow editing responses after completion? to NO

Directly in models rules.
And to do whole test for old survey.

But maybe it can break some survey.

----
Alternative solution is to update the langage string and give more explanation.
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit ID130424
Browsernot relevant
Database & DB-Versionnot relevant
Operating System (Server)debian/linux
Webserver software & versionapache
PHP VersionPHP Version 5.3
Attached Files? file icon survey_archive_516585.lsa [^] (3,669 bytes) 2013-04-24 18:41

- Relationships
related to 07849new Feature requests Complete status = N when usesleft > 1 

-  Notes
User avatar (25328)
DenisChenu (developer)
2013-05-21 20:10

Carsten: did i change the sentence in Admin screen or did i change the behaviour ?

Think change the behaviour is the best idea, but can break some survey
User avatar (25331)
c_schmitz (administrator)
2013-05-22 12:06

I think changing the behaviour is the best way to go (target for 2.05). It also needs to be fixed in the GUI if possible and you will also need to run a small update that corrects this in the database. (implement it in an existing DBversion)
User avatar (25333)
DenisChenu (developer)
2013-05-22 13:19
edited on: 2013-05-22 13:21

After careful consideration, i think leave the behaviuor is a good solution.

Because a clear sentence like this:
"Allow editing after submission for not anonymous survey or allow infinite answer for anonymous survey."

It's clear allow editing after submission can not be set, but have a "Global password" for a survey is a feature a lot requested (on forum), and we have the best solution here.

Denis
PS: assign it to you. If still code modification : give it to me. For better english sentence, think you're the best ;)

User avatar (25442)
liu (reporter)
2013-06-01 19:51

Thanks for the info in this report. I am glad I came accross it.

My usecase is precisely non-anonymous "tokens with additional attributes" (self registration) AND unlimited submissions (known users are to repeatedly submit several surveys (updated versions/variants over time) on every new encountered instance (verifying their token attributes as well, in the surveys) and get a confirmation).

This seemed to work with the current verion and demo (due to presetting and this bug/feature). But now I am not sure if this use-case will continue to work.

In particular, because I did not see any option to set a high or -1 default for "uses left" in self registered tokens.

Many thanks for your consideration.
User avatar (25446)
DenisChenu (developer)
2013-06-02 16:50

Yes liu,

It work actually with this bug. And like you i think it's a feature and not a bug ;).

But then need more clear sentence: explain your use in the sentence too :)

infinite use of the token if :
- survey is anonymous
- "Enable token-based response persistence?" is set to no (your use of this bug)

Thanks for the feedback :)
User avatar (25537)
DenisChenu (developer)
2013-06-14 16:18

I propose to replace:
"Allow editing responses after completion?"
By
"Allow editing after submission (not anonymous survey) or infinite answer (anonymous survey)."

https://github.com/LimeSurvey/LimeSurvey/blob/master/application/views/admin/survey/subview/tabTokens_view.php#L44 [^]
User avatar (25538)
c_schmitz (administrator)
2013-06-14 16:23

Sounds good.
User avatar (25542)
c_schmitz (administrator)
2013-06-14 17:05

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=12594 [^]
User avatar (25543)
c_schmitz (administrator)
2013-06-14 17:06

After some discussion we came to conclusion to NOT allow this if the option 'Anonymized responses' is set.
User avatar (25546)
DenisChenu (developer)
2013-06-14 18:11

Sorry,

Misunderstanding the vote ...

Think its' best to remove the js and to allow it.
User avatar (25622)
DenisChenu (developer)
2013-06-24 14:59

Choose to remove js and change string
User avatar (25722)
c_schmitz (administrator)
2013-07-08 13:50

2.00+ Build 130708 released.

- Related Changesets
LimeSurvey: master 8b67ec08
Timestamp: 2013-06-14 15:06:25
Author: c_schmitz
Committer: Carsten Schmitz
Details ] Diff ]
Fixed issue 07797: User with token can answer twice or more without use left more than 1
mod - application/views/admin/survey/subview/tabTokens_view.php Diff ] File ]
LimeSurvey: master 9f465adb
Timestamp: 2013-06-24 12:41:06
Author: DenisChenu
Committer: Denis Chenu
Details ] Diff ]
New functionnality: Allow multiple answers with one token ( 07797 )
Dev: maybe use same for not anonymous token: with or without token answer persistence
Dev: fix js issue with activated survey
mod - application/views/admin/survey/subview/tabTokens_view.php Diff ] File ]
LimeSurvey: 2.05 46d5eba8
Timestamp: 2013-06-24 12:52:45
Author: DenisChenu
Committer: Denis Chenu
Details ] Diff ]
New functionnality: Allow multiple answers with one token ( 07797 )
Dev: maybe use same for not anonymous token: with or without token answer persistence
Dev: fix js issue with activated survey
mod - application/views/admin/survey/subview/tabTokens_view.php Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-04-24 18:41 DenisChenu New Issue
2013-04-24 18:41 DenisChenu File Added: survey_archive_516585.lsa
2013-04-24 18:42 DenisChenu Additional Information Updated View Revisions
2013-05-21 20:10 DenisChenu Note Added: 25328
2013-05-22 12:06 c_schmitz Note Added: 25331
2013-05-22 13:13 DenisChenu Assigned To => DenisChenu
2013-05-22 13:13 DenisChenu Status new => assigned
2013-05-22 13:13 DenisChenu Target Version => 2.05 RC
2013-05-22 13:19 DenisChenu Note Added: 25333
2013-05-22 13:19 DenisChenu Status assigned => new
2013-05-22 13:19 DenisChenu Assigned To DenisChenu => c_schmitz
2013-05-22 13:19 DenisChenu Status new => assigned
2013-05-22 13:20 DenisChenu Note Edited: 25333 View Revisions
2013-05-22 13:21 DenisChenu Note Edited: 25333 View Revisions
2013-05-30 12:07 DenisChenu Relationship added related to 07849
2013-06-01 19:51 liu Note Added: 25442
2013-06-02 16:50 DenisChenu Note Added: 25446
2013-06-14 14:58 c_schmitz Status assigned => closed
2013-06-14 14:58 c_schmitz Resolution open => no change required
2013-06-14 16:18 DenisChenu Note Added: 25537
2013-06-14 16:18 DenisChenu Status closed => feedback
2013-06-14 16:18 DenisChenu Resolution no change required => reopened
2013-06-14 16:23 c_schmitz Note Added: 25538
2013-06-14 16:23 c_schmitz Status feedback => assigned
2013-06-14 17:05 c_schmitz Changeset attached => LimeSurvey master 8b67ec08
2013-06-14 17:05 c_schmitz Note Added: 25542
2013-06-14 17:06 c_schmitz Note Added: 25543
2013-06-14 17:06 c_schmitz Status assigned => resolved
2013-06-14 17:06 c_schmitz Fixed in Version => 2.00+
2013-06-14 17:06 c_schmitz Resolution reopened => fixed
2013-06-14 18:11 DenisChenu Note Added: 25546
2013-06-14 18:11 DenisChenu Status resolved => feedback
2013-06-14 18:11 DenisChenu Resolution fixed => reopened
2013-06-24 10:14 DenisChenu Assigned To c_schmitz => DenisChenu
2013-06-24 10:14 DenisChenu Status feedback => assigned
2013-06-24 14:58 DenisChenu Changeset attached => LimeSurvey 2.05 46d5eba8
2013-06-24 14:58 DenisChenu Changeset attached => LimeSurvey master 9f465adb
2013-06-24 14:59 DenisChenu Note Added: 25622
2013-06-24 14:59 DenisChenu Status assigned => resolved
2013-06-24 14:59 DenisChenu Resolution reopened => fixed
2013-07-08 13:50 c_schmitz Note Added: 25722
2013-07-08 13:50 c_schmitz Status resolved => closed
2013-10-29 17:45 DenisChenu Relationship added parent of 08316


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker