LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
07247Bug reports[All Projects] Tokenspublic2013-01-29 17:092013-03-02 16:34
ReporterNanotubes 
Assigned Toc_schmitz 
PriorityurgentSeveritymajor 
StatusclosedResolutionfixed 
Product Version2.00+ 
Target VersionFixed in Version2.00+ 
Summary07247: Token related error after submitting a survey
DescriptionI received messages that people have taken our survey and when they hit the Submit button they get this error message:

Internal Server Error

Property "Tokens_dynamic.blacklisted" is not defined.

An internal error occurred while the Web server was processing your
request. Please contact the webmaster to report this problem.

Thank you.

I tried to reproduce it, and i only got the same error once, so i think it occurs randomly. Apparently this error occurs only on two Surveys which have the same token (with mutliple uses). To clarify: we have two surveys for different regions running at the same time and there are always two different surveys for one region which both use the same token.

I already made a new token for these two, which still has the same password.
Steps To ReproduceMake a dummy token, change the password, take the survey, submit.
Additional InformationIn the backend, on the "browse all" page there are some blank surveys, where no questuon is answered at all. I took that as an indicator to know whether the error occured or not.

Strangely, when I reproduced the error, my answers appeared in the backend. When I then tried to take the survey again it linked me a site where it asks me to submit my survey. After doing that i got one of the blank responses in the backend.

Im really not sure what to take from that. For one survey i have a total of about 70 responses, half of them flagged as incomplete and about 25 blank.
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit ID130116
BrowserFirefox, maybe others
Database & DB-VersionMySQL 5.0
Operating System (Server)Linux i think
Webserver software & version1&1 Dual Unlimited Webhosting
PHP Version5.4
Attached Files

- Relationships

-  Notes
User avatar (23899)
c_schmitz (administrator)
2013-01-30 15:11

Please update to the latest version and report if the issue still exists.
User avatar (24014)
muhzak (developer)
2013-02-09 02:41

I am on the latest version and exact same issue happens. Only when I use tokens though.
User avatar (24022)
ksihota (reporter)
2013-02-09 19:00

Version 2.00+ Build 130206

Have you checked to see if your token shows that it has been decremented to 0?
I had a similar issue that appears to be corrected by 07278:

(On investigation, a recent update of application/helpers/frontend_helper.php has resulted in this variable being renamed to 'oTokenInformation' but once instance of 'usesrow' remained.

to fix, simply replace the one remaining instance of 'usesrow' with 'oTokenInformation' and the problem seems to be resolved.)

This fixed the decrementing issue for me
I'm not sure why I got the original error on submit but by making this change the users are not creating multiple entries.

My users didn't get
Property "Tokens_dynamic.blacklisted" is not defined
or at least didn't report that but did get the other error and a blank page, on returning to the survey and the session being open, they were asked to resubmit giving blanks. If they started a new session they were allowed to go back in and complete the survey again because the uses had not been set to 0.
This may solve at least part of the problem.
User avatar (24027)
pksupport (reporter)
2013-02-12 05:32

Updated today (12/2/13) and got the same error:

Internal Server Error

Property "Tokens_dynamic.blacklisted" is not defined.

An internal error occurred while the Web server was processing your
request. Please contact the webmaster to report this problem.

Thanks ksihota for your very clever pickup. I changed one instance of 'usesrow' to 'oTokenInformation' in application/helpers/frontend_helper.php and tokens began working again.

In my case, the token was simply not being created at all when the user cliccked on "send token"
User avatar (24111)
c_schmitz (administrator)
2013-02-15 15:03

Well, thing is that I cannot reproduce this issue at all. Can any of you please attach a sample survey demonstrating the issue? If you can reproduce it always, please also create a database backup and send it to carsten.schmitz@limesurvey.org describing the exact steps to reproduce the issue.
User avatar (24217)
c_schmitz (administrator)
2013-02-23 22:59

The error is only present until you visit the token section of that survey once. After that the table is automatically fixed. However it also should be fixed by the upgrade procedure in the first place (which this patch does add).
User avatar (24218)
c_schmitz (administrator)
2013-02-23 23:01

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=11676 [^]
User avatar (24415)
c_schmitz (administrator)
2013-02-26 20:03

New version released.
User avatar (24483)
c_schmitz (administrator)
2013-03-02 16:34

Fix committed to 2.1 branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=11728 [^]

- Related Changesets
LimeSurvey: master 9d5e8596
Timestamp: 2013-02-23 22:01:09
Author: c_schmitz
Committer: Carsten Schmitz
Details ] Diff ]
Fixed issue 07247: Token related error after submitting a survey
mod - application/controllers/admin/dataentry.php Diff ] File ]
mod - application/helpers/database_helper.php Diff ] File ]
mod - application/helpers/update/updatedb_helper.php Diff ] File ]
LimeSurvey: 2.1 0a512cb7
Timestamp: 2013-03-02 14:28:38
Author: c_schmitz
Committer: Carsten Schmitz
Details ] Diff ]
Fixed issue 07247: Token related error after submitting a survey
mod - application/controllers/admin/dataentry.php Diff ] File ]
mod - application/helpers/database_helper.php Diff ] File ]
mod - application/helpers/update/updatedb_helper.php Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-01-29 17:09 Nanotubes New Issue
2013-01-30 15:11 c_schmitz Note Added: 23899
2013-01-30 15:11 c_schmitz Assigned To => c_schmitz
2013-01-30 15:11 c_schmitz Status new => feedback
2013-02-09 02:41 muhzak Note Added: 24014
2013-02-09 19:00 ksihota Note Added: 24022
2013-02-09 19:01 ksihota Note View State: 24022: private
2013-02-09 19:01 ksihota Note View State: 24022: public
2013-02-12 05:32 pksupport Note Added: 24027
2013-02-15 15:03 c_schmitz Note Added: 24111
2013-02-23 22:58 c_schmitz Status feedback => assigned
2013-02-23 22:59 c_schmitz Note Added: 24217
2013-02-23 23:01 c_schmitz Changeset attached => LimeSurvey master 9d5e8596
2013-02-23 23:01 c_schmitz Note Added: 24218
2013-02-23 23:01 c_schmitz Resolution open => fixed
2013-02-23 23:01 c_schmitz Status assigned => resolved
2013-02-23 23:01 c_schmitz Fixed in Version => 2.00+
2013-02-26 20:03 c_schmitz Note Added: 24415
2013-02-26 20:03 c_schmitz Status resolved => closed
2013-03-02 16:34 c_schmitz Changeset attached => LimeSurvey 2.1 0a512cb7
2013-03-02 16:34 c_schmitz Note Added: 24483


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker