LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
07135Bug reports[All Projects] Survey takingpublic2013-01-03 17:502013-01-04 13:34
Reporterhelper 
Assigned Toc_schmitz 
PrioritynormalSeverityminor 
StatusclosedResolutionno change required 
Product Version2.00+ 
Target VersionFixed in Version 
Summary07135: URL is rewriting
DescriptionThe survey sid is dropping from the URL after the welcome screen.

This action creates an issue for those who want to complete the survey later and want to bookmark where they are at in the survey.
Steps To ReproduceOn a survey that has "save for later" and the welcome screen enabled, start a survey. At the welcome screen the URL has the sid and the actual number. Once you click next the URL shows only the index.
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit ID121231
BrowserChrome, FF, IE
Database & DB-VersionSQL Server 2008
Operating System (Server)Windows 7 and 2008r2
Webserver software & versionApache 2.4
PHP VersionPHP 3.4
Attached Files

- Relationships

-  Notes
User avatar (23449)
c_schmitz (administrator)
2013-01-03 22:33

That's the intended behaviour. A bookmark won't help because the underlying session data would be lost anyway.
User avatar (23450)
helper (reporter)
2013-01-04 13:02

Interesting that I can create a URL with the token ID and return to the survey where I "saved for later" in a different browser from the one that the original survey was taken.
User avatar (23451)
helper (reporter)
2013-01-04 13:28

the following is an example of a created URL with the token:

https://localhost/MSSQL/index.php/survey/index/sid/653847/token/gcxfykbgms3z9xtr8hkyde3c2/newtest/Y [^]
User avatar (23452)
c_schmitz (administrator)
2013-01-04 13:34

Yes, you need a token for that. But for security reason we don't show the token in the URL all the time. Please do not re-open. Thank you.

- Issue History
Date Modified Username Field Change
2013-01-03 17:50 helper New Issue
2013-01-03 22:33 c_schmitz Note Added: 23449
2013-01-03 22:33 c_schmitz Status new => closed
2013-01-03 22:33 c_schmitz Assigned To => c_schmitz
2013-01-03 22:33 c_schmitz Resolution open => no change required
2013-01-04 13:02 helper Note Added: 23450
2013-01-04 13:02 helper Status closed => feedback
2013-01-04 13:02 helper Resolution no change required => reopened
2013-01-04 13:28 helper Note Added: 23451
2013-01-04 13:28 helper Status feedback => assigned
2013-01-04 13:34 c_schmitz Note Added: 23452
2013-01-04 13:34 c_schmitz Status assigned => closed
2013-01-04 13:34 c_schmitz Resolution reopened => no change required


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker