LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
06910Bug reports[All Projects] Survey designpublic2012-11-20 23:292012-11-27 06:11
ReporterMIK 
Assigned ToTMSWhite 
PrioritynormalSeverityminor 
StatusclosedResolutionno change required 
Product Version2.00+ 
Target VersionFixed in Version 
Summary06910: cascade array: question Q2 created with filter from multiple choice question Q1 with other option doesn't add other option to Q2
DescriptionLet's assume question 1 (code Q1) is a multiple choice with the Option 'Other':
Q01 multiple choice
Code Subquestion
A Option A
B Option B
Option 'Other' Yes

We create question 2 (code Q2) as multiple choice using Q01 as array filter
we add
Relevance equation: ((Q1_A.NAOK == "Y" or Q1_B.NAOK == "Y" or Q1_other.NAOK == "Y")
we add
Code Subquestion
A Option A
B Option B
but are not able to add
other {Q1_other} because after adding it and trying to "save changes" we get the following error:
Error: 'other' is a reserved keyword.

If we leave only
Code Subquestion
A Option A
B Option B
we will not see the option 'Other' ({Q1_other} is what we want to see actually) in question 2 (Q2).

P.S.
we tried to add
other {Q1_other} because it was the way to use cascade array in LS2 Sample: Cascading Array Filters
Steps To Reproduceopened in browser localhost/.../admin
create import, or copy a survey
title: 1
Description: 1
Welcome message: 1
End message: 1
Bounce email: test@test.com
Save

Add new group to survey
Title: a
Description: a
Save question group

Add new question to group
Code: Q1
Question: b
Help: b
Question type: Multiple choice
Option 'Other': Yes
Add question
Edit subquestions for this question
Code A
Subquestion Option A
Insert a new subquestion after this one
Code B
Subquestion Option B
Save changes

Add new question to group
Code: Q2
Question: c
Help: c
Question type: Multiple choice
Option 'Other': No (it was by default, but just to make sure)
Relevance equation: ((Q1_A.NAOK == "Y" or Q1_B.NAOK == "Y" or Q1_other.NAOK == "Y")
Show advanced settings
Array filter Q1
Add question
Edit subquestions for this question
Code A
Subquestion Option A
Insert a new subquestion after this one
Code B
Subquestion Option B
Insert a new subquestion after this one
Code other
Subquestion {Q1_other}
Save changes

Error: 'other' is a reserved keyword.
Ok
Delete this subquestion (the one with code other)
Save changes

Test this survey
Next
Click on Option A (appears question Q2 with Option A available, but if I click on Other: and input text "test" into the box, a box called "test" will not appear in the question Q2).

Export Survey structure (.lss)
Save File Ok
Additional InformationI use xampp for Linux 1.7.7
I will donate to the project if issue is resolved within 48 hrsYes
LimeSurvey build number OR git commit ID121117
Browserfirefox 16.0.2
Database & DB-Versionmysqlnd 5.0.8-dev - 20102224 - $Revision: 310735 $
Operating System (Server)Linux one 3.2.0-33-generic-pae #52-Ubuntu SMP
Webserver software & versionApache/2.2.21 (Unix)
PHP VersionPHP Version 5.3.8
Attached Files? file icon limesurvey_survey_473189.lss [^] (15,299 bytes) 2012-11-20 23:29
? file icon limesurvey_survey_691112.lss [^] (15,708 bytes) 2012-11-22 05:28

- Relationships

-  Notes
User avatar (22357)
c_schmitz (administrator)
2012-11-21 09:37

The other option is in general currently not supported for array_filter - sorry.
User avatar (22392)
TMSWhite (reporter)
2012-11-22 05:26

Actually, this feature works fine
User avatar (22393)
TMSWhite (reporter)
2012-11-22 05:27

The problem was an error in the survey. The logic should be:

(Q1_A.NAOK == "Y" or Q1_B.NAOK == "Y" or !is_empty(Q1_other.NAOK))

See newly attached survey.
User avatar (22394)
TMSWhite (reporter)
2012-11-22 05:29

Per above notes, this is a not a bug in LimeSurvey, but rather a syntax error in the survey.
User avatar (22589)
c_schmitz (administrator)
2012-11-27 06:11

New 2.00+ build released.

- Issue History
Date Modified Username Field Change
2012-11-20 23:29 MIK New Issue
2012-11-20 23:29 MIK File Added: limesurvey_survey_473189.lss
2012-11-21 09:37 c_schmitz Note Added: 22357
2012-11-21 09:37 c_schmitz Status new => closed
2012-11-21 09:37 c_schmitz Assigned To => c_schmitz
2012-11-21 09:37 c_schmitz Resolution open => won't fix
2012-11-22 05:26 TMSWhite Assigned To c_schmitz =>
2012-11-22 05:26 TMSWhite Note Added: 22392
2012-11-22 05:26 TMSWhite Status closed => feedback
2012-11-22 05:26 TMSWhite Resolution won't fix => reopened
2012-11-22 05:27 TMSWhite Note Added: 22393
2012-11-22 05:28 TMSWhite File Added: limesurvey_survey_691112.lss
2012-11-22 05:29 TMSWhite Note Added: 22394
2012-11-22 05:29 TMSWhite Status feedback => resolved
2012-11-22 05:29 TMSWhite Resolution reopened => no change required
2012-11-22 05:29 TMSWhite Assigned To => TMSWhite
2012-11-27 06:11 c_schmitz Note Added: 22589
2012-11-27 06:11 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker