LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
06744Bug reports[All Projects] Survey designpublic2012-10-21 17:552012-10-30 14:52
ReporterDenisChenu 
Assigned ToDenisChenu 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
Product Version2.00+ 
Target VersionFixed in Version2.00+ 
Summary06744: Expressionmanager show false error if admin lang are not in survey lang
DescriptionAfter updating a question, EM show error even if there are no error.
Steps To ReproduceCreate a survey
Create a group
create a question : code Q1, Long free text
create another question : code Q2, text {Q1}, relevance Q1!=""
Save:

Q1 shown in error.
Click on "check survey logic for group" > all is OK
Reload the the question page : all is OK

Same think if you use "condition", add the condition (for example): Q1 are not empty. EM show (( ! is_empty(868539X81X1164.NAOK))) with 868539X81X1164 in red.
Additional InformationSeems again a cache session issue with EM.
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit ID121021
Browsernot relevant
Database & DB-Versionnot relevant
Operating System (Server)not relevant
Webserver software & versionnot relevant
PHP Versionnot relevant
Attached Files

- Relationships
parent of 06768closedc_schmitz Relevance equation works at question level but not at the group level 

-  Notes
User avatar (21578)
c_schmitz (administrator)
2012-10-24 09:01

Thomas, do you have an idea about this?

I can see that SetDirtyFlag is properly used after the question was inserted in the database. (see /controllers/database.php line 358) and then it redirects to the right URL.

Still the syntax highlighting is wrong.
User avatar (21641)
TMSWhite (reporter)
2012-10-25 06:19

I can't reproduce this. It works fine for me when I follow those instructions.
User avatar (21644)
c_schmitz (administrator)
2012-10-25 09:46

Shnoulle, can you still reproduce this? Because I can't anymore.
User avatar (21645)
DenisChenu (developer)
2012-10-25 10:00

Yes, do just this minute:
git reset --hard
git pull

Create a survey (title : Test)
Add a group (group)
Add a "Radio list question" : Q1 (without question text
Add 2 answer (default A1,A2,A3)
Add Q2 question : put in question text {Q1=="A1"} and in Relevance equation Q1=="A1"
Click on save : Q1 in red with "Undefined variable" in red.
Edit, Q1 => Q1.NAOK, click save & close : same thing.

Click on "expression manager file " for question: "Cette question, en elle-même, ne contient pas d'erreur de syntaxe" (i french ? : admin user EN, installtion FR) (but mean no problem)
Update question view (F5) : no problem shown.
User avatar (21703)
mdekker (developer)
2012-10-26 11:52
edited on: 2012-10-26 12:29

@schnoulle: I can reproduce that, also have error in relevance with double quotes. when i set it to single quotes i get Fatal error: Maximum function nesting level of '100' reached, aborting! when i check survey logic file.

EDIT: Error is when i put Q1=='A1' into validation

User avatar (21706)
DenisChenu (developer)
2012-10-26 12:54

Thank Menno, I feel less lonely :)
User avatar (21726)
DenisChenu (developer)
2012-10-27 14:12

Very strange think:
Each time, just after reload:
/admin/survey/view/surveyid/271569/gid/99/qid/1413

With question text to {Q1=="A1"}
- Force new class with "if (isset($_SESSION['LEMdirtyFlag']) || true) { "
  then i have empty question text
- Force new class with "else if (!isset(self::$instance) ||true) {"
  then 1 (like
- After i remove my test : but again error shown ....
User avatar (21728)
DenisChenu (developer)
2012-10-27 15:01

It's an admin langage issue \o/

With a user in french : create an english survey : error
With a user in english : create an french survey : error

BUT

With a user in french : create an english +french survey : NO error
With a user in english : create an french +english survey : NO error
User avatar (21730)
DenisChenu (developer)
2012-10-27 15:43

Some holiday until tuesday. Leave it , if someone can found when call
SetSurveyLanguage($iSurveyID, $language); and when.

I have same thing if i select a existing survey without admin lang.

Denis
User avatar (21755)
DenisChenu (developer)
2012-10-30 11:22

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=10048 [^]
User avatar (21756)
DenisChenu (developer)
2012-10-30 11:27

Fix committed to 2.1 branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=10049 [^]
User avatar (21757)
DenisChenu (developer)
2012-10-30 11:29

It's a view issue, then apply the patch in the surveyadmin/funtion view.

Maybe a lot of thing to ensure, but i don't found another way.

Think there are a lot of issue like that one:
For example :
- Error in default lang, but not in the admin lang
- No error in default lang, but error in adminlang
- etc ...
User avatar (21774)
c_schmitz (administrator)
2012-10-30 14:52

New 2.00+ version released - please update.

- Related Changesets
LimeSurvey: master 364dbf3e
Timestamp: 2012-10-30 03:21:43
Author: DenisChenu
Committer: Denis Chenu
Details ] Diff ]
Fixed issue 06744: Expressionmanager show false error if admin lang are not in default survey lang
Dev : in view, all survey are to be set in default lang, because survey is shown in default lang
Dev : GetLastPrettyPrintExpression seems to be updated without StartProcessingPage
mod - application/controllers/admin/surveyadmin.php Diff ] File ]
LimeSurvey: 2.1 5333e1ad
Timestamp: 2012-10-30 03:21:43
Author: DenisChenu
Committer: Denis Chenu
Details ] Diff ]
Fixed issue 06744: Expressionmanager show false error if admin lang are not in default survey lang
Dev : in view, all survey are to be set in default lang, because survey is shown in default lang
Dev : GetLastPrettyPrintExpression seems to be updated without StartProcessingPage
mod - application/controllers/admin/surveyadmin.php Diff ] File ]

- Issue History
Date Modified Username Field Change
2012-10-21 17:55 DenisChenu New Issue
2012-10-22 15:36 c_schmitz Assigned To => c_schmitz
2012-10-22 15:36 c_schmitz Status new => assigned
2012-10-24 09:01 c_schmitz Note Added: 21578
2012-10-24 09:01 c_schmitz Assigned To c_schmitz => TMSWhite
2012-10-24 09:01 c_schmitz Status assigned => feedback
2012-10-25 06:19 TMSWhite Note Added: 21641
2012-10-25 06:24 TMSWhite Assigned To TMSWhite =>
2012-10-25 09:46 c_schmitz Assigned To => DenisChenu
2012-10-25 09:46 c_schmitz Status feedback => assigned
2012-10-25 09:46 c_schmitz Note Added: 21644
2012-10-25 10:00 DenisChenu Note Added: 21645
2012-10-26 11:52 mdekker Note Added: 21703
2012-10-26 12:29 mdekker Note Edited: 21703 View Revisions
2012-10-26 12:54 DenisChenu Note Added: 21706
2012-10-26 14:44 DenisChenu Relationship added parent of 06768
2012-10-27 14:12 DenisChenu Note Added: 21726
2012-10-27 15:01 DenisChenu Note Added: 21728
2012-10-27 15:02 DenisChenu Summary Expressionmanager show false error after adding/updating question => Expressionmanager show false error if admin lang are not in survey lang
2012-10-27 15:41 DenisChenu Assigned To DenisChenu =>
2012-10-27 15:43 DenisChenu Note Added: 21730
2012-10-27 15:43 DenisChenu Assigned To => DenisChenu
2012-10-27 15:43 DenisChenu Status assigned => new
2012-10-27 15:44 DenisChenu Assigned To DenisChenu =>
2012-10-30 09:14 c_schmitz Assigned To => DenisChenu
2012-10-30 09:14 c_schmitz Status new => assigned
2012-10-30 11:22 DenisChenu Changeset attached => LimeSurvey master 364dbf3e
2012-10-30 11:22 DenisChenu Note Added: 21755
2012-10-30 11:22 DenisChenu Resolution open => fixed
2012-10-30 11:27 DenisChenu Changeset attached => LimeSurvey 2.1 5333e1ad
2012-10-30 11:27 DenisChenu Note Added: 21756
2012-10-30 11:29 DenisChenu Note Added: 21757
2012-10-30 11:29 DenisChenu Status assigned => resolved
2012-10-30 11:29 DenisChenu Fixed in Version => 2.00+
2012-10-30 14:52 c_schmitz Note Added: 21774
2012-10-30 14:52 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker