LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
06685Bug reports[All Projects] Import/Exportpublic2012-10-11 17:562012-10-30 14:52
Reporterdocl 
Assigned Toc_schmitz 
PriorityhighSeveritymajor 
StatusclosedResolutionfixed 
Product Version2.00+ 
Target VersionFixed in Version2.00+ 
Summary06685: Export of results to excel format does not work- creates empty files
DescriptionA very important feature of limesurvey (in my humble opinion) is apparently broken.
When exporting results to excel format it simply creates an empty file, that also results in an error when opening it in excel (two different versions of excel tried).

Another resembling bug regarding the export of statistics to excel and pdf format is reported here:
http://bugs.limesurvey.org/view.php?id=6644 [^] - however this export type results in a server side 500 error. Don't know if they are connected in any way..
Steps To ReproduceExport results from attached survey to excel format, open the excel file.
The files is empty (and probably creates an error), although it should contain two response sets.
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit ID121011
Browser
Database & DB-VersionMySQL 5.1.63-0+squeeze1
Operating System (Server)Linux
Webserver software & versionApache/2.2.16 (Debian)
PHP Version5.3.17
Attached Files? file icon survey_bug_example_2.lsa [^] (3,612 bytes) 2012-10-11 17:56
? file icon 581731 [^] (12,592 bytes) 2012-10-12 18:38 [Show Content]
? file icon survey_archive_581731.lsa [^] (3,630 bytes) 2012-10-22 11:34
? file icon 581731_debug2 [^] (12,592 bytes) 2012-10-22 11:35 [Show Content]
zip file icon results_survey581731_debug0.zip [^] (196 bytes) 2012-10-22 11:42

- Relationships

-  Notes
User avatar (21248)
DenisChenu (developer)
2012-10-11 19:46

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=9741 [^]
User avatar (21251)
docl (reporter)
2012-10-11 23:39

Not sure I understand the changeset comment - What do you mean with: can export all result or one answer line. But another bug report for filter?

Just tried to use the new export.php file, and I still get an empty excel file..


Thanks
User avatar (21253)
DenisChenu (developer)
2012-10-12 08:48

Hello,

Can you download the file and put it here ? (Not open with excel before).

Mine is "not-empty", there are an line more, but it's not empty :).
User avatar (21254)
docl (reporter)
2012-10-12 09:27

Could not upload the xls file directly, had to zip it first..
This xls is created with the new export.php..

In this test survey there are two responses - when pdf or csv is created data is shown, but with xls..nothing
User avatar (21267)
DenisChenu (developer)
2012-10-12 17:35

Zut,

I have something and you not ...

Can you set debug to 2 on your system.

Look in application/core/config.php if you have already a line with:
'debug'=>0, and change it to set:
'debug'=>2,

Please
User avatar (21275)
docl (reporter)
2012-10-12 18:41

When debug set to 2 or 1 a file without a file extension is generated,
This file will still generate errors when opened in excel - this time the error is specific, regarding missing file links (template files),
The file contains some kind of relevant information :-), but in a very disorganised way :-(
User avatar (21276)
c_schmitz (administrator)
2012-10-12 22:15

docl, can you attach that latest file please?
User avatar (21277)
docl (reporter)
2012-10-12 22:36

Already did. It's the one without a file extension.. Just uploadet it with no changes at all..
User avatar (21415)
docl (reporter)
2012-10-18 00:11

Just wantvto know if this bug is in fact still open? Status is 'fixed' , but the problem still exists I believe (at least in my setup..). Thanks. John
User avatar (21418)
DenisChenu (developer)
2012-10-18 08:38

Sorry,

It work on my server, but there are seems some configuration where it don't work.
User avatar (21419)
docl (reporter)
2012-10-18 09:48
edited on: 2012-10-22 10:56

Thanks, do you have any idea what the faulty config could be?

EDIT
My mistake - the following was when exporting statistics to pdf/excel - when exporting results there are no php errors shown..
---
When debug = 2 I get a lot of "undefined variable" notices - but as far as I know PHP does not require variables to be defined (hence it is a notice not an error), so this shouldn't be the dealbreaker here I suppose..?
---
EDIT

User avatar (21424)
DenisChenu (developer)
2012-10-18 10:16

No,

There are other user in forum with same problem, it's a server configuration i think.

Surely in ExcelWriter because CSV work good ...

Maybe a good solution is to replace libraries phpexcelwriter by
this Yii extension : http://www.yiiframework.com/extension/phpexcel/ [^]
User avatar (21431)
c_schmitz (administrator)
2012-10-18 12:41

docl, can you please update to the latest build and try again? Please test using the debug mode set to 2 and attach the resulting file.
Thank you.
User avatar (21432)
c_schmitz (administrator)
2012-10-18 12:43

What 'Undefined variable' notices do you get?
User avatar (21498)
pjbauer (reporter)
2012-10-19 16:28

I still get...

Firefox can't find the file at http://mydomain.com/survey/index.php/admin/statistics/index/surveyid/459297#start. [^]

...if I try to export survey stats to Excel. (Build 121019)
User avatar (21499)
c_schmitz (administrator)
2012-10-19 16:43

Can you please test using the debug mode set to 2 and attach the resulting file.
Please also explain what 'undefined variable notice' you get.
User avatar (21524)
docl (reporter)
2012-10-22 11:30
edited on: 2012-10-22 11:43

Sorry for the delay..
The bug is still present in the latest build, in my (and pjbauer's) setup.
I have attached three files. The survey, the result file when debug=0 (had to zip this files - apparently cannot upload xls files) and the result file when debug=2.
When debug = 0 an empty excel file is generated, this file will show a unspecific error when opened in excel 2007.
When debug = 2 firefox simply shows "cannot find the file" (like pjbauer reports), when IE is used, a file with no file extension is generated. This file will show specific errors regarding missing linked files (template files it seems) when opened in excel, and the contents of the files is from the survey, but completely random/messed up output.

User avatar (21532)
c_schmitz (administrator)
2012-10-22 14:31

docl, if you look at pjbauers link you can see it is about statistics so not relevant here. I still cannot reproduce here.

Would it be possible to get admin login to the LimeSurvey installation and FTP access to such a system so I can debug online?
If yes please send it to carsten.schmitz@limesurvey.org

Thank you.
User avatar (21581)
c_schmitz (administrator)
2012-10-24 09:57

?
User avatar (21712)
c_schmitz (administrator)
2012-10-26 16:07

It is solved now. It looks like the temporary folder set in your PHP configuration is not writable. Change LimeSurvey so it is using its own temporary dir.
User avatar (21713)
c_schmitz (administrator)
2012-10-26 16:10

Fix committed to 2.1 branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=10031 [^]
User avatar (21777)
c_schmitz (administrator)
2012-10-30 14:52

New 2.00+ version released - please update.

- Related Changesets
LimeSurvey: master 5faaa17d
Timestamp: 2012-10-11 10:45:57
Author: DenisChenu
Committer: Denis Chenu
Details ] Diff ]
Fixed issue 06685 : Export of results broken
Dev : just fix Undefined variable: sFilter : can export all result or one answer line. But another bug report for filter
mod - application/controllers/admin/export.php Diff ] File ]
LimeSurvey: master ae819d31
Timestamp: 2012-10-26 06:55:40
Author: c_schmitz
Committer: Carsten Schmitz
Details ] Diff ]
Fied issue 06685: Export of results to excel format does not work- creates empty files
mod - application/helpers/admin/exportresults_helper.php Diff ] File ]
LimeSurvey: 2.1 eeaa0d7b
Timestamp: 2012-10-26 06:57:18
Author: c_schmitz
Committer: Carsten Schmitz
Details ] Diff ]
Fixed issue 06685: Export of results to excel format does not work- creates empty files
mod - application/helpers/admin/exportresults_helper.php Diff ] File ]

- Issue History
Date Modified Username Field Change
2012-10-11 17:56 docl New Issue
2012-10-11 17:56 docl File Added: survey_bug_example_2.lsa
2012-10-11 18:44 DenisChenu Assigned To => DenisChenu
2012-10-11 18:44 DenisChenu Status new => assigned
2012-10-11 19:46 DenisChenu Changeset attached => LimeSurvey master 5faaa17d
2012-10-11 19:46 DenisChenu Note Added: 21248
2012-10-11 19:46 DenisChenu Resolution open => fixed
2012-10-11 23:39 docl Note Added: 21251
2012-10-12 08:48 DenisChenu Note Added: 21253
2012-10-12 09:22 docl File Added: results-survey581731.zip
2012-10-12 09:27 docl Note Added: 21254
2012-10-12 17:35 DenisChenu Note Added: 21267
2012-10-12 18:38 docl File Added: 581731
2012-10-12 18:41 docl Note Added: 21275
2012-10-12 22:14 c_schmitz File Deleted: results-survey581731.zip
2012-10-12 22:15 c_schmitz Note Added: 21276
2012-10-12 22:36 docl Note Added: 21277
2012-10-18 00:11 docl Note Added: 21415
2012-10-18 08:38 DenisChenu Assigned To DenisChenu =>
2012-10-18 08:38 DenisChenu Note Added: 21418
2012-10-18 09:48 docl Note Added: 21419
2012-10-18 10:16 DenisChenu Note Added: 21424
2012-10-18 12:13 DenisChenu Assigned To => DenisChenu
2012-10-18 12:13 DenisChenu Status assigned => new
2012-10-18 12:14 DenisChenu Assigned To DenisChenu =>
2012-10-18 12:41 c_schmitz Note Added: 21431
2012-10-18 12:41 c_schmitz Assigned To => c_schmitz
2012-10-18 12:41 c_schmitz Status new => feedback
2012-10-18 12:43 c_schmitz Note Added: 21432
2012-10-19 16:28 pjbauer Note Added: 21498
2012-10-19 16:43 c_schmitz Note Added: 21499
2012-10-22 10:56 docl Note Edited: 21419 View Revisions
2012-10-22 11:30 docl Note Added: 21524
2012-10-22 11:30 docl Status feedback => assigned
2012-10-22 11:34 docl File Added: survey_archive_581731.lsa
2012-10-22 11:35 docl File Added: 581731_debug2
2012-10-22 11:38 docl Note Edited: 21524 View Revisions
2012-10-22 11:42 docl File Added: results_survey581731_debug0.zip
2012-10-22 11:43 docl Note Edited: 21524 View Revisions
2012-10-22 14:31 c_schmitz Note Added: 21532
2012-10-22 14:32 c_schmitz Status assigned => feedback
2012-10-24 09:57 c_schmitz Note Added: 21581
2012-10-26 15:55 c_schmitz Status feedback => resolved
2012-10-26 15:55 c_schmitz Fixed in Version => 2.00+
2012-10-26 16:04 c_schmitz Changeset attached => LimeSurvey master ae819d31
2012-10-26 16:07 c_schmitz Note Added: 21712
2012-10-26 16:10 c_schmitz Changeset attached => LimeSurvey 2.1 eeaa0d7b
2012-10-26 16:10 c_schmitz Note Added: 21713
2012-10-30 14:52 c_schmitz Note Added: 21777
2012-10-30 14:52 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker