LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
06530Bug reports[All Projects] Otherpublic2012-08-30 16:372012-09-09 15:35
Reportermillsy1975 
Assigned ToDenisChenu 
PriorityurgentSeveritymajor 
StatusclosedResolutionfixed 
Product Version1.92+ 
Target VersionFixed in Version1.92+ 
Summary06530: Since latest update unable to upload documents in survey
DescriptionUpload File in survey takes you thought the motions but does not upload a file. This was working pre the latest update
Steps To ReproduceCreate a survey and try to upload a file
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit ID120822
Browser
Database & DB-VersionMySql 5.1.36
Operating System (Server)Qnap TS 212
Webserver software & versionApache 2.0
PHP VersionPHP/5.3.14
Attached Files

- Relationships
related to 06536closedc_schmitz HTML editor converts special characters to html entities within equations 

-  Notes
User avatar (20601)
startx25 (reporter)
2012-08-30 21:39
edited on: 2012-08-30 21:39

I think that file is uploaded, with survey completed, but no file in the result page (when you browse result) (can you confirm that? )

something gone wrong with json parameters, and probably with the last bug : quote in title or comment field.

User avatar (20608)
DenisChenu (developer)
2012-08-31 17:14

It's: http://git.io/XwuKyg [^]

Patch:
Replace
$result = $this->sProcessStringContainingExpressionsHelper($result,$questionNum, $staticReplacement);
BY
$result = $this->sProcessStringContainingExpressionsHelper(htmlspecialchars_decode($result,ENT_QUOTES),$questionNum, $staticReplacement);

In classes/expressions/ExpressionManager.php
User avatar (20613)
millsy1975 (reporter)
2012-08-31 19:08

Thanks for answering this so quickly.

Patch:
 Replace
 $result = $this->sProcessStringContainingExpressionsHelper($result,$questionNum, $staticReplacement);
 BY
 $result = $this->sProcessStringContainingExpressionsHelper(htmlspecialchars_decode($result,ENT_QUOTES),$questionNum, $staticReplacement);
 
In classes/expressions/ExpressionManager.php

The above code amendment has fixed the problem.

Cheers
User avatar (20621)
startx25 (reporter)
2012-09-03 11:25
edited on: 2012-09-03 14:31

this patch is already present in last update :Version 1.92+ Build 120822

It doesn't work

User avatar (20622)
startx25 (reporter)
2012-09-03 14:47

I have notice that file is present, but not appear in response page (admin section)
User avatar (20626)
DenisChenu (developer)
2012-09-06 11:21

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=9443 [^]
User avatar (20627)
DenisChenu (developer)
2012-09-06 11:35

Fix committed to Yii branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=9444 [^]
User avatar (20628)
DenisChenu (developer)
2012-09-06 11:35

Patch only javascript.

- Related Changesets
LimeSurvey: master cc8f6d90
Timestamp: 2012-09-06 02:17:35
Author: DenisChenu
Committer: Denis Chenu
Details ] Diff ]
Fixed issue 06530 : Since latest update unable to upload documents in survey
Dev: replace & by & before split. Work with or without 06536 patch
mod - scripts/modaldialog.js Diff ] File ]
LimeSurvey: Yii 5f26bca7
Timestamp: 2012-09-06 02:28:41
Author: DenisChenu
Committer: Denis Chenu
Details ] Diff ]
Fixed issue 06530 : Since latest update unable to upload documents in survey
Dev: replace & by & before split. Work with or without 06536 patch
Dev: upload have some other bug
mod - scripts/modaldialog.js Diff ] File ]

- Issue History
Date Modified Username Field Change
2012-08-30 16:37 millsy1975 New Issue
2012-08-30 21:39 startx25 Note Added: 20601
2012-08-30 21:39 startx25 Note Edited: 20601 View Revisions
2012-08-31 17:14 DenisChenu Note Added: 20608
2012-08-31 17:17 DenisChenu Relationship added child of 06423
2012-08-31 19:08 millsy1975 Note Added: 20613
2012-09-01 19:31 TMSWhite Relationship added related to 06536
2012-09-03 11:25 startx25 Note Added: 20621
2012-09-03 14:31 startx25 Note Edited: 20621 View Revisions
2012-09-03 14:47 startx25 Note Added: 20622
2012-09-06 11:21 DenisChenu Changeset attached => LimeSurvey master cc8f6d90
2012-09-06 11:21 DenisChenu Note Added: 20626
2012-09-06 11:21 DenisChenu Assigned To => DenisChenu
2012-09-06 11:21 DenisChenu Resolution open => fixed
2012-09-06 11:35 DenisChenu Changeset attached => LimeSurvey Yii 5f26bca7
2012-09-06 11:35 DenisChenu Note Added: 20627
2012-09-06 11:35 DenisChenu Note Added: 20628
2012-09-06 11:35 DenisChenu Status new => resolved
2012-09-06 11:35 DenisChenu Fixed in Version => 1.92+
2012-09-09 15:35 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker