LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
06045Bug reports[All Projects] Templatespublic2012-04-25 10:422012-05-01 11:56
Reporteruser19533 
Assigned Toc_schmitz 
PrioritynormalSeveritymajor 
StatusclosedResolutionfixed 
Product Version1.92+ 
Target VersionFixed in Version1.92+ 
Summary06045: Firefox 12 vertical scrolling problem in admin view (and other pages)
DescriptionFirefox 12 is "stable" and the bug is still here. I've seen the problem on other sites (with jQuery), maybe it's a problem with jQuery & Firefox 12 ?

Tested with Firefox 12 on Mac & Linux, and tested in Firefox 13 "aurora" (Linux), same problem.
Steps To ReproduceDuplicate of 05990, but I can't reopen the bug (access denied).
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit ID1.92
BrowserMozilla Firefox 12
Database & DB-VersionMySQL 5.1.61
Operating System (Server)Debian 6
Webserver software & versionApache 2.2.16
PHP VersionPhp 5.3.3
Attached Filespng file icon survey-error.png [^] (188,372 bytes) 2012-04-26 13:49

- Relationships
has duplicate 06051closedc_schmitz Firefox 12 vertical scrolling problem in admin view 

-  Notes
(18475)
user19533
2012-04-25 11:17

After investigation, the problem is not jQuery but jQuery UI. The (rather old) version embeded in LimeSurvey doesn't work with Firefox 12, after a manual update of the files to the latest version :

It works !!!
User avatar (18482)
c_schmitz (administrator)
2012-04-26 10:34

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=8235 [^]
User avatar (18483)
c_schmitz (administrator)
2012-04-26 10:35

Fix committed to Yii branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=8236 [^]
User avatar (18484)
c_schmitz (administrator)
2012-04-26 10:38

Thank you very much for the analysis!
(18487)
user19533
2012-04-26 13:49
edited on: 2012-04-26 13:50

With the news jquery-ui.js, the admin works, but I've a problem on a survey, I've put a "yes / no" question, and the date picker is only shown if the user select "yes".

But when the datepicker is hidden, the div "ui-datepicker-div" is displayed on the bottom left of the webpage (just a blue line). If I try with the jquery-ui.css from jqueryui site, it works, but the admin backend is quite ugly.

(I've joined a screenshot)

(18497)
user19571
2012-04-26 19:18

What is the procedure for getting a version with the scroll-bar fix?

(Clicking 'check now' for updates in the admin interface shows no new updates available).

Even if there is some collateral damage in the fix, I'd like to try it,
because there is no way to downgrade firefox on Ubuntu (except, strangely, to the much-older ff 7.0.1).

Thanks
User avatar (18508)
c_schmitz (administrator)
2012-05-01 09:11

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=8275 [^]
User avatar (18509)
c_schmitz (administrator)
2012-05-01 09:21

Fix committed to Yii branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=8277 [^]
User avatar (18512)
c_schmitz (administrator)
2012-05-01 11:56

New 1.92+ build released

- Related Changesets
LimeSurvey: master cd41aa5c
Timestamp: 2012-04-26 01:34:07
Author: c_schmitz
Committer: Carsten Schmitz
Details ] Diff ]
Fixed issue 06045: Firefox 12 vertical scrolling problem in admin view (and other pages)
mod - scripts/jquery/jquery-ui.js Diff ] File ]
LimeSurvey: Yii 53185870
Timestamp: 2012-04-26 01:34:46
Author: c_schmitz
Committer: Carsten Schmitz
Details ] Diff ]
Fixed issue 06045: Firefox 12 vertical scrolling problem in admin view (and other pages)
mod - scripts/jquery/jquery-ui.js Diff ] File ]
LimeSurvey: master 9d380b5e
Timestamp: 2012-05-01 00:11:01
Author: c_schmitz
Committer: Carsten Schmitz
Details ] Diff ]
Fixed issue 06045: Firefox 12 vertical scrolling problem in admin view (and other pages)
mod - scripts/jquery/css/start/jquery-ui.css Diff ] File ]
LimeSurvey: Yii 134812e9
Timestamp: 2012-05-01 00:21:30
Author: c_schmitz
Committer: Carsten Schmitz
Details ] Diff ]
Fixed issue 06045: Firefox 12 vertical scrolling problem in admin view (and other pages)
Dev More icon changes
rm - styles/gringegreen/images/edit_disabled.png Diff ] File ]
mod - application/helpers/admin/statistics_helper.php Diff ] File ]
mod - scripts/jquery/css/start/jquery-ui.css Diff ] File ]
mod - styles/gringegreen/images/edithtmlpopup_disabled.png Diff ] File ]

- Issue History
Date Modified Username Field Change
2012-04-25 10:42 user19533 New Issue
2012-04-25 11:17 user19533 Note Added: 18475
2012-04-25 12:43 c_schmitz Assigned To => c_schmitz
2012-04-25 12:43 c_schmitz Status new => assigned
2012-04-26 10:34 c_schmitz Changeset attached => LimeSurvey master cd41aa5c
2012-04-26 10:34 c_schmitz Note Added: 18482
2012-04-26 10:34 c_schmitz Resolution open => fixed
2012-04-26 10:35 c_schmitz Changeset attached => LimeSurvey Yii 53185870
2012-04-26 10:35 c_schmitz Note Added: 18483
2012-04-26 10:38 c_schmitz Note Added: 18484
2012-04-26 10:38 c_schmitz Status assigned => resolved
2012-04-26 10:38 c_schmitz Fixed in Version => 1.92+
2012-04-26 13:49 user19533 Note Added: 18487
2012-04-26 13:49 user19533 Status resolved => feedback
2012-04-26 13:49 user19533 Resolution fixed => reopened
2012-04-26 13:49 user19533 File Added: survey-error.png
2012-04-26 13:50 user19533 Note Edited: 18487 View Revisions
2012-04-26 19:18 user19571 Note Added: 18497
2012-04-30 17:13 c_schmitz Relationship added has duplicate 06051
2012-05-01 09:11 c_schmitz Changeset attached => LimeSurvey master 9d380b5e
2012-05-01 09:11 c_schmitz Note Added: 18508
2012-05-01 09:11 c_schmitz Status feedback => resolved
2012-05-01 09:11 c_schmitz Resolution reopened => fixed
2012-05-01 09:21 c_schmitz Changeset attached => LimeSurvey Yii 134812e9
2012-05-01 09:21 c_schmitz Note Added: 18509
2012-05-01 11:56 c_schmitz Note Added: 18512
2012-05-01 11:56 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker