LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
05952Bug reports[All Projects] Statisticspublic2012-03-26 16:432012-04-04 11:51
Reportergjaouen 
Assigned Toc_schmitz 
PrioritynormalSeveritymajor 
StatusclosedResolutionfixed 
Product Version1.92+ 
Target VersionFixed in Version1.92+ 
Summary05952: Statistics fail under LS Version 1.92+ Build 120325
DescriptionAfter upgrading to LS 1.92+ Build 120325 from LS 1.92+ build 120323, I have trouble getting statistics from old existing surveys.

When requesting statistics from admin interface, the output of statistics_function.php generate notices :
Notice: Undefined index: 99641X20X867 in /var/www/clients/client1/web30/web/admin/statistics_function.php on line 1497
Notice: Undefined variable: qtitle in /var/www/clients/client1/web30/web/admin/statistics_function.php on line 1894
Notice: Undefined variable: qquestion in /var/www/clients/client1/web30/web/admin/statistics_function.php on line 1899

After upgrading LS, I see some errors into the fr.po file so I upgraded mine and attach it in this report if it can help.

Best regards,
Guillaume
Steps To Reproduce1) upgrade LS to 1.92+ Build 120325
2) connect to admin interface
3) select an active survey
4) request statistics for this survey
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit ID120325
BrowserFirefox 11.0
Database & DB-Versionmysql Ver 14.12 Distrib 5.0.77, for redhat-linux-gnu (x86_64) using readline 5.1
Operating System (Server)CentOS release 5.6 (Final)
Webserver software & versionApache/2.2.3
PHP VersionPHP 5.2.10
Attached Files? file icon limesurvey_survey_99641.lss [^] (742,234 bytes) 2012-03-26 17:14

- Relationships
has duplicate 05956closedc_schmitz Statistics fail under LS Version 1.92+ Build 120325 

-  Notes
User avatar (18085)
Mazi (developer)
2012-03-26 17:07

Can you attach a test survey?
User avatar (18086)
gjaouen (reporter)
2012-03-26 17:15

Hello,

I add lss and csv file from one of the surveys I'm trying to obtain statistics from build 120325
User avatar (18103)
gjaouen (reporter)
2012-03-28 17:48

Hello,

I wanna add to my previous notes this precision :


- admin.php?action=browse&sid=99641&subaction=id&id=7 : NOT OK (empty response screen)
- admin.php?action=browse&sid=99641&subaction=all&limit=50&order=desc : OK (display last answers correctly in a table)

Best regards,
Guillaume
User avatar (18105)
gjaouen (reporter)
2012-03-28 18:07

One more thing,

The export screen of data doesn't display all questions but only from "id" to "refurl"...
User avatar (18106)
c_schmitz (administrator)
2012-03-28 18:41

gjaouen: I am sorry but I am confused. Please don't mix several issues in the same bug report.

In the beginning you talk about statistics, but later you give some 'Browse responses' URLs. What is it now?
User avatar (18107)
c_schmitz (administrator)
2012-03-28 18:44

Btw, I don't get any errors on your survey when running statistics.
User avatar (18108)
c_schmitz (administrator)
2012-03-28 18:46

If you really get errors on statistics can you please attach a dump of your database so I can check? I switched the issue to private so only me and you can see download the dump.
User avatar (18111)
c_schmitz (administrator)
2012-03-29 11:55

Hello Guillaume,

I am sorry but that does not help me to find the cause. I will need a full database dump.
User avatar (18113)
gjaouen (reporter)
2012-03-29 12:24

If you wanna try to reproduce this bug, set all settings of language to french.

It seems that there is other bug report that may be linked to this one, like bug n°05960.
User avatar (18114)
c_schmitz (administrator)
2012-03-29 12:41

I downloaded the file, can't gunzip it because it is corrupted. Can you try again please?
User avatar (18115)
gjaouen (reporter)
2012-03-29 12:47
edited on: 2012-03-29 18:49

Carsten don't waste time, I've found the origin of the bug !!!

When I change the default language setting to english all run smoothly and no more bug.

If I went back to french, then bug occur again !!!

So I think it's a bug linked with the fr.po file and not with database.

User avatar (18116)
gjaouen (reporter)
2012-03-29 13:02

I think I can release a new good fr.po from limesurvey.pot, I'll try to make a new one and if it's working properly, I'll send it to the translation manager.

What do you think about it ?
User avatar (18117)
c_schmitz (administrator)
2012-03-29 13:06
edited on: 2012-03-29 13:08

I still can't reproduce it, even in French language. Can you please provide the database dump. Thank you.
OH, and if you are at it, can you please attach your PHPinfo information.

User avatar (18121)
gjaouen (reporter)
2012-03-29 14:32
edited on: 2012-03-29 18:50

Hello again carsten,

back from lunch :))

I've upload the dump as requested.

When you say you try to reproduce the bug in french did you change the language in the general setup tab ?

I try again login in french and in english and can reproduce the problem on my LS install.

I'm quite sure that it's a gettext bug.

User avatar (18130)
c_schmitz (administrator)
2012-03-30 13:53

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=8058 [^]
User avatar (18191)
c_schmitz (administrator)
2012-04-04 11:51

Fix committed to Yii branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=8086 [^]

- Related Changesets
LimeSurvey: master 1371faf7
Timestamp: 2012-03-30 04:53:20
Author: c_schmitz
Committer: Carsten Schmitz
Details ] Diff ]
Fixed issue 05952: Error in statistics
mod - admin/statistics_function.php Diff ] File ]
LimeSurvey: Yii 9c332be9
Timestamp: 2012-04-04 01:55:01
Author: c_schmitz
Committer: Carsten Schmitz
Details ] Diff ]
Fixed issue 05952: Error in statistics
mod - application/helpers/admin/statistics_helper.php Diff ] File ]

- Issue History
Date Modified Username Field Change
2012-03-26 16:43 gjaouen New Issue
2012-03-26 16:43 gjaouen File Added: fr.po
2012-03-26 17:07 Mazi Assigned To => DenisChenu
2012-03-26 17:07 Mazi Status new => assigned
2012-03-26 17:07 Mazi Note Added: 18085
2012-03-26 17:07 Mazi Status assigned => feedback
2012-03-26 17:14 gjaouen File Added: limesurvey_survey_99641.lss
2012-03-26 17:14 gjaouen File Added: results-survey99641.csv
2012-03-26 17:15 gjaouen Note Added: 18086
2012-03-26 17:15 gjaouen Status feedback => assigned
2012-03-27 14:28 gjaouen File Added: stats output for LS 1.92+ 120325 for survey 99641.7z
2012-03-28 15:11 c_schmitz Relationship added has duplicate 05956
2012-03-28 17:48 gjaouen Note Added: 18103
2012-03-28 18:07 gjaouen Note Added: 18105
2012-03-28 18:41 c_schmitz Note Added: 18106
2012-03-28 18:44 c_schmitz Assigned To DenisChenu => c_schmitz
2012-03-28 18:44 c_schmitz Note Added: 18107
2012-03-28 18:44 c_schmitz View Status public => private
2012-03-28 18:46 c_schmitz Note Added: 18108
2012-03-28 18:46 c_schmitz Status assigned => feedback
2012-03-29 10:42 gjaouen Note Added: 18110
2012-03-29 10:42 gjaouen Status feedback => assigned
2012-03-29 11:55 c_schmitz Note Added: 18111
2012-03-29 12:14 gjaouen Note Added: 18112
2012-03-29 12:24 gjaouen Note Added: 18113
2012-03-29 12:41 c_schmitz Note Added: 18114
2012-03-29 12:47 gjaouen Note Added: 18115
2012-03-29 13:02 gjaouen Note Added: 18116
2012-03-29 13:06 c_schmitz Note Added: 18117
2012-03-29 13:08 c_schmitz Note Edited: 18117 View Revisions
2012-03-29 14:17 gjaouen File Added: c11.sql.bz2
2012-03-29 14:32 gjaouen File Added: phpinfo.php
2012-03-29 14:32 gjaouen Note Added: 18121
2012-03-29 18:49 gjaouen Note Edited: 18110
2012-03-29 18:49 gjaouen Note Edited: 18115 View Revisions
2012-03-29 18:50 gjaouen Note Edited: 18121 View Revisions
2012-03-30 13:53 c_schmitz Changeset attached => LimeSurvey master 1371faf7
2012-03-30 13:53 c_schmitz Note Added: 18130
2012-03-30 13:53 c_schmitz Resolution open => fixed
2012-03-30 13:56 c_schmitz File Deleted: phpinfo.php
2012-03-30 13:56 c_schmitz File Deleted: c11.sql.bz2
2012-03-30 13:56 c_schmitz File Deleted: stats output for LS 1.92+ 120325 for survey 99641.7z
2012-03-30 13:57 c_schmitz File Deleted: results-survey99641.csv
2012-03-30 13:57 c_schmitz File Deleted: fr.po
2012-03-30 13:57 c_schmitz Note Deleted: 18110
2012-03-30 13:57 c_schmitz Note Revision Dropped: 18110: 01132
2012-03-30 13:58 c_schmitz Note Revision Dropped: 18117: 01129
2012-03-30 13:58 c_schmitz Note Deleted: 18112
2012-03-30 13:58 c_schmitz Status assigned => resolved
2012-03-30 13:58 c_schmitz Fixed in Version => 1.92+
2012-03-30 13:59 c_schmitz View Status private => public
2012-03-30 15:00 c_schmitz Status resolved => closed
2012-04-04 11:51 c_schmitz Changeset attached => LimeSurvey Yii 9c332be9
2012-04-04 11:51 c_schmitz Note Added: 18191


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker