LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
04939Bug reports[All Projects] Survey designpublic2011-02-08 17:112011-02-17 18:25
Reporteremilus 
Assigned Toc_schmitz 
PrioritynormalSeveritymajor 
StatusclosedResolutionfixed 
Product Version1.90+ 
Target VersionFixed in Version1.91RC4 
Summary04939: Group ordering problem: group_order not correctly initialized when adding groups
DescriptionWhen adding groups to a new survey, the group order cannot be changed.
Steps To Reproduce1. Create a new survey, you get f.e. id 13687

2. Start adding a group, save.
3. Observe at SQL level that the first group_order entry is set at "0". (Pardon my LISP here)

CL-USER> (clsql:query "select * from lime_groups where sid=13687")
((46 13687 "First group" 0 "Test opmerking first group
" "en"))
("gid" "sid" "group_name" "group_order" "description" "language")

3. Add another group and save.

4. Observe at SQL level that the second group_order entry is also set at "0".

CL-USER> (clsql:query "select * from lime_groups where sid=13687")
((46 13687 "First group" 0 "Test opmerking first group
" "en")
(47 13687 "Second group" 0 "Test remarks second group
" "en"))
("gid" "sid" "group_name" "group_order" "description" "language")

5. In limesurvey, try to flip the order of these groups. It is not possible.

Additional InformationWhen you manually re-initialize the group_order for one of those entries:
(clsql:query "update lime_groups set group_order=1 where gid=47 and sid=13687")

..you will be able to reorder.

Finally, adding a new group in limesurvey AFTER havng done the above, yields this result:
(clsql:query "select * from lime_groups where sid=13687")
((46 13687 "First group" 0 "Test opmerking first group
" "en")
 (47 13687 "Second group" 1 "Test remarks second group
" "en")
 (48 13687 "bla" 2 "This should be group 3
" "en"))
("gid" "sid" "group_name" "group_order" "description" "language")

..So it looks like group addition will go OK from then.


I did not attach this survey - since the reproduction is simple, basically an empty survey with two groups. Switching the DB driver does not seem to help.



I will donate to the project if issue is resolved within 48 hrsYes
LimeSurvey build number OR git commit ID9642
BrowserFirefox 3.6.13
Database & DB-VersionMS-SQL Server 2005 Database driver used = 'mssql_n'
Operating System (Server)Windows 2003
Webserver software & versionIIS5
PHP Version5.2
Attached Files

- Relationships

-  Notes
User avatar (14090)
Mazi (developer)
2011-02-08 18:05

Carsten, my first guess is that there is a MS SQL problem when adding groups. Can you check?
User avatar (14137)
c_schmitz (administrator)
2011-02-10 20:08

This happens with the mssql_n driver. mssql_odbc is not affected.
User avatar (14225)
c_schmitz (administrator)
2011-02-17 18:25

1.91RC4 released

- Issue History
Date Modified Username Field Change
2011-02-08 17:11 emilus New Issue
2011-02-08 18:05 Mazi Note Added: 14090
2011-02-08 18:05 Mazi Assigned To => c_schmitz
2011-02-08 18:05 Mazi Status new => assigned
2011-02-10 20:08 c_schmitz Note Added: 14137
2011-02-10 20:08 c_schmitz Status assigned => resolved
2011-02-10 20:08 c_schmitz Fixed in Version => 1.91RC4
2011-02-10 20:08 c_schmitz Resolution open => fixed
2011-02-17 18:25 c_schmitz Note Added: 14225
2011-02-17 18:25 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker