View Issue Details

IDProjectCategoryView StatusLast Update
08672Development [All Projects] Expression Managerpublic2015-08-21 15:51
ReporterDenisChenuAssigned ToDenisChenu 
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Product Version 
Target Version2.1Fixed in Version2.06 
Summary08672: Sub question attribute in mandatory question Filtered can not be answered
Description

If you set a filter to a Array/text or Multi text or Multi numeric : Sub question relevance status not tested when testing Sub question validation.

Steps To Reproduce

Import the lss file attached , it's an example with Multi Numerci "min value". But surely some example can be found.

Additional Information

Attended behaviour:

  • Test validation only if subquestion is relevant
    Existing behaviour:
  • Allways test validation
Tagsexpression manager, question settings, questions

Relationships

parent of 08665 closedDenisChenu Bug reports Multiple numeric doesn´t work after Matrix Filter 
child of 08335 new Development  Move Mandatory to EM system 

Activities

DenisChenu

DenisChenu

2014-02-06 15:04

developer  

limesurvey_survey_MULTINUM_minvalue_200_bug.lss (18,630 bytes)
DenisChenu

DenisChenu

2014-02-25 17:08

developer   ~28914

Last edited: 2014-02-25 17:10

View 2 revisions

1st idea :
Always use QQ_SQ.relevanceStatus when testing a sub question.

Not sure for 2.06/2.1 because don't really know if we start rewrite EM in 2.06 or if we just fox some issue.

PS: if someone have another idea .....

DenisChenu

DenisChenu

2014-06-04 18:11

developer   ~30051

Fix committed to 2.06 branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=14237

Related Changesets

LimeSurvey: 2.06 11ebc7d7

2014-06-04 16:09:36

DenisChenu

Details Diff
Fixed issue 08946: mandatory numerical input shows numerical only validation error
Fixed issue 08672: Sub question min_value_n attribute in mandatory question Filtered can not be answered
Dev: like other : leave mandatory for mandatory attribute
Dev: don't fix DATE question type
Dev: maybe same fix to apply elsewhere
Dev: we leave the 'red' color BUT : see bug(dev) 08335
Affected Issues
08672, 08946
mod - application/helpers/expressions/em_manager_helper.php Diff File

Issue History

Date Modified Username Field Change
2014-02-06 15:04 DenisChenu New Issue
2014-02-06 15:04 DenisChenu File Added: limesurvey_survey_MULTINUM_minvalue_200_bug.lss
2014-02-06 15:05 DenisChenu Relationship added parent of 08665
2014-02-25 17:02 c_schmitz Product Version 2.00+ => 2.05+
2014-02-25 17:07 c_schmitz Project Bug reports => Development
2014-02-25 17:07 DenisChenu Assigned To => DenisChenu
2014-02-25 17:07 DenisChenu Status new => assigned
2014-02-25 17:07 DenisChenu Product Version 2.05+ =>
2014-02-25 17:07 DenisChenu Target Version => 2.1
2014-02-25 17:08 DenisChenu Note Added: 28914
2014-02-25 17:09 DenisChenu Tag Attached: expression manager
2014-02-25 17:09 DenisChenu Tag Attached: questions
2014-02-25 17:09 DenisChenu Tag Attached: question settings
2014-02-25 17:10 DenisChenu Note Edited: 28914 View Revisions
2014-06-04 18:11 DenisChenu Changeset attached => LimeSurvey 2.06 11ebc7d7
2014-06-04 18:11 DenisChenu Note Added: 30051
2014-06-04 18:11 DenisChenu Resolution open => fixed
2014-06-04 18:15 DenisChenu Relationship added child of 08335
2014-06-04 18:15 DenisChenu Status assigned => resolved
2014-06-04 18:15 DenisChenu Fixed in Version => 2.06
2015-08-21 15:51 c_schmitz Status resolved => closed