View Issue Details

IDProjectCategoryView StatusLast Update
07129Development Survey editingpublic2014-10-26 12:34
ReporterDenisChenu Assigned ToDenisChenu  
PrioritylowSeverityminor 
Status closedResolutionduplicate 
Summary07129: Good question id, but page break
DescriptionIt's a specific issue, the url for question can change even if it can be OK.
Question view page need only the qid, not the group or survey id (this part is in question models), the if you made an error on group id, the link are bad.
Steps To ReproduceGet to a question view, send you the link by email : clicking this link is OK (for example for a co-worker).
Change the group of the question, the old link are bad ( Trying to get property of non-object )
Additional InformationThink we can review controllers/admin/surveyadmin view:
if qid is set : get the gid and sid from qid
if not and gid is set : get the sid from sid
if not go with surveyid

Mayve review edit group and edit question with same system
TagsNo tags attached.

Relationships

duplicate of 07692 closedDenisChenu Removing uneeded sid and gid from admin link 

Activities

DenisChenu

DenisChenu

2013-01-03 01:25

developer   ~23421

And,

Maybe we can put sid/gid/qid to array $params of createUrl and remove it from route (step by step).

Issue History

Date Modified Username Field Change
2013-01-03 01:22 DenisChenu New Issue
2013-01-03 01:25 DenisChenu Note Added: 23421
2013-01-03 09:45 c_schmitz Project Bug reports => Development
2014-10-26 12:33 DenisChenu Relationship added duplicate of 07692
2014-10-26 12:34 DenisChenu Status new => closed
2014-10-26 12:34 DenisChenu Assigned To => DenisChenu
2014-10-26 12:34 DenisChenu Resolution open => duplicate
2019-11-01 17:25 c_schmitz Category Survey design => Survey editing