View Issue Details

IDProjectCategoryView StatusLast Update
07063Development Expression Managerpublic2021-10-22 12:39
Reporterhelper Assigned Toc_schmitz  
PrioritynormalSeveritypartial_block 
Status closedResolutionfixed 
Target Version2.05 
Summary07063: Expression Manager Deletes Relevance Equation
DescriptionPreviously entered Relevance equations are cleared out when attempting to add anything from the Expression Manager.
Steps To Reproduce1. Using the attached survey, navigate to question ALC_AUDITC1.
2. Make note that there is a Relevance Equation - ((ALC_WKUSE.value * ALC_DAYUSE.value >= 14))
3. Click on the "Set conditions for this question" to enter the Expression Manager.
4. Add a condition (any condition will cause the predefined Relevance Equation to disappear. Click on the "Add condition" button.
5. Click on the home icon to return to the question - note that the predefine Relevance Equation has been replaced with the condition added in step 4.
Additional InformationIn addition, if there is a newly entered condition, you cannot change the value through the question editor and manually entering a value in the Relevance text box.
TagsNo tags attached.

Users monitoring this issue

User List mfaber

Activities

helper

helper

2012-12-11 14:23

reporter  

c_schmitz

c_schmitz

2012-12-11 14:30

administrator   ~23120

Yes, that's the expected behaviour. Conditions equations automatically replace any relevance equation.
helper

helper

2012-12-11 16:08

reporter   ~23143

So... if I need to set conditions for a question that has both expression and entered logic I need to do all as entered logic? Any plans on pumping up the functionality here?
tpartner

tpartner

2012-12-11 20:09

developer   ~23152

Anything that is generated by the conditions designer could be entered as an equation in the Relevance box of the question editor. The conditions designer is just a friendly UI to create those equations.

What I think is the real bug here is (as helper says) that once the conditions designer is used, you cannot edit the equation in the Relevance box. You must go back to the conditions designer and remove the condition first.
c_schmitz

c_schmitz

2012-12-11 21:16

administrator   ~23156

I agree.
sammousa

sammousa

2012-12-12 11:55

reporter   ~23164

c-schmitz is there a reason for this behavior? we could make it so that it just combines the expressions using logical and...
mdekker

mdekker

2012-12-12 13:25

reporter   ~23170

Expressions have no pretty editor (yet).

When there is a pretty editor that allows to select questions and answers easily it should replace the old conditions editor. If I remember correct this was plannend but due to lack of development capacity this is not yet done.

A warning when someone enters the condition editor that existing relevance will be erased should at least tell people about this expected (interim) behaviour.
TMSWhite

TMSWhite

2012-12-13 00:51

reporter   ~23200

Or have a pop-up dialog to give users some options:

(1) If there are existing conditions and edit relevance, let user decide whether to keep relevance (deleting conditions), or keep conditions (deleting custom relevance).

The core issue is that EM has a routine that automatically computes relevance from conditions if there are any conditions (LEM::ConvertConditionsToRelevance()). So, another option is to add a field to the question model that lets users decide whether to give precedence to conditions or relevance on a question-by-question basis.

Yet another option is to let users AND or OR together conditions and custom relevance as Sam suggests - but that would also require an extra attribute to the question model. if you want that route, I'd let users enter the short custom relevance in the text entry area, but show the entire relevance (including the portion from conditions) in the read-only displays of question (e.g. admin and show logic file).
mfaber

mfaber

2014-01-12 19:07

reporter   ~27836

To avoid frustration among users I'd vote for mdekker's info/warning message...relatively quickly implemented and effective....until there's a proper GUI for relevance equations, at which point conditions can be "switched off".

Relevance equations converted from conditions could be made editable. But again better after a warning that, if edited, the GUI editor can not be used anymore to further work on this equation.

Issue History

Date Modified Username Field Change
2012-12-11 14:23 helper New Issue
2012-12-11 14:23 helper File Added: limesurvey_survey_612676.lss
2012-12-11 14:30 c_schmitz Note Added: 23120
2012-12-11 16:08 helper Note Added: 23143
2012-12-11 20:09 tpartner Note Added: 23152
2012-12-11 21:16 c_schmitz Note Added: 23156
2012-12-12 11:55 sammousa Note Added: 23164
2012-12-12 13:25 mdekker Note Added: 23170
2012-12-12 22:27 c_schmitz Assigned To => c_schmitz
2012-12-12 22:27 c_schmitz Status new => assigned
2012-12-13 00:51 TMSWhite Note Added: 23200
2012-12-22 11:29 c_schmitz Target Version => 2.10
2012-12-22 11:29 c_schmitz Project Bug reports => Development
2013-01-30 04:19 mfaber Issue Monitored: mfaber
2013-03-18 22:29 c_schmitz Target Version 2.10 => 2.05
2014-01-12 19:07 mfaber Note Added: 27836
2021-10-22 12:39 galads Status assigned => closed
2021-10-22 12:39 galads Resolution open => fixed