View Issue Details

IDProjectCategoryView StatusLast Update
07037Development [All Projects] Survey takingpublic2012-12-22 02:46
ReporterDenisChenu Assigned ToDenisChenu  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version2.1 
Summary07037: In some condition, unable to enter in survey
Description

I have some difficulty to find exactly the condition to reproduce, but sometimes i have:
PHP notice
Undefined variable: hiddenfieldnames
/htdocs/limesurvey_GIT/dev/application/helpers/SurveyRuntimeHelper.php(739)

Steps To Reproduce

Maybe:
Import lss files,
Activate survey
Add a token table
Make dummy token
Launch 1 or 2 time the survey by the token link

Additional Information

$hiddenfieldnames CAN nOT be defined, but why sometimes survey don't go to this stage ????

$hiddenfielsnames are used only at line 735/740.
In 2.0, is set by :$hiddenfieldnames = implode("|", $inputnames); with inputnames, all inputnames of question.

I don't know why exactly hiddenfieldnames is used, but sure for EM ....

TagsNo tags attached.

Activities

DenisChenu

DenisChenu

2012-12-06 02:22

developer   ~22949

When it work,

SurveyRuntimeHelper / function run seems to be not used (put a die at start of function ...)

TMSWhite

TMSWhite

2012-12-06 03:51

reporter   ~22952

EM doesn't use $hiddenfieldnames at all. It may help generate them, but it doesn't use them for validation the way 1.91 did.

DenisChenu

DenisChenu

2012-12-06 08:38

developer   ~22958

OK,

Thank you Thomas.

I think we can remove this function because even without SurveyRuntimeHelper / function run using there are an hidden input with inputnames.

Add to test with "upload question type".

Denis

DenisChenu

DenisChenu

2012-12-22 02:46

developer   ~23347

Fixed some time ago with another bug

Issue History

Date Modified Username Field Change
2012-12-06 02:14 DenisChenu New Issue
2012-12-06 02:15 DenisChenu Description Updated View Revisions
2012-12-06 02:22 DenisChenu Note Added: 22949
2012-12-06 03:51 TMSWhite Note Added: 22952
2012-12-06 08:38 DenisChenu Note Added: 22958
2012-12-06 09:43 c_schmitz Project Bug reports => Development
2012-12-22 02:46 DenisChenu Note Added: 23347
2012-12-22 02:46 DenisChenu Status new => closed
2012-12-22 02:46 DenisChenu Assigned To => DenisChenu
2012-12-22 02:46 DenisChenu Resolution open => fixed
2012-12-22 02:46 DenisChenu Fixed in Version => 2.1