Anonymous Login
2016-12-04 02:53 CET

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
05983Development Survey Designpublic2015-08-21 15:51
ReporterDenisChenu 
Assigned ToDenisChenu 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
Product Version 
Target Version2.06Fixed in Version2.06 
Summary05983: Comportment of "Equation question type"
DescriptionHello,

When i look to equation question type, i search for a "value" option. For example, put the equation in default value.
But here : the question set the value.

Maybe it's best to separate the value and the question text.
Then we can have :
question text : Yes ! you're the best because you gain {ASSESMENT} point
value in DB : {ASSESMENT}

Then it's more clear for user.
Additional InformationIdea:
Add advanced setting :
Equation
Only for equation question type

Or use "default value" settings.

After we can remove the extra <div clas="em_equation"> from replacement.php

Can get it.
TagsNo tags attached.
Attached Files

-Relationships
related to 08673closedDenisChenu Bug reports Equation attribute 'numeric' do nothing 
related to 08885new Feature requests Validate 'mandatory' equation 
+Relationships

-Notes

~18187

DenisChenu (developer)

Sorry,

I put in bug report, it's not a bug it's a dev :)

~18197

TMSWhite (reporter)

I don't understand what you are asking.

The equation question type saves in the database as a text field, so it can store numbers, dates, or even full reports (which reference many variables). Also, only a subset of equations are like what you describe. Often they are intermediate calculations used for branching logic or scoring, so you would never have an Assessment-like message for them.

So, I don't think we should change the way the equation question type is implemented.

On the other hand, if you are asking for an easier way to represent assessments, that could certainly be discussed.

~18198

DenisChenu (developer)

Last edited: 2012-04-04 19:01

View 4 revisions

It's not specific for assesment, it's just for an example. I had to explain how to use equation question type at a user on the forum, and i understand why she don't understand.

For an example:
The equation : to be in database: young/old
(the equation make somethink like {if age.value<35,'young','old'})

But you can want to show:

<question>You're are {if age.value<35,'young','old'})</question>
 but save only
<database>{if age.value<35,'young','old'}</database>

Then i think an advanced parameter with : Equation:
Can be a good solution.

Or use the default value.

Like i say, it's not a bug; but an improvement.
If (attribute['equation']=="")
{
attribute['equation']==question['question'];
}

And input are <input type="hidden" id .... value="attribute['equation']" />

we use only attribute['equation'] in database.

~25616

DenisChenu (developer)

Put it for 2.05.

Extra div must e removed too. This "div" must be in answer part.

~25741

mdekker (developer)

Last edited: 2013-07-09 09:46

View 2 revisions

Why not use a boilerplate to display to the respondent and expression field for the db value? No work needed.

EDIT: expression field = equation question type

~25742

DenisChenu (developer)

Last edited: 2013-07-09 09:51

View 2 revisions

Yes Menno,

But think it's a workaround, think beter is to have allways difference betwwen : what is shown and what is put in DB.

Maybe not for 2.05, but better for 2.1 (Question Plugon).

Denis
PS: confirm the severity : minor

~26083

DenisChenu (developer)

@mdeker : and actually 'boilerplate' add a column in database. This can break some survey if you have a lot of equation.

~31807

DenisChenu (developer)

Fix committed to 2.06 branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=15023
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2012-04-04 11:47 DenisChenu New Issue
2012-04-04 11:47 DenisChenu Status new => assigned
2012-04-04 11:47 DenisChenu Assigned To => TMSWhite
2012-04-04 11:48 DenisChenu Note Added: 18187
2012-04-04 18:03 TMSWhite Note Added: 18197
2012-04-04 18:36 c_schmitz Project Bug reports => Development
2012-04-04 18:36 c_schmitz Category Survey design => Survey Design
2012-04-04 18:57 DenisChenu Note Added: 18198
2012-04-04 18:58 DenisChenu Note Edited: 18198 View Revisions
2012-04-04 18:59 DenisChenu Note Edited: 18198 View Revisions
2012-04-04 19:01 DenisChenu Note Edited: 18198 View Revisions
2012-08-14 23:18 c_schmitz Assigned To TMSWhite => DenisChenu
2012-08-14 23:18 c_schmitz Product Version 1.92+ =>
2012-08-14 23:18 c_schmitz Target Version => 2.1
2013-06-22 11:44 DenisChenu Note Added: 25616
2013-06-22 11:44 DenisChenu Target Version 2.1 => 2.05
2013-07-09 09:46 mdekker Note Added: 25741
2013-07-09 09:46 mdekker Note Edited: 25741 View Revisions
2013-07-09 09:51 DenisChenu Note Added: 25742
2013-07-09 09:51 DenisChenu Note Edited: 25742 View Revisions
2013-08-26 12:18 DenisChenu Note Added: 26083
2014-03-21 09:11 DenisChenu Relationship added related to 08673
2014-03-21 09:12 DenisChenu Relationship added related to 08885
2015-03-04 12:16 DenisChenu Target Version 2.05 => 2.06
2015-03-12 10:51 DenisChenu Changeset attached => LimeSurvey 2.06 5485367e
2015-03-12 10:51 DenisChenu Note Added: 31807
2015-03-12 10:51 DenisChenu Resolution open => fixed
2015-03-12 10:51 DenisChenu Status assigned => resolved
2015-03-12 10:51 DenisChenu Fixed in Version => 2.06
2015-08-21 15:51 c_schmitz Status resolved => closed
+Issue History