View Issue Details

IDProjectCategoryView StatusLast Update
05781Development Survey takingpublic2019-09-23 12:18
ReporterDenisChenu Assigned Toc_schmitz  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version3.x 
Summary05781: Implement WAI-ARIA for accessibility
Description

Actually, LS have some painless for accessibilty.

But some question made can have great difficulty to be labelled clean.

Actually, w3c work on WAI-ARIA, and Aria offer great possibility for labelling:

I think specially at aria-labelledby : http://www.w3.org/TR/wai-aria/states_and_properties#aria-labelledby for input in table.

Steps To Reproduce

Try FANGS to answer a survey.

Try with Array / Array 5 point for example.

https://addons.mozilla.org/fr/firefox/addon/fangs-screen-reader-emulator/

Additional Information

I think the best is to do some labelling <label> when we can.
But sometimes, it's seems to be a pity to have labelling even for blind people.

I think screen-reader have some option for WAI-ARIA, then it can be good to implement in LS.

For 2.1 maybe ;), but starting in 2.0 can be a good option.

TagsNo tags attached.

Activities

DenisChenu

DenisChenu

2016-04-13 09:49

developer   ~37280

Last edited: 2016-04-13 09:50

View 2 revisions

Louis start it in https://github.com/LimeSurvey/LimeSurvey/commit/167f1ebd76a619a20b5a1326f09285c38e8d3929

We go ?
If yes : i have a lot of fix to send

PS : label is inline, user use a lot "div/table" in label : maybe the labelled-by is great everywhere

Issue History

Date Modified Username Field Change
2012-02-08 18:18 DenisChenu New Issue
2012-02-09 01:21 c_schmitz Project Bug reports => Development
2016-04-13 09:49 DenisChenu Note Added: 37280
2016-04-13 09:49 DenisChenu Assigned To => c_schmitz
2016-04-13 09:49 DenisChenu Status new => feedback
2016-04-13 09:50 DenisChenu Note Edited: 37280 View Revisions
2019-01-12 11:02 DenisChenu Status feedback => resolved
2019-01-12 11:02 DenisChenu Resolution open => fixed
2019-01-12 11:02 DenisChenu Fixed in Version => 3.x
2019-09-23 12:18 c_schmitz Status resolved => closed