View Issue Details

IDProjectCategoryView StatusLast Update
04482User patchesOtherpublic2010-08-04 23:11
Reporteruser8934Assigned Toc_schmitz  
PriorityhighSeveritycrash 
Status closedResolutionfixed 
Product Version1.87 
Target VersionFixed in Version1.90 
Summary04482: SendMail does'n work without authentication (just telling how to fix)
Description

Application tries to authenticate even when user and password are leaved blank on global settings.

Steps To Reproduce

The error always occur when you try to connect on a SMTP server that doesn't require authentication.

This happened on my corporate intranet where mail servers didn't require user credentials.

Additional Information

The problem was already solved!
I took this answer from one forum and due to didn't have found this bug officialy reported, so decided to contribute.

How to fix:
On file common.php, line 4464 just surround $emailsmtpuser variable by a trim.

common.php line 4464
Original:if ($emailsmtpuser!="")
Patched: if (trim($emailsmtpuser)!="")

TagsNo tags attached.
Complete LimeSurvey version number (& build)8518

Activities

c_schmitz

c_schmitz

2010-07-18 15:05

administrator   ~12450

Thank you!

Issue History

Date Modified Username Field Change
2010-07-14 18:37 user8934 New Issue
2010-07-16 15:35 Mazi Assigned To => c_schmitz
2010-07-16 15:35 Mazi Status new => assigned
2010-07-18 15:04 c_schmitz Status assigned => resolved
2010-07-18 15:04 c_schmitz Fixed in Version => 1.90
2010-07-18 15:04 c_schmitz Resolution open => fixed
2010-07-18 15:05 c_schmitz Note Added: 12450
2010-08-04 23:11 c_schmitz Status resolved => closed