View Issue Details

IDProjectCategoryView StatusLast Update
16879Development Survey editingpublic2021-03-07 21:56
Reporterollehar Assigned Toollehar  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version4.x.0-dev 
Target Version4.x.0-dev 
Summary16879: All question themes will be available in question selector
DescriptionTitle, plus the setting "question theme" will then be removed.

Must work with <select> question type selector too.

The XML setting will be obsolete.
TagsNo tags attached.

Activities

tammo

tammo

2020-12-08 15:08

partner   ~60863

Idea, not well worked out yet: I can imagine that theme developer can include/exclude question types/question themes in some way. For example: exclude array questions from mobile only theme.
DenisChenu

DenisChenu

2020-12-08 15:10

developer   ~60864

I'm unsure on this point .
Example

- Button : it's a question type for single choice, but an attribute for YesNo and gender. I think here : Theme as attribute is OK
- Checkbox for Array number : clearly must be a theme separate as Question type
- https://gitlab.com/SondagesPro/QuestionTheme/arraytext_display_rows : I think it's best if it's stay a QuestionTheme and not a Question Type
- https://gitlab.com/SondagesPro/QuestionTheme/really_hidden_equation : I think it's best if it's stay a QuestionTheme and not a Question Type
- https://gitlab.com/SondagesPro/QuestionTheme/EmailInput QuestionTyep OK ONLY when we can add validation Expression in QuestionTheme
tpartner

tpartner

2020-12-08 15:11

developer   ~60865

Last edited: 2020-12-08 15:12

View 2 revisions

Overall, makes sense but I would like to see an indication of what is core and what is custom.
DenisChenu

DenisChenu

2020-12-08 15:27

developer   ~60866

Another Example (with Slider of Tony )
Slider question is a settings of Multi numeric
But 2 specific slider is new Question type https://github.com/tpartner/LimeSurvey-Slider-Controls-3x

Since Theme dev can choose to be in dropdown or in Theme chooser : why change tis ? Realy needed ? If it's for more stability OK.
But if you think it's for user : i really think it's false. I can be more complicated for some user (and less unerstandable).
ollehar

ollehar

2020-12-25 15:37

administrator   ~61164

Merged into develop.

Issue History

Date Modified Username Field Change
2020-12-08 15:05 ollehar New Issue
2020-12-08 15:07 ollehar Description Updated View Revisions
2020-12-08 15:07 ollehar Steps to Reproduce Updated View Revisions
2020-12-08 15:08 tammo Note Added: 60863
2020-12-08 15:10 DenisChenu Note Added: 60864
2020-12-08 15:11 tpartner Note Added: 60865
2020-12-08 15:12 tpartner Note Edited: 60865 View Revisions
2020-12-08 15:27 DenisChenu Note Added: 60866
2020-12-08 15:59 ollehar Product Version => 4.0.0dev
2020-12-08 16:08 ollehar Product Version 4.0.0dev => 4.x.0-dev
2020-12-08 16:08 ollehar Target Version 4.0.0dev => 4.x.0-dev
2020-12-25 15:37 ollehar Note Added: 61164
2020-12-25 15:37 ollehar Assigned To => ollehar
2020-12-25 15:37 ollehar Status new => resolved
2020-12-25 15:37 ollehar Resolution open => fixed
2021-03-07 21:56 c_schmitz Status resolved => closed