View Issue Details

IDProjectCategoryView StatusLast Update
14726Bug reportsSurvey takingpublic2020-03-16 10:04
Reporterbismark Assigned ToMazi  
PrioritynoneSeverityminor 
Status newResolutionreopened 
Product Version3.22.8 
Summary14726: LanguageSelector national language
Descriptionthe language selector should always display languages in the appropriate national language?
then it should always be the same list, but it isn't.

eg

Deutsch, Englisch, Italiano instead of Deutsch, English, Italiano

in zh-Hans we can see English in chinese letters - Deutsch, Italiano are correct
TagsNo tags attached.
Complete LimeSurvey version number (& build)master
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Version10.1.26-MariaDB
Server OS (if known)
Webserver software & version (if known)
PHP Version7.1.8

Activities

Mazi

Mazi

2019-04-03 18:03

partner   ~51320

I can reproduce this, the way languages are listed at the JS language switch drop down seems not to be consistent.
DenisChenu

DenisChenu

2019-04-03 18:17

developer   ~51323

Last edited: 2019-04-03 18:19

View 2 revisions

Unsure it must be only «national language» but must have national language.

Maybe adding language iso code too ? https://en.wikipedia.org/wiki/IETF_language_tag

French - Français
Spanich (Spain) - Español (España)
Spanich (Mexico) - Español (Mexico)
Chinese (Simplified) - 中文(简体)

Mazi

Mazi

2019-04-04 09:45

partner   ~51335

I think listing both versions (string with local language + each language with its own translation) makes sense.
c_schmitz

c_schmitz

2019-05-23 15:11

administrator   ~52083

@bismark: To which language selector are you actually referring to? Screenshot would help, also.
c_schmitz

c_schmitz

2020-03-14 21:36

administrator   ~56547

Closed due to missing feedback.
Mazi

Mazi

2020-03-16 10:02

partner   ~56562

Re-opend, will add screenshots.
Mazi

Mazi

2020-03-16 10:04

partner   ~56563

This issue shows up when using the javaScript based language selector which directly changes the languages after having picked a lnaguage from the drop down. As you can see from the screenshot the language lists look different for the non-JS version (used "vanilla" theme for testing) and the JS based version tested with our template.
The non-JS version looks correct to me but at the JS based language list the languages are not listed using the native language.
en-van.png (18,398 bytes)   
en-van.png (18,398 bytes)   
es-van.png (21,049 bytes)   
es-van.png (21,049 bytes)   
es.png (50,585 bytes)   
es.png (50,585 bytes)   
en.png (52,068 bytes)   
en.png (52,068 bytes)   

Issue History

Date Modified Username Field Change
2019-04-03 10:53 bismark New Issue
2019-04-03 18:03 Mazi Assigned To => Mazi
2019-04-03 18:03 Mazi Status new => acknowledged
2019-04-03 18:03 Mazi Note Added: 51320
2019-04-03 18:17 DenisChenu Note Added: 51323
2019-04-03 18:19 DenisChenu Note Edited: 51323 View Revisions
2019-04-04 09:45 Mazi Note Added: 51335
2019-05-23 15:11 c_schmitz Status acknowledged => feedback
2019-05-23 15:11 c_schmitz Note Added: 52083
2020-03-14 21:36 c_schmitz Status feedback => closed
2020-03-14 21:36 c_schmitz Resolution open => unable to reproduce
2020-03-14 21:36 c_schmitz Note Added: 56547
2020-03-16 10:02 Mazi Status closed => new
2020-03-16 10:02 Mazi Resolution unable to reproduce => reopened
2020-03-16 10:02 Mazi Category Translation => Survey taking
2020-03-16 10:02 Mazi Product Version => 3.22.8
2020-03-16 10:02 Mazi Note Added: 56562
2020-03-16 10:04 Mazi File Added: en-van.png
2020-03-16 10:04 Mazi File Added: es-van.png
2020-03-16 10:04 Mazi File Added: es.png
2020-03-16 10:04 Mazi File Added: en.png
2020-03-16 10:04 Mazi Note Added: 56563