View Issue Details

IDProjectCategoryView StatusLast Update
14666Bug reports[All Projects] Survey takingpublic2019-05-27 09:35
ReporterjeloAssigned ToDenisChenu 
PrioritynoneSeveritymajor 
Status assignedResolutionreopened 
Product Version3.16.x 
Target VersionFixed in Version 
Summary14666: Samsung Internet Browser + Video : Forward or Submit triggers "Please use the Survey navigation buttons or index"
Description

Under Samsung Internet Browser a video is played inside a survey.
After playing the video the forward / submit button triggers the browser button detection.

Try on this survey:
https://www.6ws.at/cawi/index.php/862482?lang=de

The survey is simple and raised the same error on other LimeSurvey installations.
LS 2.06, LS 3.16 and LS Professional.

To me it looks like the detection code is raised when "exotic" videoplayerroutines are used (not that unusual on mobile platforms and browser). A way to disable this detection might be a good thing, to keep surveys in the game.

Steps To Reproduce

Use Samsung Internet Browser (Android https://play.google.com/store/apps/details?id=com.sec.android.app.sbrowser )

https://www.6ws.at/cawi/index.php/862482?lang=de

Survey and MP4 video attached

The survey is simple and raised the same error on other LimeSurvey installations.
LS 2.06, LS 3.16 and LS Professional.

Additional Information

I opened this ticket based on the discussion in the German forum.
https://www.limesurvey.org/forum/german-forum/104999-kein-weiterkommen-bei-mit-video-button-eingebundenem-video

Samsung Browser Issues / Developer
https://github.com/SamsungInternet/support

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.15.9+190214
I will donate to the project if issue is resolvedNo
BrowserSamsung Internet Browser 8.2.01.2 (checked under Android 6,7 and 9)
Database & DB-VersionN/A
Server OS (if known)
Webserver software & version (if known)
PHP VersionN/A

Activities

jelo

jelo

2019-03-20 09:16

partner  

survey_samsunginternet.lss (17,789 bytes)
test.mp4 (991,088 bytes)
DenisChenu

DenisChenu

2019-03-20 17:26

developer   ~51075

Last edited: 2019-03-20 17:39

View 4 revisions

Can confirm with Samsung internet on LineAgeOS (Thanks YalpStore). Ok with some other browser.

Seems not related to template : https://demo.sondages.me/953474

Else about detection system : It's done using a SESSION var and an hidden input var : if it's broken : all submit can be broken.

Edit : name of the var (and input) LEMpostKey …

jelo

jelo

2019-03-20 22:00

partner   ~51079

Thanks for checking. I had some success with tapping in the free html canvas after watching the video and then answering the question and then hitting forward/submit.

This prevention detection should be optional.

It's the checkIfUseBrowserNav() function:
https://github.com/LimeSurvey/LimeSurvey/blob/5955f725682cfc5b0279334a648a3d9f95a401b0/application/helpers/SurveyRuntimeHelper.php#L722

Let's say the Samsung Internet Browser executes an external video player and then returns to the browser.
I'm not that into mobile platforms. But a setting to disable this browser button detection would help.

c_schmitz

c_schmitz

2019-03-21 08:13

administrator   ~51080

This detection cannot be optional. As said, if the detection jumps in the page has not been properly submitted (which is usually the case if the user uses the browser buttons instead of page navigation)-.
So if your applet triggers that issue then the page is not properly POSTed.

jelo

jelo

2019-03-21 09:11

partner   ~51081

#1 This kind of detection is optional in other survey tools.
#2 It's no applet, it's the video tag handling by the Samsung Internet Browser.

But i will inform the forum user about the closing.

c_schmitz

c_schmitz

2019-03-23 21:09

administrator   ~51108

I am not able to reproduce this on a Samsung smartphone (S5) using the above example link.

DenisChenu

DenisChenu

2019-03-24 11:16

developer   ~51109

Strange ? With SamsungInternet ?

You click to play the video ?

Else : i think it's browser unfixable issue but , strange you can't reproduce. Maybe an update of SamsungInternet ?

c_schmitz

c_schmitz

2019-03-24 17:05

administrator   ~51111

Yeah, did everything (using the Samsung browser) - played video, normal and fullscreen. No problems.

jelo

jelo

2019-03-24 17:42

partner   ~51112

I don't think the URL will be able to show the bug anmore.
The threadstarter already patched the installation and removed the browser button detection.

/$this->checkIfUseBrowserNav(); // Check if user used browser navigation, or relaoded page/

DenisChenu

DenisChenu

2019-03-25 08:35

developer   ~51113

Ok, mine still valid.
I add some tracevar when find time to understand what happen exactly.

(and set this topic to «acknowledged» / «won't fix»)

Issue History

Date Modified Username Field Change
2019-03-20 09:16 jelo New Issue
2019-03-20 09:16 jelo File Added: survey_samsunginternet.lss
2019-03-20 09:16 jelo File Added: test.mp4
2019-03-20 09:25 jelo Steps to Reproduce Updated View Revisions
2019-03-20 09:25 jelo Additional Information Updated View Revisions
2019-03-20 17:26 DenisChenu Note Added: 51075
2019-03-20 17:35 DenisChenu Note Edited: 51075 View Revisions
2019-03-20 17:37 DenisChenu Note Edited: 51075 View Revisions
2019-03-20 17:39 DenisChenu Note Edited: 51075 View Revisions
2019-03-20 22:00 jelo Note Added: 51079
2019-03-21 08:13 c_schmitz Note Added: 51080
2019-03-21 08:13 c_schmitz Assigned To => c_schmitz
2019-03-21 08:13 c_schmitz Status new => closed
2019-03-21 08:13 c_schmitz Resolution open => not fixable
2019-03-21 09:11 jelo Note Added: 51081
2019-03-23 21:09 c_schmitz Note Added: 51108
2019-03-24 11:16 DenisChenu Status closed => feedback
2019-03-24 11:16 DenisChenu Resolution not fixable => reopened
2019-03-24 11:16 DenisChenu Note Added: 51109
2019-03-24 17:05 c_schmitz Note Added: 51111
2019-03-24 17:42 jelo Note Added: 51112
2019-03-24 17:42 jelo Status feedback => assigned
2019-03-25 08:35 DenisChenu Note Added: 51113
2019-05-23 15:48 c_schmitz Assigned To c_schmitz => DenisChenu
2019-05-27 09:35 DenisChenu Summary Forward or Submit triggers "Please use the Survey navigation buttons or index" => Samsung Internet Browser + Video : Forward or Submit triggers "Please use the Survey navigation buttons or index"