View Issue Details

IDProjectCategoryView StatusLast Update
14550Bug reports[All Projects] LimeSurvey Websitepublic2019-02-23 11:14
ReporterDenisChenu Assigned Toollehar  
PrioritynoneSeverityminor 
Status assignedResolutionreopened 
Product Version4.0.0dev 
Target VersionFixed in Version 
Summary14550: Trying to update existing extension receive an error when sumbnit
Description

I try to update SkelVanilla with

  • Update title to SkelVanilla with a11y and options
  • Update long description
  • Adding pictures
  • zip file

Receive
0
Error: 0

Call to a member function transactionRollback() on null

Steps To Reproduce

?

Additional Information

Attached the element : maybe ?

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.0.0 github
I will donate to the project if issue is resolvedNo
Browserff
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Activities

DenisChenu

DenisChenu

2019-02-19 11:40

developer  

one.png (126,796 bytes)
two.png (237,657 bytes)
skelvanilla.zip (1,905,527 bytes)
ollehar

ollehar

2019-02-19 11:51

administrator   ~50625

Shit. Will fix. Sorry.

ollehar

ollehar

2019-02-19 11:55

administrator   ~50626

Applied a fix, but you might see another error. Please try again.

DenisChenu

DenisChenu

2019-02-19 12:12

developer   ~50627

Zip file is too big. ???

ollehar

ollehar

2019-02-19 12:21

administrator   ~50628

Did you see such an error? Screenshot?

DenisChenu

DenisChenu

2019-02-19 13:39

developer  

DenisChenu

DenisChenu

2019-02-19 13:39

developer   ~50629

Just : edit / set zip to the one here, save

ollehar

ollehar

2019-02-19 13:46

administrator   ~50630

That's funny. How big is your zip file?

DenisChenu

DenisChenu

2019-02-19 13:56

developer   ~50631

Last edited: 2019-02-19 13:59

View 2 revisions

skelvanilla.zip (1,905,527 bytes) see attached zip here :)

A lot of variations => each ~ 130 kB

DenisChenu

DenisChenu

2019-02-19 14:02

developer   ~50632

I have one with more bigger size : https://dl.sondages.pro/limeMpdf.zip
Include fonts (because include mpdf) then 46M :)

ollehar

ollehar

2019-02-19 14:22

administrator   ~50633

OK, have to discuss upload limits with Carsten, will fix after.

DenisChenu

DenisChenu

2019-02-19 14:30

developer   ~50634

For template 2Mo is not a lot since there can have

  1. A lot of variations
  2. Picture

About mPdf : right, it's big here … then : must allow external URL ?

DenisChenu

DenisChenu

2019-02-22 17:52

developer   ~50680

Still not able tu update for SkelVanilla … less than 2M.

I really think theme need 3/4Mo.

About limeMpdf : i wait to know the size limit to see if i can remove fonts directory in "light" distribution (using LimeSurvey core fonts). Then can close for limeMpdf. But i don't see how i can reduce skelvanilla (all css are minimized, but there are a lot …)

ollehar

ollehar

2019-02-22 22:43

administrator   ~50681

We'll increase it to 50 Mb.

DenisChenu

DenisChenu

2019-02-23 11:14

developer   ~50682

Ouah really huge :).

Like i say : i think limeMpdf can have 2 versions : one with all mpdf fonts, and one using limesurvey included fonts (but need to construct the config-font file).
I work to include a way to use fa fonts currently, but working on remove fonts its' cool too :)

PS : i open another bug report about moving from tpcf to mpdf.

Issue History

Date Modified Username Field Change
2019-02-19 11:40 DenisChenu New Issue
2019-02-19 11:40 DenisChenu Status new => assigned
2019-02-19 11:40 DenisChenu Assigned To => ollehar
2019-02-19 11:40 DenisChenu File Added: one.png
2019-02-19 11:40 DenisChenu File Added: two.png
2019-02-19 11:40 DenisChenu File Added: skelvanilla.zip
2019-02-19 11:51 ollehar Note Added: 50625
2019-02-19 11:55 ollehar Status assigned => feedback
2019-02-19 11:55 ollehar Note Added: 50626
2019-02-19 12:12 DenisChenu Note Added: 50627
2019-02-19 12:12 DenisChenu Status feedback => assigned
2019-02-19 12:21 ollehar Note Added: 50628
2019-02-19 13:39 DenisChenu File Added: Capture d’écran du 2019-02-19 13-39-15.png
2019-02-19 13:39 DenisChenu Note Added: 50629
2019-02-19 13:46 ollehar Note Added: 50630
2019-02-19 13:56 DenisChenu Note Added: 50631
2019-02-19 13:59 DenisChenu Note Edited: 50631 View Revisions
2019-02-19 14:02 DenisChenu Note Added: 50632
2019-02-19 14:22 ollehar Note Added: 50633
2019-02-19 14:30 DenisChenu Note Added: 50634
2019-02-22 17:29 ollehar Status assigned => closed
2019-02-22 17:29 ollehar Resolution open => fixed
2019-02-22 17:52 DenisChenu Status closed => feedback
2019-02-22 17:52 DenisChenu Resolution fixed => reopened
2019-02-22 17:52 DenisChenu Note Added: 50680
2019-02-22 22:43 ollehar Note Added: 50681
2019-02-23 11:14 DenisChenu Note Added: 50682
2019-02-23 11:14 DenisChenu Status feedback => assigned