View Issue Details

IDProjectCategoryView StatusLast Update
12881Bug reports[All Projects] Installationpublic2018-01-15 10:35
ReporterfvanderstarreAssigned ToLouisGac 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.0.0-rc.x 
Target VersionFixed in Version 
Summary12881: Exception on trying to view template list
DescriptionAfter fresh install of 3.0 RC2 with some preexisting templates from version 2.xx I get an exception when trying to view template list.
"can't find a template for template 'Test_default_new' in path 'view_folder'. "
Test_default_new was based on a copy of the default template in version 2.xx.
I deleted the template folder for Test_default_new but the error message remains the same.
Steps To ReproduceSee above.
TagsNo tags attached.
Complete LimeSurvey version number (& build)3.0.0-RC.2 + 171102
I will donate to the project if issue is resolvedNo
BrowserAny
Database & DB-VersionMS-SQL 2008 R2
Operating System (Server)Linux RHEL 7
Webserver software & versionApache 2.4.6
PHP Version5.6.31

Activities

LouisGac

LouisGac

2017-11-10 13:56

manager   ~45017

1. If they are some files from 2.x, it's not a fresh install ;-)
2. It doesn't happen if debug mode is off

But sill need to list all the none working templates
fvanderstarre

fvanderstarre

2017-11-10 14:03

reporter   ~45018

Still getting the exception after setting debug=0...
LouisGac

LouisGac

2017-11-10 14:15

manager   ~45019

I can't reproduce then.
you tried first to install the template or something right?
LouisGac

LouisGac

2017-11-10 14:17

manager   ~45020

yep confirmed: it's when trying to install a template for 2.5
thx for reporting
LouisGac

LouisGac

2017-11-10 16:19

manager   ~45022

Fix committed to develop branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=24781
c_schmitz

c_schmitz

2018-01-15 10:35

administrator   ~45608

Version 3.0.3 released.

Related Changesets

LimeSurvey: develop 70a95042

2017-11-10 16:18:40

LouisGac

Details Diff
Fixed issue 12881: Exception on trying to view template list
mod - application/models/TemplateConfiguration.php Diff File

Issue History

Date Modified Username Field Change
2017-11-09 15:06 fvanderstarre New Issue
2017-11-10 13:56 LouisGac Note Added: 45017
2017-11-10 14:03 fvanderstarre Note Added: 45018
2017-11-10 14:15 LouisGac Note Added: 45019
2017-11-10 14:17 LouisGac Note Added: 45020
2017-11-10 14:17 LouisGac Sticky Issue No => Yes
2017-11-10 16:19 LouisGac Changeset attached => LimeSurvey develop 70a95042
2017-11-10 16:19 LouisGac Note Added: 45022
2017-11-10 16:19 LouisGac Assigned To => LouisGac
2017-11-10 16:19 LouisGac Resolution open => fixed
2017-11-10 16:19 LouisGac Status new => resolved
2018-01-12 13:18 c_schmitz Sticky Issue Yes => No
2018-01-15 10:35 c_schmitz Note Added: 45608
2018-01-15 10:35 c_schmitz Status resolved => closed