View Issue Details

IDProjectCategoryView StatusLast Update
12852Bug reports[All Projects] Pluginspublic2017-12-21 18:46
ReporterDenisChenu Assigned Tomarkusfluer  
PrioritynoneSeverityminor 
Status assignedResolutionreopened 
Product Version3.0.0-rc.x 
Target VersionFixed in Version3.0.0-rc.x 
Summary12852: Separation of survey plugins setting
Description

During 3.0 alpha test, we have clean separation between plugins settings. It's not the case today

Steps To Reproduce

Look at 3.0.0 alpha (2.57.1 merged) and compare with Version 3.0.0-beta.3

Additional Information

Separation of plugins settings is really cool ;)

TagsNo tags attached.
Complete LimeSurvey version number (& build)20171030
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

related to 12536 assignedmarkusfluer Where is the plugin Survey setting 

Activities

DenisChenu

DenisChenu

2017-10-30 12:27

developer  

DenisChenu

DenisChenu

2017-10-30 12:29

developer   ~44898

After activation of AuditLog plugin , ;)

LouisGac

LouisGac

2017-11-01 18:58

manager   ~44925

must be a wrong merge...

markusfluer

markusfluer

2017-11-03 12:12

administrator   ~44949

Sorry forgot to close this one

DenisChenu

DenisChenu

2017-11-03 12:22

developer   ~44951

Still have same behaviour in last version

Each plugin must have (have in previous 3.0 version) own menu.

DenisChenu

DenisChenu

2017-11-03 12:24

developer   ~44952

And currently there are 2 plugins menu (even without activated plugins)



markusfluer

markusfluer

2017-11-03 12:32

administrator   ~44954

Ok now I know what you mean.
Right now, the plugin menuentry should only show the activated plugins, like it was the case in the old version.
For every plugin to have a seperate menu entry, the plugin has to create the entry.

I will update the audit log plugin to add an entry for final release, so that it may be used as a blueprint

DenisChenu

DenisChenu

2017-12-20 18:11

developer   ~45350

@markusluer : new version is more complex than befoer :

  1. One click : open submenu with only "Simple plugin"
  2. Second click : open plugin settings

It's a WIP ?



markusfluer

markusfluer

2017-12-21 18:24

administrator   ~45372

This is to prevent cluttering of the main menu.
Also to have a graceful fallback for old plugins.

DenisChenu

DenisChenu

2017-12-21 18:41

developer   ~45373

« Also to have a graceful fallback for old plugins. » Usage of beforeSurveySettings / $event->set("surveysettings.{$this->id}", array( …… seems to be the CURRENT way to add plugin settings by survey.
Not old plugin.

When have a lot of settings : i already use tools menu, but it's not the documented way to do.

markusfluer

markusfluer

2017-12-21 18:46

administrator   ~45376

I will document the addition of menus to the system in the audit log plugin.
But I'm still bound in bugfixing.
Hopefully adding settings by event will be obsolete in the future

Issue History

Date Modified Username Field Change
2017-10-30 12:27 DenisChenu New Issue
2017-10-30 12:27 DenisChenu File Added: Capture du 2017-10-30 12-23-57.png
2017-10-30 12:29 DenisChenu Note Added: 44898
2017-11-01 18:58 LouisGac Note Added: 44925
2017-11-03 12:12 markusfluer Note Added: 44949
2017-11-03 12:12 markusfluer Assigned To => markusfluer
2017-11-03 12:12 markusfluer Status new => resolved
2017-11-03 12:12 markusfluer Resolution open => fixed
2017-11-03 12:12 markusfluer Fixed in Version => 3.0.0-rc.x
2017-11-03 12:12 markusfluer Status resolved => closed
2017-11-03 12:22 DenisChenu Status closed => feedback
2017-11-03 12:22 DenisChenu Resolution fixed => reopened
2017-11-03 12:22 DenisChenu Note Added: 44951
2017-11-03 12:24 DenisChenu File Added: Capture du 2017-11-03 12-21-55.png
2017-11-03 12:24 DenisChenu Note Added: 44952
2017-11-03 12:24 DenisChenu Status feedback => assigned
2017-11-03 12:32 markusfluer Note Added: 44954
2017-11-23 10:56 markusfluer Relationship added related to 12536
2017-12-20 18:11 DenisChenu File Added: Capture du 2017-12-20 18-10-41.png
2017-12-20 18:11 DenisChenu Note Added: 45350
2017-12-21 18:24 markusfluer Note Added: 45372
2017-12-21 18:41 DenisChenu Note Added: 45373
2017-12-21 18:46 markusfluer Note Added: 45376