View Issue Details

IDProjectCategoryView StatusLast Update
12819Development Otherpublic2017-10-25 16:02
ReporterLouisGac Assigned Tomarkusfluer  
PrioritynoneSeveritycrash 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version3.x 
Summary12819: Blank page + json after login
Description

logout then loggin again, a blank page with json is shown
(see picture)

Steps To Reproduce
  1. Log in
  2. Start the tour until page 2
  3. Log out
  4. Log in
Additional Information

{"tutorial":{"name":"firstStartTour","steps":[{"element":"#lime-logo","orphan":true,"backdrop":true,"path":"\/index.php?r=admin\/index","title":"Welcome to LimeSurvey!","placement":"bottom","content":"This tour will help you get a hold of LimeSurvey.<br\/>
We would like to help you with a quick tour of the most essential functions and features","redirect":false},{"element":".selectorlstour--mainfunctionboxes","path":"\/index.php?r=admin\/index","title":"The basic functions","content":"The three top boxes are the most basic functions of LimeSurvey. <br\/>
From left to right it should be 'Create survey', 'List surveys' and 'Global settings'. Best we start by creating a survey.
<p class=\"alert bg-warning\">Click on Create survey or Next in this box.<\/p>","reflex":".selector
lstour--createsurvey","redirect":false},{"element":"#surveyls_title","path":"\/index.php?r=admin\/survey\/sa\/newsurvey","title":"The survey title","content":"This is the title of your survey. <br\/>
Your participants will see this title as well in the browser's title bar, as also on the welcome screen.
<p class='bg-warning alert'>You have to put in at least a title for the survey to be saved.<\/p>","redirect":true},{"element":"#cke_description","path":"\/index.php?r=admin\/survey\/sa\/newsurvey","title":"The survey description","placement":"top","content":"This is the description of the survey.<br\/>
Your participants will see this at first on their welcome screen.
Try to describe what your survey is about, but don't ask any question just yet.","redirect":false},{"element":".bootstrap-switch-id-createsample","path":"\/index.php?r=admin\/survey\/sa\/newsurvey","title":"Create a sample question and question group","content":"In this tutorial we will be creating a question group and a question, so no need to automatically create it.","redirect":false},{"element":"#cke_welcome","path":"\/index.php?r=admin\/survey\/sa\/newsurvey","title":"The welcome message","placement":"top","content":"This message is shown directly under the survey description on the welcome page.
You may leave this blank and concentrate on a good text for your description, or vice versa.","redirect":false},{"element":"#cke_endtext","path":"\/index.php?r=admin\/survey\/sa\/newsurvey","title":"The end message","placement":"top","content":"This message is shown at the end of your survey to every participant.
It's a great way to say thank you or give some links or hints where to go next.","redirect":false},{"element":"#save-form-button","path":"\/index.php?r=admin\/survey\/sa\/newsurvey","title":"Now save sour survey","placement":"bottom","content":"You may play around with more settings, or edit your survey now. Just click on save.","reflex":true,"redirect":false,"onNext":"(function(tour){\n $('#save-form-button').trigger('click');\n return Promise.resolve(tour);\n })"},{"element":"#sidebar","path":["\/index.php?r=admin\/survey\/sa\/view&surveyid=%5B0-9%5D%7B4%2C25%7D"],"placement":"right","title":"The sidebar","content":"This is the sidebar.<br\/>
All important settings can be reached in this sidebar.<br\/>
You may resize it to fit your screen, or largen it to better control your survey structure.
It may be collapsed to show the quick-menu.
To collapse it either click on the arrow button or resize it to the left.","redirect":false,"onShow":"(function(tour){\n return Promise.resolve(tour);\n })"},{"element":"#adminpanelsidebar--selectorSettingsButton","path":["\/index.php?r=admin\/survey\/sa\/view&surveyid=%5B0-9%5D%7B4%2C25%7D"],"placement":"bottom","title":"The settings tab with the survey menu","content":"This tab shows the survey settings.
Any setting to your survey is accessible in this menu.
If you want to know more about the settings, have a look at our manual.","redirect":false},{"element":"#surveybarid","path":["\/index.php?r=admin\/survey\/sa\/view&surveyid=%5B0-9%5D%7B4%2C25%7D"],"placement":"bottom","title":"The top bar","content":"This is the top bar.
This bar will change as you move through the functionalities.
In this view it contains the most important LimeSurvey functionalities like activating and previewing the survey","redirect":false},{"element":"#adminpanel
sidebar--selectorStructureButton","path":["\/index.php?r=admin\/survey\/sa\/view&surveyid=%5B0-9%5D%7B4%2C25%7D"],"placement":"bottom","title":"The survey structure","content":"This is the structure view of your survey. Here you can see all your question groups and questions.","redirect":false,"onShow":"(function(tour){\n $('#adminpanelsidebar--selectorStructureButton').trigger('click');\n return Promise.resolve(tour);\n })"},{"element":"#adminpanelsidebar--selectorCreateQuestionGroup","path":["\/index.php?r=admin\/survey\/sa\/view&surveyid=%5B0-9%5D%7B4%2C25%7D"],"placement":"right","title":"Let's add another question group","content":"What good would your survey be without questions?<br\/>
In LimeSurvey a survey is organized in question groups and questions. To begin creating questions we first need a question group.
<p class=\"alert bg-warning\">Click on the 'Add questiongroup' button<\/p>","reflex":true,"redirect":false,"onNext":"(function(tour){\n document.location.href = $('#adminpanel__sidebar--selectorCreateQuestionGroup').attr('href');\n return Promise.resolve(tour);\n })"},{"element":"#group_name_en","path":["\/index.php?r=admin\/questiongroups\/sa\/add&surveyid=%5B0-9%5D%7B4%2C25%7D"],"placement":"bottom","title":"Add the title to your question group","content":"The title will be visible to your participants and cannot be empty.
Question groups are important to logically divide your questions, also in the default setting your survey is shown question group-wise.","redirect":false},{"element":"label[for=description_en]","path":["\/index.php?r=admin\/questiongroups\/sa\/add&surveyid=%5B0-9%5D%7B4%2C25%7D"],"placement":"top","title":"A description for your question group","content":"This description is also visible to your participants.
You do not need to add a description to your question group, but sometimes it makes sense to add a little extra information for your participants.","redirect":false},{"element":"#randomization_group","path":["\/index.php?r=admin\/questiongroups\/sa\/add&surveyid=%5B0-9%5D%7B4%2C25%7D"],"placement":"left","title":"Advanced settings","content":"Best to leave them like they are.
If you want to know more about randomization and relevance settings, have a look at our manual.","redirect":false},{"element":"#save-and-new-question-button","path":["\/index.php?r=admin\/questiongroups\/sa\/add&surveyid=%5B0-9%5D%7B4%2C25%7D"],"placement":"bottom","title":"Save and add a new question","content":"Now when you are finished click on 'Save and add question'.<br\/>
This will directly add a question to the current question group.
<p class=\"alert bg-warning\">Now click on Save and add a new question<\/p>","reflex":true,"redirect":false,"onNext":"(function(tour){\n $('#save-and-new-question-button').trigger('click');\n return Promise.resolve(tour);\n })"},{"element":"#title","path":["\/index.php?r=admin\/survey\/sa\/view&surveyid=%5B0-9%5D%7B4%2C25%7D&gid=%5B0-9%5D%7B1%2C25%7D&qid=%5B0-9%5D%7B4%2C25%7D"],"placement":"top","title":"The title of your question","content":"This code is normally not shown to your participants, still it is necessary and has to be unique for the survey.<br\/>
This code is also the name of the variable that will be exported to SPSS or Excel.
<p class=\"alert bg-warning\">Please type in a code that consists only of letters and numbers, and doesn't start with a number.<\/p>","redirect":false},{"element":"#cke_question_en","path":["\/index.php?r=admin\/survey\/sa\/view&surveyid=%5B0-9%5D%7B4%2C25%7D&gid=%5B0-9%5D%7B1%2C25%7D&qid=%5B0-9%5D%7B4%2C25%7D"],"placement":"top","title":"The actual question text","content":"The content of this box is the actual question text shown to your participants.
It may be empty, but that is not recommended. You may use all the power of our WYSIWYG editor to make your question shine.","redirect":false},{"element":"#cke_help_en","path":["\/index.php?r=admin\/survey\/sa\/view&surveyid=%5B0-9%5D%7B4%2C25%7D&gid=%5B0-9%5D%7B1%2C25%7D&qid=%5B0-9%5D%7B4%2C25%7D"],"placement":"top","title":"An additional help text for your question","content":"You can add some additional help text to your question.
This may also be empty, then it will not be shown.","redirect":false},{"element":"#questionTypeContainer","path":["\/index.php?r=admin\/survey\/sa\/view&surveyid=%5B0-9%5D%7B4%2C25%7D&gid=%5B0-9%5D%7B1%2C25%7D&qid=%5B0-9%5D%7B4%2C25%7D"],"placement":"left","title":"Set your question type.","content":"LimeSurvey offers you a lot of different question types.<br\/>
The example question created for you as well as the default setting is the'Long free text'-type.<br\/>
This type will create a big text input for your participants.
<p class=\"alert bg-warning\">Please select the 'Array'-type.<\/p>","redirect":false},{"element":"#save-button","path":["\/index.php?r=admin\/survey\/sa\/view&surveyid=%5B0-9%5D%7B4%2C25%7D&gid=%5B0-9%5D%7B1%2C25%7D&qid=%5B0-9%5D%7B4%2C25%7D"],"placement":"left","title":"Now save the created question","content":"Next we will create subquestions and answer options.<br\/>
Please be sure the question has a legal title with only letters and numbers starting with a letter.","reflex":true,"redirect":false,"onNext":"(function(tour){\n $('#save-button').trigger('click');\n return Promise.resolve(tour);\n })"},{"element":"#questionbarid","path":["\/index.php?r=admin\/survey\/sa\/view&surveyid=%5B0-9%5D%7B4%2C25%7D&gid=%5B0-9%5D%7B1%2C25%7D&qid=%5B0-9%5D%7B4%2C25%7D"],"placement":"bottom","title":"The question bar","content":"This is the question bar.
The most important option here is the edit button.
Also important are the preview buttons, which we will show in one of the next steps.","redirect":false},{"element":"#adminpaneltopbar--selectorAddSubquestions","placement":"bottom","path":["\/index.php?r=admin\/survey\/sa\/view&surveyid=%5B0-9%5D%7B4%2C25%7D&gid=%5B0-9%5D%7B1%2C25%7D&qid=%5B0-9%5D%7B4%2C25%7D"],"title":"Add some subquestions to your question","content":"The array question is a type that creates a matrix for the participant.<br\/>
To fully use it you have to add subquestions as well as answer options.<br\/>
Let's start with subquestions.
<p class=\"alert bg-warning\">Click on the 'Edit subquestions' button.<\/p>","reflex":true,"redirect":false,"onNext":"(function(tour){\n document.location.href = $('#adminpanel
topbar--selectorAddSubquestions').attr('href');\n return Promise.resolve(tour);\n })"},{"element":"#rowcontainer","path":["\/index.php?r=admin\/questions\/sa\/subquestions\/surveyid\/[0-9]{4,25}\/gid\/[0-9]{1,25}\/qid\/[0-9]{4,25}"],"placement":"bottom","title":"Edit subquestions","content":"Here you may add some subquestions for your question.<br\/>
Every row is one subquestion. It's best practice to use logical or numerical codes for the subquestions.
Your participants cannot see the subquestion code, only the subquestion text itself.
<p class='bg-info alert'>Pro tip: the subquestion may contain HTML code if you are logged in with admin mode.<\/p>","redirect":false},{"element":"#rowcontainer>tr:first-of-type .btnaddanswer","path":["\/index.php?r=admin\/questions\/sa\/subquestions\/surveyid\/[0-9]{4,25}\/gid\/[0-9]{1,25}\/qid\/[0-9]{4,25}"],"placement":"left","title":"Add subquestion row","content":"Click on the plus sign to add another subquestion to your question.
<p class='bg-warning alert'>Please add at least two subquestions<\/p>","redirect":false},{"element":"#save-button","path":["\/index.php?r=admin\/questions\/sa\/subquestions\/surveyid\/[0-9]{4,25}\/gid\/[0-9]{1,25}\/qid\/[0-9]{4,25}"],"placement":"left","title":"Now save the subquestions","content":"You may save empty subquestions, but that would useless.
<p class='bg-warning alert'>Save now and let's edit the answer options.<\/p>","reflex":true,"redirect":false,"onNext":"(function(tour){\n $('#save-button').trigger('click');\n return Promise.resolve(tour);\n })"},{"element":"#adminpaneltopbar--selectorAddAnswerOptions","path":["\/index.php?r=admin\/survey\/sa\/view&surveyid=%5B0-9%5D%7B4%2C25%7D&gid=%5B0-9%5D%7B1%2C25%7D&qid=%5B0-9%5D%7B4%2C25%7D"],"placement":"bottom","title":"Add some answer options to your question","content":"Now that we've got some subquestions, we have to add answer options as well<br\/>
The answer options will define the values that represent your subquestions.
<p class=\"alert bg-warning\">Click on the 'Edit subquestions' button.<\/p>","reflex":true,"redirect":false,"onNext":"(function(tour){\n document.location.href = $('#adminpanel
topbar--selectorAddAnswerOptions').attr('href');\n return Promise.resolve(tour);\n })"},{"element":"#rowcontainer","path":["\/index.php?r=admin\/questions\/sa\/answeroptions\/surveyid\/[0-9]{4,25}\/gid\/[0-9]{1,25}\/qid\/[0-9]{4,25}"],"placement":"bottom","title":"Edit answer options","content":"As you can see answer options and subquestions really don't differ much.
<p class=\"alert bg-warning\">Please add at least two answer options to proceed.","redirect":false},{"element":"#save-button","path":["\/index.php?r=admin\/questions\/sa\/answeroptions\/surveyid\/[0-9]{4,25}\/gid\/[0-9]{1,25}\/qid\/[0-9]{4,25}"],"placement":"left","title":"Now save the answer options","content":"Click on save or next to proceed","reflex":true,"redirect":false,"onNext":"(function(tour){\n $('#save-button').trigger('click');\n return Promise.resolve(tour);\n })"},{"element":".selectortopbar--previewSurvey","path":["\/index.php?r=admin\/survey\/sa\/view&surveyid=%5B0-9%5D%7B4%2C25%7D&gid=%5B0-9%5D%7B1%2C25%7D&qid=%5B0-9%5D%7B4%2C25%7D"],"placement":"bottom","title":"Preview survey","content":"Now is the time to preview your first survey.<br\/>
Just click on this button and a new window will open, where you can test run your survey.<br\/>
Please be aware that your answers will not be saved, because the survey isn't active yet.
<p class=\"alert bg-warning\">Click on 'Preview survey' and return to this window when you are done testing.<\/p>","redirect":false},{"element":"#breadcrumb-container","path":["\/index.php?r=admin\/survey\/sa\/view&surveyid=%5B0-9%5D%7B4%2C25%7D&gid=%5B0-9%5D%7B1%2C25%7D&qid=%5B0-9%5D%7B4%2C25%7D"],"placement":"bottom","title":"Easy navigation with the "breadcrumbs"","content":"In the top bar of the admin interface you see the "breadcrumbs".<br\/>
These will always be an easy way to get back to any previous setting.
<p class=\"alert bg-warning\">Click on the name of your survey to get back to the survey settings overview.<\/p>","reflex":"#breadcrumb
survey--overview","redirect":false,"onNext":"(function(tour){\n document.location.href = $('#breadcrumbsurvey--overview').attr('href');\n return Promise.resolve(tour);\n })"},{"element":"#ls-activate-survey","path":["\/index.php?r=admin\/survey\/sa\/view&surveyid=%5B0-9%5D%7B4%2C25%7D"],"placement":"bottom","title":"Finally, activate your survey","content":"Now activate this simple survey.<br\/>
You can have as many surveys as you like.
<p class=\"alert bg-warning\">Click on 'Activate this survey'<\/p>","reflex":true,"redirect":false,"onNext":"(function(tour){\n document.location.href = $('#ls-activate-survey').attr('href');\n return Promise.resolve(tour);\n })"},{"element":"#activateSurvey
basicSettings--proceed","path":["\/index.php?r=admin\/survey\/sa\/activate&surveyid=%5B0-9%5D%7B4%2C25%7D"],"placement":"bottom","title":"Activation settings","content":"These settings cannot be changed once the survey is online.<br\/>
For this simple survey the default settings are ok, but read the disclaimer carefully when you activate your own surveys.<br\/>
For more information consult or manual, or our forum.
<p class=\"alert bg-warning\">Now click on "Save & activate survey"<\/p>","reflex":true,"redirect":false,"onNext":"(function(tour){\n $('#activateSurveybasicSettings--proceed').trigger('click');\n return Promise.resolve(tour);\n })"},{"element":"#activateTokenTableselector--no","path":["\/index.php?r=admin\/survey\/sa\/activate&surveyid=%5B0-9%5D%7B4%2C25%7D"],"placement":"bottom","title":"Activate token table","content":"Here you can select to start your survey in closed access mode.<br\/>
For our simple survey it is better to start in open access mode.<br\/>
The closed access mode needs a participant list, which you may create by clicking on the menu entry 'Participant tokens'.<br\/>
For more information please consult our manual or our forum.
<p class=\"alert bg-warning\">Click on 'No, thanks'<\/p>","reflex":true,"redirect":false,"onNext":"(function(tour){\n $('#activateTokenTableselector--no').trigger('click');\n return Promise.resolve(tour);\n })"},{"element":"#adminpanelsurveysummary--mainLanguageLink","path":"\/index.php","placement":"top","title":"Share this link","content":"Just share this link with some of your friends and of course, test it yourself.
<p class=\"alert bg-success lstutorialtypography--white\">Thank you for taking the tour!<\/p>","redirect":false}],"debug":true,"orphan":true,"keyboard":false,"template":"<div class='popover tour lstutorialtemplate--mainContainer'> <div class='arrow'><\/div> <h3 class='popover-title lstutorialtemplate--title'><\/h3> <div class='popover-content lstutorialtemplate--content'><\/div> <div class='popover-navigation lstutorial__template--navigation'> <div class='btn-group col-xs-8' role='group' aria-label='...'> <button class='btn btn-default col-xs-6' data-role='prev'>\u00ab Prev<\/button> <button class='btn btn-primary col-xs-6' data-role='next'>Next \u00bb<\/button> <\/div> <div class='col-xs-4'> <button class='btn btn-warning' data-role='end'>End tour<\/button> <\/div> <\/div><\/div>","onShown":"(function(tour){ console.log($('#notif-container').children()); $('#notif-container').children().remove(); })"}}

TagsNo tags attached.

Activities

LouisGac

LouisGac

2017-10-23 16:12

manager  

bug.png (624,183 bytes)
markusfluer

markusfluer

2017-10-24 14:27

administrator   ~44812

Fix committed to develop branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&amp;id=24238

Related Changesets

LimeSurvey: develop 3880d8b6

2017-10-24 14:27:36

markusfluer

Details Diff
Fixed issue 12819: Blank page + json after login Affected Issues
12819
mod - application/controllers/admin/TutorialsController.php Diff File
mod - application/models/Tutorials.php Diff File
mod - assets/packages/lstutorial/build/lstutorial.js Diff File
mod - assets/packages/lstutorial/build/lstutorial.js.map Diff File
mod - assets/packages/lstutorial/build/lstutorial.min.js Diff File
mod - assets/packages/lstutorial/src/tours/global-tour-object.js Diff File

Issue History

Date Modified Username Field Change
2017-10-23 16:12 LouisGac New Issue
2017-10-23 16:12 LouisGac File Added: bug.png
2017-10-23 16:36 LouisGac Steps to Reproduce Updated View Revisions
2017-10-23 16:36 LouisGac Additional Information Updated View Revisions
2017-10-24 11:05 LouisGac Assigned To => markusfluer
2017-10-24 11:05 LouisGac Status new => assigned
2017-10-24 14:27 markusfluer Changeset attached => LimeSurvey develop 3880d8b6
2017-10-24 14:27 markusfluer Note Added: 44812
2017-10-24 14:27 markusfluer Resolution open => fixed
2017-10-24 14:27 markusfluer Status assigned => resolved
2017-10-24 14:27 markusfluer Fixed in Version => 3.x
2017-10-25 16:02 LouisGac Status resolved => closed